AniLaPaint (1.2.5.12) 最終β版 取扱説明書

2001年 01月 13日 土曜日 更新

AniLaPaint (1.2.5.12) 最終β版 取扱説明書

AniLaPaint起動中に、「 選択した場所の説明 クリックした部分の説明」を利用することで、この取扱説明書の必要なページを簡単に検索することができます。

皆様、AniLaPaint をダウンロードいただき、β版のテストに参加していただき大変感謝しております。

前バージョンのダウンロード件数は以下のとおりでした。

リクエスト数 | ファイル
384 | AniLaPaint12511.msi
60 | AniLaPaint12511up.msi
41 | AniLaRegClear1202.msi
8 | AniLaPaint12511a.lzh
解析：2001年 1月12日(金) 02時22分

1.2.5.11でアンケートを送信してくださった４名の方、ありがとうございました。
他の方もよろしくお願いいたします。「とりあえず、異常なし」なのかどうかだけでも・・・。

現在は最終β版なので、機能追加をストップし、バグフィックスと安定動作のみを追及しています。
安定動作に必要な機能追加は今後ともあります。この点で、何か良いアイデアなどがあれば取り上げていきたいと思っています。
それ以外の機能追加は正式版発表後までお待ちください。

この取扱説明書に使われている絵は全て自分で書いたものですが、正式版発表時にはすべて AniLaPaint オリジナルキャラクタに変更したいと思っています。まだ、チュートリアルや応用編などを作成したいと思います。

第１章 はじめにお読みください

ここでは、AniLaPaint を使用する前に知っておく必要がある項目についてまとめました。必ずお読みくださるようお願い申し上げます。

第２章　入門編

ここでは、はじめて AniLaPaint を使用する方が、基本的な仕様を理解し、操作手順をマスターするためのチュートリアルを掲載しています。

第３章　応用編

ここでは、さらに AniLaPaint を理解するために、すこし踏み込んだ操作手順を掲載しています。

第４章 画面の各部の説明

ここでは、画面の各部分を説明します。

第５章 よくある質問(FAQ)

ここでは、今までに受けた質問をもとに、ＦＡＱをまとめました。

第６章 バージョンアップによる変更点

ここでは、現在に至るまでのAniLaPaintのバージョンアップによる変更点を掲示しています。

第７章 その他

ここでは、その他の事項に付いて説明します。


第１章 はじめにお読みください

ホーム>>

第１章 はじめにお読みください

ここでは、AniLaPaint を使用する前に知っておく必要がある項目についてまとめました。必ずお読みくださるようお願い申し上げます。

このたびは、AniLaPaintをダウンロードしてください、まことにありがとうございます。ここに、このソフトを使用する上で最初に知っておかなくてはならない事項についてまとめてみましたので、一読くださるようお願い申し上げます。

このソフトの用途

ここでは、このソフトの用途について簡単に説明します。

動作環境

ここでは、AniLaPaint をお使いいただけるパソコンの動作環境について説明します。

AniLaPaintの状態を保存する場所について

ここでは、AniLaPaintの状態を保存する場所について説明します。

バージョン番号について

ここでは、AniLaPaintのバージョン番号の表記方法について説明します。

免責事項

ここでは、免責事項を述べさせていただきます。

制限事項

ここでは、AniLaPaint を利用する上での制限事項について説明します。

ライセンス取得方法

ここでは、AniLaPaint を使いつづけることのできるライセンスを取得する方法を説明します。

ユーザサポート

ここでは、作者のユーザサポートに対しての考え方と取り組みを説明します。

取扱説明書の表示方法

ここでは、AniLaPaintの取扱説明書（この画面）を表示する方法について説明します。

アンケートのお願い

ここでは、試用後のアンケートおよび要望などを送信フォームにて受け付けています。

アンインストールの方法

ここでは、AniLaPaint のアンインストールの方法について説明します。

初めてお使いになられる方は、引き続き第２章 入門編をご覧くださるようお願い申し上げます。


このソフトの用途

ここでは、このソフトの用途について簡単に説明します。

セルアニメーション作画方法に最適化されたペイントソフト

セルアニメーションは次の過程を経て制作されます。
シナリオ→絵コンテ→レイアウト→原画→ 動画→仕上げ（彩色） →撮影（ムービー化）→TV出力
背景原図→背景

このソフトは、仕上げ（彩色）部門のみを担当するためのソフトです。
従来のフィルムを使ったセルアニメーション制作体制のまま、仕上げ以降をコンピュータ処理で行うためのソフトです。そのため、動画までの作業は全て紙上で行います。撮影以降は、ホビーユーザ向けには「ぜんまいハウス」のAnimeStudioⅡ、プロユーザ向けには「CELSYS」のCoreRETASなどがあります。また、AdobePremiereでムービー化することも可能です。

仕上げ対象になる動画は、セルアニメーション作画方法で紙に描かれていなくてはなりません。

セルアニメーションの作画方法で書かれた従来の動画を、スキャナで取り込んで、一般的なペイントソフトで彩色するのはあまりに効率が悪いといえます。実線のマスキング処理や、色トレス線の消去、スキャンノイズの消去など、全て１枚1枚手作業で行わなくてはならないからです。

このソフトは、そういった決まりきった処理をコンピュータの力を借りることで効率よく作業できるようになります。実線の分離合成、スキャンノイズの自動消去、色トレス線の自動マスキング、色トレス線の自動彩色、塗り残しのドット穴の自動彩色、アニメーション表示による塗り間違い（色パカ）のチェックなど、セルアニメーションの作画方法で描かれた動画を彩色するために、速く沢山仕上げられることを主眼としております。

出力ファイルにはホームページにも貼り付けることができるPNG形式もあります。また、αチャンネルに対応した出力ができるので、ペイントソフトのレイア素材としても流用できます。
マウスやタブレットで絵を書くのが苦手な方にとっても、紙に書いた絵に色を塗るソフトなので、実は使い道は他にもあると思います。

処理の流れ

貴方がセルアニメーション作画方法で描き
スキャナなどで取り込んだ線画
↓
インポート
↓
実線画像
↓
ゴミなどを取り除く
↓ 		彩色画像
↓
色を塗る
↓
ビルド
↓
セル画像
↓ 		マスク画像
↓

エクスポート
↓

汎用画像ファイル
↓
他のソフト
AnimeStudioII,
PhotoShop,
etc...

■の部分がAniLaPaintで処理する部分です。

より詳しい説明は、第２章 入門編をご覧ください。


動作環境について

動作環境

ここでは、AniLaPaint をお使いいただけるパソコンの動作環境について説明します。

必要なハードウェアについて

Pentium 200MHｚ以上推奨 (Windows)
PowerPC G3 400MHz以上推奨 (MacOS + VirtualPC + Windows)

メモリ容量 実メモリ１２８ＭＢ以上＋ページングファイル２００MB以上 推奨

お手持ちのパソコンのメモリ容量を確認したりページングファイルのサイズを変更するには、マイコンピュータアイコンを右クリックして出てくるメニューでプロパティを選ぶと表示されるダイアログ上にあります。ページングファイルとは、Win95では「仮想メモリ」と呼ばれています。

必要なＯＳについて

次のいずれの OS でも動作する予定です。
（現在はβ版のため確認作業をしているOSは Windows2000 SP1 + IE5.5 SP1 のみです。）
Win95 と NT4.0 では、IE5（インターネットエクスプローラ）を 5以上にアップグレードしてください。
他のOSの場合は、IEをアップグレードしなくても動作します。

●Windows95系
Windows 95OSR1 + ＩＥ5 以上
Windows 95OSR2 + ＩＥ5 以上
Windows 98
Windows 98SE
Windows Me

●WindowsNT系
RISC版(MIPS/Alhpa/PowerPC)のWindowsNTには対応していません。
Windows NT4.0 + SP4以上 + IE5 以上
Windows2000
※SPとは「サービスパック」のこと。雑誌の付録や、ＭＳ社のホームページから入手可能です。

WindowsNT系では、管理者権限でインストールしてください。このソフトは、次世代のインストールファイル msi パッケージにて配布しております。このインストーラーでは、従来のインストーラと異なり、管理者が全てのユーザにアドバダイズするかどうかは、インストールの仕方により決まります。それらはOSのバージョンにも異なりますし、将来のOSの進化によってインストールできる場所や形態が、配布者が考えるものとは異なっていっても正常にインストールすることができるようになります。つまり、Windows の標準的なフォルダの配置の仕様が将来変化したとしても、このパッケージはそのままそのOSの仕様にあわせてインストールされることになります。

現在の方法は、管理者が全てのユーザにパッケージをアドバダイズする方法は以下のとおりです。コマンドプロンプトを使う以外の方法はありません。
msiexec /jm Example.msi

上記の Example のところが、アドバダイズしたい msi フィルの名となります。絶対パスで打ち込んでください。
具体的には、コマンドプロンプトを開いたら、 msiexec /jm までキーボードで打ち込み、あとは、msi ファイルをコマンドプロンプトへドラッグしてリターンキーを押してください。それでインストーラが立ち上がり、全てのユーザのメニューに AniLaPaint が登録されます。

※上記のことをダブルクリックだけで自動でやってくれるバッチファイルも配布しております。コマンドラインが苦手な方はそちらをどうぞ。

同時に配布している、レジストリ削除用ダミープラグの方は、この方法でユーザ全員にアドバダイズしないでください。ダミープラグは、ユーザ各自が普通にインストールしてください。（ダミープラグは、環境の初期化を AniLaPaint 内部に取り込んだ後に廃止いたします）

●エミュレータ系 (確認済)
PowerMacG3/G4 + MacOS + VirtualPC + 上記Windows (400MHzG3の場合Pentium100MHz相当)
エミュレータでの動作は保証していませんが、ユーザによって確認された環境のみここに提示しております。

必要なシステムファイルについて

MFC DLL ver4.0 ＆ ver6.0
LEADTOOLS ActiveX ver7.0j
フルセット版のインストーラではすべてインストールされます。
アップグレード版のインストーラには含まれておりません。

ＬＡＮによるネットワークについて

AniLaPaintは、UNCパスに対応しております。
したがって、ＬＡＮに繋がれた他のＷｉｎｄｏｗｓパソコンの共有フォルダにアクセスできます。（共有の条件がフルアクセスの時のみ対応しています）

注意事項

上記、動作環境を満たしている場合でも正常に動かない事があります。それは、今までの経験上、OSのバグや違いによる非互換な部分を使っていたために起こるようです。つまり、作者の環境では起こらないために、ほぼ間違いなく、報告しない限り永久に作者は気付きませんし、直りません。そして、報告すれば直ぐにでも直る場合がほとんどです。

誰かが既に報告しているか、あるいわ自分が報告する方法についてはユーザサポートで紹介しています。

今後、エミュレータ以外の全てのOSで動作テストを行い、正式版をリリースする予定です。
関連事項

[FAQ01] インストールしても起動しない
[FAQ02] 存在するフォルダにもかかわらず存在しないとメッセージがでる


AniLaPaintの状態を保存する場所について

ここでは、AniLaPaintの状態を保存する場所について説明します。

AniLaPaintは、ビューとクールバーを除く全てのウィンドウの位置やインポートやビルドなどの設定値や環境設定の状態を終了時に保存して、次回起動時にその状態に復帰します。そのため、前回の状態を保存する場所が必要になります。

Windows にはそのために用意された方法が２つあります。１つは INI ファイルに保存する方法。もう１つはレジストリに保存する方法です。

レジストリは、Windows95 から使われ始めた方法で、より高速に情報を扱うことができるようになりました。ただし、Windows9x 系では、OS 自体にバグともいえる仕様的欠陥があり、ソフトを沢山インストール＆アンインストールを繰り返すとレジストリが肥大化し、OS自身が読める限界を超えてしまい Windows 自体が必ず壊れます。したがって、Windows9x 系の場合は少なくとも１年に１回はフォーマットからOSを入れなおすクリーンインストールがどうしても必要になってしまいます。もっとも、入れるソフトが限られている場合は長持ちします。

INI ファイルは、 Windows3.1 の頃から使われていた方法で互換性のために今も OS に残っている機能です。Windows9x 系の場合は、ソフトが起動している間OS自体がINIファイルを一時的にレジストリにマッピングして処理しているのでINIファイルでも高速に動作します。しかし、WindowsNT4/2000では、そのような仕組みがOSに無いので、INIファイルを使用すると極端にアプリケーションが遅くなります。

●初回起動時での設定について

このような事を前提にし、AniLaPaint では、初回起動時に、このどちらへ保存するかをユーザ各自が選択することが可能となっています。
また、初回起動時に限らず、メニューやショートカットから起動する際に Shift キーを押していると同様のダイアログが表示されます。
idd_reg_init.png (11124 バイト)
この画面で、INIファイルかレジストリかを選択してください。
また、ソフトに異常が発生したら、INIファイルやレジストリを出荷時の状態に戻す・・・つまり、情報を削除するボタンをお使いください。

●アンインストール時の注意点について

AniLaPaint は、アンインストール時に、INIファイルおよびレジストリに書き込まれた情報を削除しません。そのため、バージョンアップのために一旦アンインストールし、新しいバージョンをインストールしても、ver1.2.x.x であれば常に上位互換で前回の状態が保存されたままになります。
しかし、今後使わない場合など、削除が必要な場合はあらかじめこの機能を使い手動で削除する必要があります。
INIファイル・レジストリを両方とも[出荷時の状態に戻す]ボタンを押してこの両方のボタンがイネーブル状態になったら、[中止]ボタンを押して終了してください。
ここで[起動する]ボタンを押してしまうと、起動した瞬間に新規の状態が保存されてしまいますのでご注意ください。


バージョン番号について

ここでは、AniLaPaintのバージョン番号の表記方法について説明します。

AniLaPaint のバージョン番号を調べるには、次の２つの方法があります。

  1. エクスプローラから、AniLaPaint.EXE ファイルを選択して、右クリックメニューからプロパティを選択する。
  2. AniLaPaint を起動して、AniLaPaintのバージョン情報コマンドを実行する。

これらを実行した結果、４つの数字の列を得ることができます。

例えば、このバージョンは、1.2.5.12 です。

この数値の意味は次のとおりです。

１番目の数
ライセンス単位を示します。この数値が同じ場合、新たにライセンスを取得する必要なくバージョンアップされたソフトをインストールして使うことができます。
２番目の数
ソフトに仕様の変更があった場合に１加算されます。
３番目の数
ソフトに機能の追加があった場合に開発単位毎に1ないし2加算されます。奇数の場合は開発版で、偶数の場合は安定版です。つまり、この値は安定版だけ使う場合は、バージョンアップの際に2ずつ上がっていくことになります。
ソフトの仕様に変更があった場合には２番目の数が１上がり、この数は1に戻ります。開発版は新しい機能のテストをユーザの方にしてもらうために公開するものです。実用で使う場合は、安定版を使うほうが無難です。
４番目の数
機能が変わらないが、バグのフィックスをした場合１加算されます。バグのフィックスと共に機能も追加された場合３番目の数が上がり、この数は０に戻ります。


免責について

免責事項

ここでは、免責事項を述べさせていただきます。

AniLaPaint を利用したこと、又は利用できなかったこと、もしくは AniLaPaint の瑕疵によりユーザが損害を被った場合やデータが失われた場合でも、作者は一切の責任を免れることとさせて頂きますので、ご承知の程宜しくお願い致します。

以上の免責事項に対して御同意いただけない場合は、AniLaPaint を起動してはいけません。


制限事項

ここでは、AniLaPaint ver1.2 最終β版での制限事項について説明します。

AniLaPaintはシェアウェアです。利用するにはライセンスを取得する必要があります。

しかし、まだ Windows2000SP1 + IE5.5SP1 以外のOSでの動作テストが終わっていません。また、この取扱説明書も完成しておりません。

そのため、現在は、ユーザ様に試用してもらう事と、不具合の報告を頂くことを目的に、フリーソフトとして公開しています。

このバージョンは、ユーザ様を信じ、試用期間や機能制限などは一切なくしました。

ただし、正式版が売れずに、このバージョンがいつまでも使われるような状況になると、開発自体が続けられなくなります。
したがって、以下の制限事項を設けることといたしました。必ず守ってご試用ください。

  • 雑誌やパソコン通信BBSやCDなど、作者以外による転載や再配布を禁止します。

  • 1.2.6.0以上のバージョン（正式版）が作者ホームページでリリースされた後１ヶ月以上を経過し、このバージョンを使用しつづけることを禁止します。毎月１回程度は、作者ホームページをチェックしてください。

  • 上記項目に違反している場合、このバージョンを利用して彩色したデータの利用や販売は禁止します。

正式版が出たら、ぜひ買っていただけると助かります(^^;)。


ライセンス・キー登録について

ライセンス取得方法

まだβ版なので、ライセンスは取得できません。以下は正式版発表後に予定しているライセンスの形態です。

ライセンスとは？

ここでいうライセンスとは、利用者（個人・企業・法人・サークルなど）が AniLaPaint をコンピュータの記憶媒体に所持し、実行できる権利のことです。ユーザは、２ヶ月の試用の後、このソフトを使いつづけるには、ライセンス料を作者へ支払い、パスワードを発行してもらう必要があります。

ライセンス料

ライセンス料は、インストールするコンピュータ１台あたり１５００円です。
ライセンス料は現在は、ソフト開発費の分担という位置付けです。今までの開発実費として払うもので、未来の開発の持続を保証するものではありません。しかし、これからも開発を持続するために必要な運転資金となるでしょう。

開発費の分担

開発費は、作者がソフトウェアを制作するために必要な経費を指します。現在のところハードウェア代やOS代や人件費は含めていません。AdobePremiere5.1やAnimeStudioIIやスキャナーやPhotoShopLEなどもテスト環境にも必要で購入しましたが自分の創作活動にも使えるものなので含めていません。ここでいう経費はあくまで開発をしなかったら発生し得ない費用のことをいいます。

内訳を公開した方がよいという指摘をいただきましたので、公開していくことにします。

開発関連のソフト代は、約24万です。

コンパイラ (Delphi2/Visual C++ ver4 Std/Visual C++ ver 6 Pro) 約10万
ライブラリー(ImageKit4 OCX/LEADTOOLS ver7.0 Pro) 約12万
ツール(リッチテキスト・ヘルプ・エディタ/FrontPage98/HTML Help for VisualStudio/MakeSet/小次郎）約2万
※Delphi2/VC4/ImageKit4/リッチテキスト・ヘルプエディタ/MakeSetは途中のバージョンまで使用していました。
書籍代は、約10万程度です。(3段のカラーボックスからはみ出すくらいの量です。ほとんど読破。作り始める前に勉強段階で購入したものです。カーニハン・リッチーのC言語という本からスタートしました。情報をインターネットで仕入れるようになってからは増えていません。)
通信費（電話＋プロバイダ）が、最初の２年半は月々2万平均で、約60万、CATVにしてから１年半で工事費が３万５千円と月々６５００円で約15万、合計約75万です。
他にホームページを置かせてもらっているAAAに今まで6万円の寄付をしています。
このように経費として一般的に認められる金額でも100万を超えています。
仮に、人件費を考えるなら、今まで6000時間（ソフトを思いついてからの勉強期間の２年間の時間は含まず、あくまでコーディングだけの時間)を要していますので、このソフトで時給1000円以上の利益を出すにはいったいいくつ売れたらよいのでしょうか？4000個以上ですね・・・。そんなにアマチュア活動でアニメを作っている人すら居ない現状で、この個数は絶対無理なのは誰にでもわかります。予測としては１年間で50個程度であると私は考えています。
このソフトの作りがしっかりしているのは、最初からお金をかけてシェアウェアで出すことを念頭に開発をはじめたからです。例えば、使用しているLEADTOOLSというライブラリーは、FrontPageやPicturePublisherにも使われているライブラリーです。いわば企業向けのライセンスを個人で買って使っているようなものです。実は、私のコーディングよりそっちの方の処理が優秀なのでかなり助かっています。私は本職がアニメータ(原画)なので、アイデアだけはプロの視点から山ほどあるのですが、ファイルフォーマットの知識など基礎技術的なことは無知ですし、自分が使える時間が少ないという状況で、いかにしてソフトを開発するかを考えるとこのアプローチしかありませんでした。ただしお金が無くてLEADTOOLSはver7のままですが、動かないと思われていたWindows2000の上位互換性も優れており、大変助かっております。7のバグはいくつかありましたが、そこをコールしないようにコーディングしています。
ともかく、このソフトは、「作りたいから作る」「作れる方法で作る」というアプローチで作っているので、何ら利益が出なくても、この気持ちが維持できる限りは続けていきたいと思っています。ただし、上記の経費を見ればわかるように、最もお金がかかる部分が、いわゆるIT投資の部分というわけです。だから、結局のところ、ライセンス料を一番あてにしている部分は、当面の月々の通信費用の維持というわけです。前述の年間50個売れた場合がちょうど全額通信コストにあてられます。

ただし、2001年の１年間の売上を見て、その後のインターネット上での活動の是非は再検討するつもりです。年間50個を下回るようでしたら、2002年からはシェアウェアとしての販売をやめて通販のみという形にするなど通信コストの削減に努めて開発自体は継続できるようにしたいと考えております。

ライセンスの形態

コンピュータ１台あたり１ライセンスの取得が必要です。
このライセンスは、バージョン (1.x.x.x) で有効ですが、将来の (2.x.x.x) では新たにライセンスを取得する必要があります。

※バージョン (2.x.x.x) を作るつもりは現在のところありません。ライセンスのバージョンが異なるということは、ソース全体を書き直すほどの改良を加えた場合です。現在それほどの時間的余裕は作者にありません。

ライセンス取得後のサポートについて

ライセンス料は、経費の実費でありサポート料が含まれているわけではありません。しかし、ライセンス取得前・後にかかわらず、無償のユーザサポートを行っております。詳しくは「ユーザサポート」をご覧ください。

ライセンスの解約（返金）は？

一旦ライセンスを取得した後の解約および返金はできません。
試用期間をフルに活用して、貴方のコンピュータと相性が良い事を十分確認した上で、送金してくださるようお願い申し上げます。

その他の注意点

ライセンスを取得して得たパスワードは、決して他人に教えないでください。パスワードを故意に他人に教えたり公開したりした場合、著作権侵害にあたります。(パスワードが著作管理情報にあたるため刑事罰が課せられます。）

送金方法

上項目を全て了承していただけた場合は、送金方法へ進んでください。


サポートについて

ユーザサポート

ここでは、作者のユーザサポートに対しての考え方と取り組みを説明します。

ユーザサポートについての考え方

作者は、あくまで健康と知能とお金が続く限り、本職の仕事に支障が出ない範囲内で、１９９８年以来サポートおよびバージョンアップを続けています。これからも持続していきたいと思います。

ユーザサポートのURL

ユーザサポートについては、以下の URL で行っております。
今までに発見された問題点の参照から、掲示板による些細な質問まで、お気軽にご利用ください。
http://members.jcom.home.ne.jp/anilapaint/support/

また作者へ直接連絡を取る方法については、「作者への連絡方法」をご覧下さい。


取扱説明書の表示方法

ここでは、AniLaPaintの取扱説明書（この画面）を表示する方法について説明します。

取扱説明書だけを表示する方法

スタートメニューのプログラムの下の AniLaPaint 1.2 の下に、取扱説明書のメニュー項目ができます。これを選択する事で、この取扱説明書をいつでも表示させる事ができます。

AniLaPaint 起動後に取扱説明書を表示する方法

スタートメニューのプログラムの下の AniLaPaint 1.2 の下に、AniLaPaint のメニュー項目ができます。これを選択する事で、AniLaPaint を起動できます。その後、次の３つの方法でこの取扱説明書をいつでも表示させる事ができます。
  1. AniLaPaint のメニューから「ヘルプメニュー→目次」を選択する。

    取扱説明書の表紙ページが表示されます。

  2. F1キーを押す。または、ヘルプボタンを押す。

    マウスカーソルを調べたいボタンやウィンドウへ置いて[F1]キーを押すことで、その部分の説明が表示されます。

    また、ダイアログ表示の場合に[F1]キーを押すと、そのダイアログの説明が表示されます。この場合はダイアログに配置されているヘルプボタンを押しても同じことです。

  3. AniLaPaint のメニューから「ヘルプメニュー→クリックした場所の説明」を選択する。または、 クリックした場所の説明 ボタン、または、[Shift + F1]キーを押す

    マウスカーソルが？付の矢印カーソルになります。そのカーソルで、調べたいボタンやメニューなどをクリックすると、その部分の説明が表示されます。


アンケートのお願い

皆様からのアンケートを受け付けています。
何度でもお願いしたいくらいです。

インターネットに接続できる環境さえあれば、メールアドレスは必要ありません。
作者は、送信した人を特定できませんので、完全な匿名の送信となります。
そのため、作者からの返信ができません。

作者の返答が必要な内容に付いては、作者宛てにメールでお願いいたします。

●タイトルです。
（そのままで構いません。特に注目して欲しい内容の場合のみ変えてください）

※タイトルは確認画面で表示されません！

●送信者名（ハンドルやペンネーム、匿名希望でも構いません）

●性別
男　女

●所属
小学生　中学生　高校生　大学生
専門学校生　社会人

●AniLaPaintをどういった用途で使いますか？
（あてはまるものを複数せんたくしてね）
仕事で使う
趣味で使う
アニメ制作（TV出力用）
アニメ制作（Gifアニメ用とかムービーファイル用）
１枚絵の素材として

●AniLaPaintを走らせているOSを選択してください。
（IEの場合Ctrlキーを押しながらマウスの左クリックで複数選択可）

●AniLaPaintの最初に使ったバージョンはどれですか？（覚えている近いもの）

●このバージョン1.2.5.12を使い始めてどのくらいたちましたか？（近いものを選択してください）

●このバージョン1.2.5.12で一般保護違反が起きましたか？

●一般保護違反が起きたという方、どんな時に起きましたか？（覚えている範囲で）

●このバージョン1.2.5.12で、Windows９ｘ系のブルースクリーン状態に落ちたりしましたか？
それはどんな時ですか？（落ちていない場合は空白）

●このバージョン1.2.5.12で、障害と思われるようなことが発生しましたか？
それはどんな時ですか？（心当たりが無い場合は空白）

●ご意見やご感想などあればここに書いてください

●要望がある場合ここに書いてください。
ただし、仕様変更はver2以降でないと行いません。（作るかどうかも不明）
現在の仕様に追加する形での要望の方が対処しやすいです。

インターネットに接続した後に下のボタンを押すことで、送信内容の確認画面に進めます。


アンインストールの方法

ここでは、AniLaPaint のアンインストールの方法について説明します。

●アンインストール時の注意点

AniLaPaint はアンインストール時に、AniLaPaintの状態を保存する場所に保存した情報を削除しません。
これは、WindowsInstallerの仕様でバージョンアップ時にも前のバージョンをアンインストールしなくてはならないために、バージョンアップする毎に、AniLaPaintの設定が全て出荷時の状態に戻ってしまうことを防ぐためです。
もし、今後もAniLaPaintを使用しない場合には、INIファイルやレジストリに書き込まれた情報を削除することをお勧めします。方法については、AniLaPaintの状態を保存する場所に記述してあります。

●アンインストールの方法

スタートメニューからコントロールパネルを選んでください。
コントロールパネルが表示されたら、アプリケーションの追加と削除アイコンをダブルクリックして開きます。
リストの中から AniLaPaint を選択してアンインストールしてください。
※AniLaPaint.EXEを直接ゴミ箱へ移動するアンインストール方法は、システムにインストーラーの情報を残したままとなりますので、インストーラを使ってインストールした場合は、必ず上記の方法でアンインストールを行ってください。


第２章 入門編

ホーム>>

第２章　入門編

ここでは、はじめて AniLaPaint を使用する方が、基本的な仕様を理解し、操作手順をマスターするためのチュートリアルを掲載しています。

AniLaPaint の基本仕様

ここでは、AniLaPaint の基本的な仕様について説明します。AniLaPaint を使う上で最低限知っておかなければならない事なので、必ずお読みください。

チュートリアル（工事中）

ここでは、はじめて AniLaPaint を試用する方が、その基本的な操作をマスターしやすくするためのチュートリアルを掲載する予定です。


AniLaPaint の基本仕様

ここでは、AniLaPaint の基本的な仕様について説明します。AniLaPaint を使う上で最低限知っておかなければならない事なので、必ずお読みください。

AniLaPaint の操作手順

セルアニメーション作画方法

ここでは、AniLaPaint が前提にしているセルアニメーションの作画方法について解説します。

インポートについて

ここでは、貴方が描いた絵を AniLaPaint で彩色できるようにする方法（インポート）について説明します。

カット袋ワークスペースについて

ここでは、インポートした画像を編集するために、カット袋ワークスペースについて説明します。

ペイント作業について

ここでは、インポートした画像にペイントする方法について説明します。

ビルドについて

ここでは、ペイント作業後に境界線を消去し、実線画像と彩色画像を統合し、セル画像と透明度マスクを作成するビルドの機能について説明します。

エクスポートについて

ここでは、AniLaPaint で完成させたセル画像と透明度マスクを、他のソフトで使える形式に変換出力するエクスポートの機能について説明します。

AniLaPaint の仕様

ファイル形式について

AniLaPaint で使用する各種ファイル形式について説明します。AniLaPaint は、コンパイラー型の画像ソフトを目指して作られています。１つの完成画像を作るまでにさまざまな形式のファイルを使用します。ここではそれらの説明をします。

色について

AniLaPaint はフルカラーの色を扱えますが、いくつかの色はシステム使用色として彩色などには利用できません。それらの色の役割について説明します。


セルアニメーション作画方法

ここでは、AniLaPaint が前提にしているセルアニメーションの作画方法について解説します。

作画時の線の色

主線のことをアニメーション用語では実線といいます。実線は、黒の鉛筆で描くことになっています。２Bがお勧めです。線の色の濃さが濃ければ、シャープペンでも構いません。

明暗の色の境界線や水などのように輪郭が主線でない輪郭線のことをアニメーション用語では色トレス線といいます。色トレス線は、赤などの色鉛筆で描くことになっています。

最近のスキャナは色の分解能力が高まっており、赤・青・水色・桃色・紫・赤茶色・オレンジ・黄緑色等さまざまな色鉛筆が使用できます。ただし、緑系は色トレス線が実線として出てしまう場合があるので要注意です。

赤が最も黒の鉛筆との区別のつく色ですので、初心者の方は赤を最初に使ってください。

CCDカメラから取り込んだ画像は一般的に色分解に向いていません。スキャナーでの取り込みを前提としています。（しかし最新のデジカメとかだと結構大丈夫かも？）

紙の上で完全に清書し、無駄な線などは一切ない状態にしておきます。その際に、動画用紙・タップ・ライトボックスという３つのアイテムが必要になります。（画材屋またはアニメショップなどで購入してください。）

通常影色の部分は、裏に薄い水色や黄緑などで軽く塗りつぶします。これは、塗りを担当する人に伝えたり、自分の確認のために行なった方が良い場合は行ってください。AniLaPaintでこの表記を読み取る事はありません。

作画時のセル重ね

一番奥が、背景とよばれるポスターカラーで描かれた絵です。これは、AniLaPaint では扱いません。

セルアニメーションでは、セルと呼ばれる塩化ビニールの透明シートを背景の上に複数枚重ねることで、１つの絵の各部品毎に動きを決める事ができました。例えば、顔と目のセルを別々のものにしておき、目のセルだけに動きを加える事で、瞬きなどの表現が可能でした。

このセルの重ね方は、アルファベットで表記します。Ａが背景のすぐ上のセルで、ＢがＡの上にきます。先ほどの例では、顔がＡ、目がＢとなります。この上に髪の毛がゆれる効果があれば、髪がＣとなったりします。このように、アルファベットが異なる素材のことを別セル素材と呼びます。

別セル素材の場合、紙の段階で予め別々の紙に清書しておく必要があります。上記の例ですと、Aの顔、Bの目、Cの髪は別々の紙に清書しておく必要があります。この３枚を重ねて透かすと、完成形の顔が形作られるようにします。この際、３枚の紙の位置のずれが生じないように、先述した動画用紙とタップを使い紙を固定します。

AniLaPaint では、このセル重ねをＡセルからＺセルまでで管理します。

このセル重ねは、グラフィックソフトでレイアとよばれているものと等価ですが、重なり方に名前規則を取り入れている点がレイアとは異なります。

作画時のセル番号

セルアニメーションでは、動画に番号をつけて管理します。

例えば、瞬きなどで開目・中目・閉目の３枚がある場合は、１から３までの番号がつきます。（どれを１にするかは自由です。）

先ほどのセル重ねのアルファベットに続き番号を書きます。例えば、B1とかB2と書きます。

番号は各アルファベット毎に１から始まる連番と決まっており、アルファベット毎の最後の番号にはend(END)を付加します。たとえば、Aセルは１枚しか無いような場合でも、A1endと付けます。先ほどの瞬きの例ですと、B1,B2,B3end です。

AniLaPaint では、この番号を１から９９９まで管理しますが、endに関しては管理しません。番号が飛んでいても構いません。

セル番号は、セル重ねと番号のセットをいいます。

作画した絵の紙の右上（スキャンしない部分）にこれらのセル番号を書き込んでおきます。

ファイルとフォルダ管理

これは、AniLaPaint のローカルな仕様であります。

AniLaPaint で管理する画像ファイルは、全て上記のセル番号に準拠したものとし、ファイル名として半角アルファベットと3桁の半角数字であらわすものとします。(例 A001.ANP)

１カット分の動画を１フォルダに入れる事とします。このフォルダを AniLaPaint では、カット袋と読んでいます。

例)
カット袋 = C:\AniLaData\Cut01\
ファイル = A001.ANL, A001.ANP, B001.ANL, B001.ANP, ... etc.


インポートについて

ここでは、貴方が描いた絵を AniLaPaint で彩色できるようにする方法（インポート）について説明します。

スキャナーで絵を取り込む

この作業は、ご使用のスキャナーに付随したソフトなどで行なってください。

まず、予め塗るための素材（絵）を用意してください。必ず、セルアニメーション作画方法で描いてください。

動画用紙に描いた絵を取り込む場合、スキャナにタップをセロテープで貼り付けてください。１枚のみの場合は、タップは必要ありません。

動画の場合は、１カット分を全て同じ解像度でスキャンしてください。この際、dpi値よりも、ピクセル数をご覧ください。AniLaPaintは、TVのブラウン管に写すためのアニメを制作する事を目的としているため、推奨される解像度は、640x480 または、 1280x960 の２つです。PAN素材やスライド素材の場合はこの限りではありません。実用的に、動画を彩色するためには、128MB程度のメモリは必要です。

静止画の場合は、解像度に規則はありませんが、128MBのメモリをつんでいる場合は1280x960程度を推奨します。ホームページに貼る程度の絵ならもう少し小さくても構いません。この解像度を大きくとりすぎると、メモリ容量不足に陥ります。

動画の場合も、静止画の場合も、必ずフルカラーでスキャンしてください。モノクロでスキャンした場合は、AniLaPaint でインポートできません。

スキャンした画像はファイルに保存します。必ずファイルフォーマットは、表示のみの画像(*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.jpg;*.jpeg;*.cmp;*.ras;*.pct)の何れか（LZW圧縮は不可）にしてください。その際のファイル名は自由です。連続で取り込めるスキャナーソフトなどを使用すると勝手に連番ファイルなどにしてくれて楽です。いずれにしても、後で AniLaPaint 側で名前を付け直しますので、ここでのファイル名は仮のものと思ってください。

AniLaPaintにインポートする

スキャナーで保存した任意のフォルダに配置した任意の名前のファイルから、主線と境界線を抽出して実線画像(*.anl)と彩色画像(*.anp)と呼ばれる２つの AniLaPaint 画像ファイルをカット袋に自動生成する作業をインポートと呼んでいます。

メニューバー>>ファイル>> 新規作成 新規作成でインポートができます。

また、ねこらさんが作られたトレースちゃんというソフトでも、インポート作業ができます。http://www.mapletown.net/~nekora/

AniLaPant のインポートに関するファイルについて

インポート オプションファイル(*.asp)

ここでは、インポート時の２値化の設定を含むインポートオプションファイルについて説明します。

インポート ログファイル(ImportLog.dat)

ここでは、インポート設定のログファイルについて説明します。


カット袋ワークスペースについて

ここでは、インポートした画像を編集するために必要なカット袋ワークスペースの機能について説明します。

インポート後のフォルダ構成について

１回のインポートは、常に１つのフォルダを対象にして行なわれます。つまり、同一カットの動画は全て同じフォルダに保存されます。

このようにインポートで作成されたフォルダをカット袋と呼んでいます。カット袋には、カット袋ワークスペースファイル(AniLaProject.dat)と、セル番号規則による AniLaPaint画像ファイルが格納されています。

カット袋ワークスペースの開き方について

インポート時には、インポートされたフォルダをカット袋ワークスペースとして自動的に開きます。

また、AniLaPaint 再起動時には、前回に開いていたカット袋ワークスペースを自動的に開きます。

現在、カット袋ワークスペースを開いていない場合や、他のカット袋に切り替えたい場合には、メニューバー>>ファイル>> カット袋ワークスペースを開く カット袋ワークスペースを開くか最近のカット袋ワークスペースを選択する事で、新たにカット袋ワークスペースを開く事ができます。

現在、カット袋ワークスペースを開いている場合は、カット袋ワークスペースの表示・非表示を、メニューバー>>ウィンドウ>> カット袋ワークスペース カット袋ワークスペースで切り替える事が出来ます。

ただし、カット袋ワークスペースは全体として常に１つしか開く事ができません。複数のカット袋を同時に開く時には、AniLaPaintを複数開くしかありませんが、AniLaPaintの起動自体に13MB程度のメモリを消費しますので、その点はご了承ください。

カット袋ワークスペースの役割

カット袋ワークスペースは、AniLaPaintのメインウィンドウの左辺にドッキングし、カット袋フォルダ内のAniLaPaint画像ファイルをサムネイル（縮小）表示したり、名前付きパレットを表示するためのウィンドウです。

このカット袋ワークスペースには、 実線画像 実線・ 彩色画像 彩色・ セル画像 セル・ 色アイコン 色の４つのタブがあり、順に実線画像・彩色画像・セル画像・色アイコンを現しています。
このタブをマウスでクリックするか、メニューバー>>カット袋>>表示で切り替えて表示する事ができます。また、表示順序をアイコンの整列で切り替えて表示する事もできます。また、カット袋ワークスペース上でマウスの右ボタンをクリックして表示させるメニューからも行なえます。
カット袋ワークスペースは、伸縮ができ横に伸ばすことが可能です。また、左上の グリップ をドラッグすることで、メインウィンドウから取り出してフローティングさせることもできます。

カット袋ワークスペースは、次の２つの目的のために存在します。

カット袋内の複数のAniLaPaint画像をサムネイルで分かりやすく表示し、これらをダブルクリックする事で素早く開くため。

カット袋内の実線画像と彩色画像から、ビルドにより、セル画像とマスク画像を自動生成したり、エクスポートにより他のソフトで扱える形式に変換し出力するため。


ペイント作業について

ここでは、インポートした画像にペイントする方法について説明します。

ペイント作業を施す画像ファイルについて

インポートで生成された画像は１つのセル番号の絵に対して２種類です。「実線画像(*.anl)」と「彩色画像(*.anp)」と呼ばれるものです。

「実線画像(*.anl)」は、黒の鉛筆で描かれた主線のみを取り出した、グレースケールの画像です。

「彩色画像(*.anp)」は、黒の鉛筆で描かれた主線と色鉛筆で描かれた境界線を取り出しデジタル８色で表現したフルカラー画像です。

画像ファイルの編集について

カット袋ワークスペースに表示された 実線画像 実線タブ（またはメニューバー>>カット袋>>表示>>実線）を押して表示される画像のサムネイル（縮小表示）をダブルクリックすると「実線画像(*.anl)」の編集ができます。この編集で行なう事は、無駄な線やノイズを消すことだけです。この際に、メニューバー>>ビュー>> 強調表示/マスク表示 強調表示/マスク表示で、２値表示するとゴミが消しやすくなります。

カット袋ワークスペースに表示された 彩色画像 彩色タブ（またはメニューバー>>カット袋>>表示>>彩色）を押して表示されるサムネイルをダブルクリックすると「彩色画像(*.anp)」の編集ができます。この編集で行なう事は、メニューバー>>ツール>>塗りつぶしツール>> バケツ バケツなどを使って、境界線で囲まれた領域に目的の色をペイントすることだけです。境界線は消す必要がありません。また、１０ドット未満の塗り残しも埋める必要がありません。

同じまたは前後のセル番号の画像ファイルの編集について

メニューバー>>ビューには、現在彩色している同じセル番号の画像を素早く開くために、 実線画像 実線画像と 彩色画像 彩色画像があります。

また、前後のセル番号の同じ種類のファイルを素早く開くために、 前番号(F11) 前番号(F11)と 次番号(F12) 次番号(F12)があります。

これらのコマンドを選択した時に、自動的に前の画像を閉じるための 直前の画像を常に閉じる 直前の画像を常に閉じるや、自動的に前の画像を保存するための 直前の画像を自動保存 直前の画像を自動保存があり、作業効率を高めます。

これらのコマンドをマウスで直接クリックできるツールバーが、ウィンドウメニューのツールバーのビュー切り替えで表示できます。


ビルドについて

ここでは、ペイント作業後に境界線を消去し、実線画像と彩色画像を統合し、セル画像と透明度マスクを作成するビルドの機能について説明します。

ビルドで行なう事

ペイント作業を行なっても、実線画像(*.anl)と彩色画像(*.anp)は別々のファイルですし、彩色画像の境界線がそのままだと、完成したセルアニメの絵にはなりません。

そこで、ビルドの機能が必要になります。この機能は、まず、彩色画像の塗り残しの穴を判別して埋めてくれます。
次に、実線画像との比較で、実線の下の境界線と純粋な色トレス線を判別し、それぞれに最適な色を、近隣の色から着彩します。この際、境界線の色・詳細設定で、色の境界をギザギザの２値にしたり、３値にしたり、多値（グラデーション）にしたり、境界線を細くしたりすることができます。
最後に、境界線が消去された彩色面の上に実線画像を合成しセル画像(*.anc)と、アニメ制作では欠かせないレイアの透明度を現すαチャンネルをマスク画像(*.anm)を作成します。この実線画像の線の濃さも、境界線の色・詳細設定で調節できます。

つまり、同一カットのカット袋内の全ての実線画像と彩色画像から、新たに、セル画像とマスク画像を作成する事を、ビルドと呼びます

カット袋ワークスペースに表示された セル画像 セルタブ（またはメニューバー>>カット袋>>表示>>セル）を押して表示されるサムネイルが、ビルドによって自動生成されたセル画像です。
このサムネイルをダブルクリックするとセル画像のビューが表示されます。この時、メニューバー>>ビュー>> 強調表示/マスク表示 強調表示/マスク表示を選択すると、マスク画像の表示に切り替わります。このビューでは、一切の編集作業はできません。このビューは、表示のみなので、ビルドの結果が間違っていないかを確認する作業だけしてください。

もし、この画像を見て、自動的に消去された境界線の状態や塗り残しの穴の状態が思い通りにならなかった場合は、メニューバー>>ビュー>> 実線画像 実線画像か 彩色画像 彩色画像を選択してください。すると、現在セル画像で表示しているのと同じ場所（拡大率）で素早く実線または彩色画像が表示されます。これにより、簡単にペイントし直すことができます。その後、再度ビルドが必要です。

ビルドとカット袋ワークスペースの関係

ビルドは、通常カット袋ワークスペースが行ないます。

メニューバー>>カット袋>> 全更新ビルド 全更新ビルドを選択してビルドする場合、カット袋内の全ての実線画像と彩色画像の保存日時と、セル画像の保存日時を比較して、セル画像の方が古い場合、またはセル画像が存在しない場合、最新のセル画像とマスク画像をビルドします。

メニューバー>>カット袋>> リビルド リビルドを選択してビルドする場合、カット袋ワークスペースの特定のセル画像のサムネイルを選択しているとそのセル画像のみを再度ビルドし直します、どのサムネイルも選択していないとカット袋内の全てのセル画像を再度ビルドし直します。

実は、全更新ビルドの機能は、ファイルの日時の比較で更新するセル画像を割り出しているために、境界線の色・詳細設定で設定を変更した際には、全更新ビルドを選択しても更新されないということが起こります。ですから、設定を変更した場合は、リビルドを使って更新してください。

メニューバー>>カット袋>>クリーンを選択した場合、現在あるセル画像とマスク画像を全て削除します。

このように、ビルドの機能を便利に使用するにはカット袋ワークスペースを事前に開いておく必要があります。

これらのビルドのツールバーのボタンは、スタンダードツールバーにあります。

カット袋ワークスペースに依存しないビルド

ビルドには、カット袋ワークスペースに依存しないビルドもあります。これには次の２種類があります。一つは、ビュー毎の単独のビルドであり、もう一つは、複数のフォルダをまとめて行なうバッチビルドです。

単独のビルドとは、現在開いている実線画像や彩色画像などをその場でビルドする機能です。このコマンドは、メニューバー>>カット袋>> 現在のビューの画像をビルド 現在のビューの画像をビルドです。このコマンドは、カット袋ワークスペースを開いていなくても選択できます。このコマンドを実行すると、セル画像が直ちに作られますが、セル画像を開くには、メニューバー>>ビュー>> セル画像 セル画像を選択する必要があります。（自動的に開かれません）

バッチビルドとは、複数のカット袋を一括でビルドする機能です。これは、ペイント作業だけをどんどん行ない、外出する時などに、一括で複数のフォルダのカット袋をビルドできたら便利だという事で作られたコマンドです。メニューバー>>ファイル>>バッチ処理に全更新ビルドとリビルドがあります。全更新ビルドは、ファイル日時による比較のみを使ってセル画像を更新します。リビルドは、全てのセル画像を新しい設定で再度ビルドし直します。


エクスポートについて

ここでは、AniLaPaint で完成させたセル画像と透明度マスクを、他のソフトで使える形式に変換出力するエクスポートの機能について説明します。

エクスポートとは

エクスポートは、完成した「セル画像(*.anc)」と「マスク画像(*.anm)」から、AniLaPaint の後の作業、レイアの合成や、動きを付けるソフトで扱える形式のファイルとして出力する作業の事をいいます。 詳しくは「エクスポートできる画像」をご覧ください。

セルアニメーション作画方法に準拠したソフトへエクスポート

現在、複数の静止画素材に使い動きを付けてムービーファイルとして出力できるソフトはいろいろありますが、セルアニメーション作画方法に準拠したツールは、
AnimeStudio II ( http://member.nifty.ne.jp/zenmaihouse/ )
CoreRETAS ( http://retaspro.celsys.co.jp/ )
の２つがあります。

AnimeStudio II で扱えるファイルとしてエクスポートするには、TGA32bitフォーマットを選択します。

CoreRETAS で扱えるファイルとしてエクスポートするには、最新のバージョンでは 32bit TGA でも可能ですが、CoreRETAS 上でアンチエリアス処理を施すには、一つ前のビルドの段階で、パラメータの実線・境界線の両方を２値にしてビルドしておく必要があります。その上で、CoreRETAS が読める形式の画像ファイルで24bitマスクなし（透明キー白）を選択します。

その他のムービー制作ソフトへエクスポート

セルアニメーションの作画方法に準拠していないムービー制作ソフトでは、その画像が扱える形式でエクスポートする必要がありますが、セルや背景を重ねることを考えると TGA 32 bit しか選択肢がありません。ですので、このファイルを読めないソフトではコンバートが必要になります。

例えば、AdobePremiere では、TGA32bit が読めます。ただし、透明度からαチャンネルを選択しないと背景を重ねられません。また、マスクなどが白黒反転になっている可能性も考えられますので、それもお試しください。

いずれの 32bit ファイルもサポートしていないソフトで使用する場合は、24bit + 8bitマスク という２枚のファイルを出力する方法もあります。しかし、この方法は最後の手段であり、実際に使えるかどうかはソフトとオペレータの技量によるところが多いと思います。

ホームページに貼り付ける静止画のエクスポート

ホームページに貼り付ける静止画の素材にする目的でエクスポートする場合は、顔と目を別々のセルに書いてしまわずに、１枚の絵としてAセルにインポートして塗るのが一般的です。エクスポートでは、PNG ファイルの24bitマスクなしで背景色をホームページの背景と同じ色にしてください。PNG は GIF とは異なり特許に関わらないW3C準拠の画像フォーマットで、GIFの後継を担うものです。

GIFアニメーション素材としてのエクスポート

ホームページに貼り付けるアニメーション画像などを作成するには、今のところ GIF アニメしかないわけですが、一般的に、GIF アニメの場合、セル量ねを表現するには、カラーキーを使います。しかし、この方法では、グレースケールの主線は扱えないので、エクスポートの段階で、24bitマスクなしを選択すると自動的に制作される画像の主線は２値（黒のぎざぎざ）となります。もし、GIF アニメを作ろうとして、セル量ねを必要としない場合は、エクスポートの際に、24bit マスクなしで背景色を指定したエクスポートを行なってください。すると、主線がグレースケールの状態でエクスポートできます。
この際、お使いになるGIFアニメーションを制作するソフトで読み込める形式でエクスポートする必要があります。無難なのは24bitBMPです。

32bitBMPについて

これについては、殆どのソフトが対応していません。

画像コンバータについて

外部のコンバータを使うことで任意のファイルフォーマットに変換できます。詳しくは「エクスポートできる画像」をご覧ください。


ファイル形式について

AniLaPaint で使用する各種ファイル形式について説明します。AniLaPaint は、コンパイラー型の画像ソフトを目指して作られています。１つの完成画像を作るまでにさまざまな形式のファイルを使用します。ここではそれらの説明をします。

画像ファイルについて

AniLaPaint 画像 (*.anl;*.anp;*.anc;*.anm)

ここでは、AniLaPaint で実際に編集に使用する独自画像ファイルを説明します。

エクスポートできる画像(*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.ras)

ここでは、AniLaPaint からエクスポートできる汎用画像フォーマットについて説明します。

表示のみの画像 (*.anc;*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.jpg;*.jpeg;*.cmp;*.ras;*.pct)

ここでは、AniLaPaint で表示のみできる画像について説明します。

その他のファイルについて

色アイコン ファイル (*.anila_palette; *.apl; *.csv; *.txt)

ここでは、AniLaPaint のカット袋ワークスペースに表示される色アイコンのデータファイルについて説明します。

インポート オプション ファイル (*.anila_import; *.asp)

ここでは、インポート時の２値化の設定を含むインポートオプションファイルについて説明します。

インポート ログファイル(ImportLog.dat)

ここでは、インポート設定のログファイルについて説明します。

エクスポートオプション ファイル (export.ini)

ここでは、エクスポートオプションファイルについて説明します。

カット袋ワークスペース ファイル (AniLaProject.dat)

ここでは、カット袋ワークスペースファイルについて説明します。


AniLaPaint 画像 (*.anl;*.anp;*.anc;*.anm)

ここでは、AniLaPaint で実際に編集に使用する独自画像ファイルを説明します。

AniLaPaint 画像とは？

AniLaPaint は１つの画像ファイルに着色するペイントソフトやレタッチソフトとは異なり、１枚の絵に対して次の４つの異なる特性を持った画像ファイルが対応づけられています。
画像の種類 | 拡張子 | ビット数 | 編集時のビュー | 画像の編集
実線画像 | anl | 8bit | 実線画像 実線画像のビュー | 可
彩色画像 | anp | 24bit | 彩色画像 彩色画像のビュー
セル画像 | anc | 24bit | セル画像 セル画像のビュー | 不可（表示のみ）
マスク画像 | anm | 8bit
これらの、独自画像をまとめて AniLaPaint 画像と呼びます。

AniLaPaint画像の内部形式

AniLaPaint画像ファイルの内部形式はメニューバー>>ファイル>>環境設定>>環境設定ダイアログ>>ファイルタブで設定することができます。

実は、AniLaPaint画像は、拡張子が違うだけでファイルの内容は、ここで設定した一般の画像フォーマットそのものです。

ですから、他の画像ソフトにドラッグ＆ドロップでも読める事があります。（ただし、拡張子を変更しなければならないソフトがほとんどです。）

しかし、画像そのものは以下のAniLaPaint 独自の仕様にのっとった色の規則を満たしていなければならないので、他のソフトで彩色する事はお勧めしません。
画像の種類 | 拡張子 | ビット数 | 他のソフトで編集してよい色
実線画像 | anl | 8bit | グレースケールの全ての色
彩色画像 | anp | 24bit | デジタル８色以外の全ての色と白
セル画像 | anc | 24bit | AniLaPaintの中間ファイルなので編集してはならない
マスク画像 | anm | 8bit

実線画像と彩色画像

実線画像と彩色画像はセルアニメーション作画方法で描かれ、スキャナーで取り込んだファイルから、メニューバー>>ファイル>> 新規作成（インポート） 新規作成（インポート）を使い、自動作成します。

実線画像と彩色画像の編集については、「カット袋ワークスペースいついて」や「ペイント作業について」をご覧ください。
画像ファイルの詳細な仕様については、「実線画像」「彩色画像」をご覧ください。

セル画像とマスク画像

セル画像とマスク画像は編集済の実線画像と彩色画像から、メニューバー>>カット袋>> 全更新ビルド 全更新ビルドコマンドを使い、自動作成します。

セル画像とマスク画像の表示については、「ビルドについて」をご覧ください。

これらのファイルは、AniLaPaintの中間ファイルです。画像ファイルの詳細な仕様については、「セル画像」「マスク画像」をご覧ください。

これらの中間ファイルから、完成した汎用画像フォーマットのファイルを作成する作業については、「エクスポートについて」をご覧ください。

処理の流れ

貴方がセルアニメーション作画方法で描き
スキャナなどで取り込んだ線画
↓
インポート
↓
実線画像
↓
ゴミなどを取り除く
↓ 		彩色画像
↓
色を塗る
↓
ビルド
↓
セル画像
↓ 		マスク画像
↓

エクスポート
↓

汎用画像ファイル
↓
他のソフト
AnimeStudioII,
PhotoShop,
etc...

■の部分がAniLaPaintで処理する部分です。


実線画像 (*.anl)

ここでは、AniLaPaint画像の 実線画像(*.anl) について説明します。

実線とは

AniLaPaintで実線というと、アニメーション作画方法の用語の実線をあらわします。これは、キャラクターの主線の意味です。つまり、キャラクターの黒の線の部分を実線といいます。

ただし、画面になった時に実線が黒以外になる事もあります。たとえば、実線をこげ茶色にして画面に柔らかさを与えるなどの効果を出す事ができます。

しかし、最終的な画面がどうであれ、紙の上では、実線は常に黒の鉛筆で描くことになっています。

実線画像とは

インポート時に、あなたの絵の実線の部分だけを抽出しファイルとして保存したものを実線画像といいます。

ファイル名は、AniLaPaintが自動的に付けたもので、セル番号に基づいている必要があります。拡張子は、anl と決まっています。

画像は白黒の８ビットグレースケール画像です。

カラーを使う事はできません。

ファイルの内部形式は？

「AniLaPaint画像の内部形式」をお読みください。

その他

実線画像の作成方法については、「インポートについて」をご覧ください。

実線画像の編集方法については、「ペイント作業について」や「第４章 画面の各部の説明>> ビュー>>実線画像」をご覧ください。

実線に色を付ける方法があります。ただし、この機能は実線全体の色を変えることであり、部分的に色を付けるという意味ではありません。これについては、ビルド時の境界線の色・詳細設定ダイアログで指定できます。

実線に部分的に色を付けたい場合は、その部分の実線を消してください。その後、彩色画像の同じ部分の境界線に色を付けてください。ただし、アンチエリアスはかかりません。


彩色画像 (*.anp)

ここでは、AniLaPaint画像の 彩色画像(*.anp) について説明します。

色トレス線とは

AniLaPaintで色トレス線というと、アニメーション作画方法の用語の色トレス線をあらわします。これは、キャラクターの色の境界線の意味です。つまり、キャラクターの明色と影色の見えない境界線や、水などのように輪郭が黒でない見えない輪郭線の部分を色トレス線といいます。

ただし、画面になった時に見えるタッチや効果線などの効果も色トレス線です。

紙の上では、色トレス線は常に黒以外の色鉛筆で描くことになっています。赤はAniLaPaintで使用できますが、それ以外の色は、スキャナとの相性などで読めない場合が多々あります。予め、ご使用の色鉛筆をテストし、AniLaPaintのインポート時に認識できるかどうかテストしてください。

彩色画像とは

インポート時に、あなたの絵の実線の部分と色トレス線の部分を抽出し原色（白以外のデジタル７色）に変換しファイルとして保存したものを彩色画像といいます。

ファイル名は、AniLaPaintが自動的に付けたもので、セル番号に基づいている必要があります。拡張子は、anp と決まっています。

画像は２４ビットフルカラー画像です。

白以外のデジタル７色は、色の境界線を意味しており、境界線はビルドの際に近隣の色で自動的に埋められて見えなくなります。

白は、透明部分をあらわしており、ビルドの際に作る透明度マスクの透明部分になります。
彩色画像の編集画面では、透明部分を白以外の色で表示する事もできますが、ファイルに保存する際に自動的に透明部分を白に戻して保存するようになっており、ファイル上では常に白は透明部分をあらわしています。

ファイルの内部形式は？

「AniLaPaint画像の内部形式」をお読みください。

その他

彩色画像の作成方法については、「インポートについて」をご覧ください。

彩色画像の編集方法については、「ペイント作業について」や「第４章 画面の各部の説明>> ビュー>>彩色画像」をご覧ください。

境界線に色を付ける方法があります。通常、境界線は保護されていて、変更できませんが、色保護メニューの境界線で境界線の各色の保護を解除する事が可能です。また、境界線以外を保護にして境界線のみに色を付けることができるように、色保護メニューの反転有効を選択する事も出来ます。

ビルド時に、境界線の部分をどう消すかを設定する事で、境界線部分をかぶらペンでトレスしたようにする事も、また境界線を細くしてシャープなアンチエリアス的効果を出す事も可能です。色の境界を完全に２値のギザギザにして、CoreRetasへエクスポートするためのビルドを行なう事もできます。これらの設定については、ビルド時の境界線の色・詳細設定ダイアログで指定できます。


セル画像 (*.anc)

ここでは、AniLaPaint画像の セル画像(*.anc) について説明します。

セル画像とは

実線画像と彩色画像から、ビルドによって自動的に作られるAniLaPaintの中間ファイルです。エクスポートをする前に、ビルドの結果を確認するために存在します。

ファイル名は、実線画像と彩色画像についているものと同じです。拡張子は、anc と決まっています。

画像は２４ビットフルカラー画像です。

白は、透明部分をあらわしています。

ファイル上の画像データでは、透明部分との輪郭部分は、アンチエリアスはかかりません。これは、仕様です。この部分は、マスク画像の方にアンチエリアスをかけ、白のフリンジを防止しています。
AniLaPaintでセル画像を表示した場合は、自動的に背景色と合成した結果が表示されるので、透明部分との輪郭部分もアンチエリアスがかかったように見えます。

ファイルの内部形式は？

「AniLaPaint画像の内部形式」をお読みください。

その他

セル画像の作成方法や、表示方法については、「ビルドについて」をご覧ください。

セル画像にペイントする事はできません。
修正はあくまで、彩色画像か実線画像を修正してください。
（将来においては、セル画像の上に修正レイアを追加できるようにしたいと考えております。ver1.5くらいまでには・・・。いつになることやら・・・。）


マスク画像 (*.anm)

ここでは、AniLaPaint画像の マスク画像(*.anm) について説明します。

マスク画像とは

実線画像と彩色画像から、ビルドによって自動的に作られるAniLaPaintの中間ファイルです。エクスポートをする前に、ビルドの結果を確認するために存在します。

ファイル名は、実線画像と彩色画像についているものと同じです。拡張子は、anm と決まっています。

画像は白黒8ビットグレースケール画像です。

白は、透明部分をあらわしています。黒は、不透明部分をあらわしています。グレーは、半透明の部分で、セル画像の同位置のアンチエリアスです。

ファイルの内部形式は？

「AniLaPaint画像の内部形式」をお読みください。

その他

マスク画像の作成方法や、表示方法については、「ビルドについて」をご覧ください。

マスク画像にペイントする事はできません。


エクスポートできる画像(*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.ras)

ここでは、AniLaPaint からエクスポートできる汎用画像フォーマットについて説明します。

AniLaPaintで彩色した画像を、最終的に他のソフトでも読める形式のファイルとしてエクスポートします。

エクスポートダイアログで選択できる画像フォーマットは以下のようになっています。

  • 32 bit（マスク付き）

    これは、１つのファイル内に、画像の透明度を0～255までの階調で保存する事により、他のソフトで背景と合成する際にスムーズなキャラクターの輪郭を実現するためのフォーマットです。レイアなどを考慮したソフトであれば大概はこの機能が備わっています。

    (RLE圧縮) Truevision TARGA 形式 (TGA) … 32bit形式のファイルとしては一般的です。

    (無圧縮) Truevision TARGA 形式 (TGA) … 32bit形式のファイルとしては一般的です。
    (無圧縮) SUN Raster 形式 (RAS) … UNIX では良く使うそうです。
    (無圧縮) Windows ﾋﾞｯﾄﾏｯﾌﾟ 形式 (BMP) … ただし、MS社のソフト以外では読めません｡

  • 24 bit + 8 bit（マスク）

    これは、２つのファイルで、画像とその透明度をあらわす方法です。この方法は一般的ではありませんが、グラフィックツールのスキルに長けた方であれば、何らかの使い道を模索していただけるのではないかと思いつけてあります。透明度を別のファイルとして出力したい時にお使いください。

    (ZIPLIB圧縮) Portable Network Graphics 形式 (PNG)
    (RLE圧縮) Adobe Photoshop 3.0 形式 (PSD)
    (RLE圧縮) Zsoft PCX 形式 (PCX)
    (無圧縮) Truevision TARGA 形式 (TGA)
    (無圧縮) SUN Raster 形式 (RAS)
    (無圧縮) TIFF 形式 (TIF)
    (無圧縮) Windows ﾋﾞｯﾄﾏｯﾌﾟ 形式 (BMP)
    (無圧縮) OS/2 ﾋﾞｯﾄﾏｯﾌﾟ ver.1 (BMP)
    (無圧縮) OS/2 ﾋﾞｯﾄﾏｯﾌﾟ ver.2 (BMP)

  • 24 bit（マスクなし 透明キー白）

    これは主に Core ReTas 用のファイル（PSD,TGA,BMP,TIFのいずれか）を出力する為のものです。この場合、あらかじめビルド時に実線と色トレス線を２値にしておく必要があります。

    また、Gif アニメなどを作る場合で、白をカラーキーとして別の背景画像を合成したい場合にこれを使います。（背景が単色の Gif アニメを作る場合には次の 24bit（マスクなし 背景[色]設定）をご使用ください。）

    AniLaPaint では、デジタル８色以外の全ての色が塗られている可能性があるので、透明部分のカラーキーを白として出力します。これはあくまでカラーキーで透明部分を抜くことが目的である場合にのみ使用してください。なぜなら、そのために背景との境界部分をわざとギザギザにしてあるからです。これは、カラーキーで抜く場合に必要不可欠な処理です。もし、背景との合成が必要でない場合は、次の 24bit（マスクなし 背景[色]設定）をご使用ください。

    出力できるフォーマットは、24bit + 8bit と同様です。

  • 24 bit（マスクなし 背景[色]設定）

    これは、後で背景との合成をする必要の無い場合の出力方法です。例えば、ホームページに貼り付ける画像を作りたい時に、その目的のホームページの背景がピンクの場合、それと同じピンク色を指定して出力すれば、AniLaPaintでビルドした奇麗なキャラクターの輪郭のまま、ホームページにマッチした背景色での出力が可能になります。ホームページに出力する画像としては GIFやJPEG が一般的ですが、前者は特許のため使えません。また後者は、画像劣化が起こるために、現在は混乱を避けるために使えないようにしてあります。IE や Netscape で表示できるフォーマットとしては、 PNG をお勧めします。それ以外のブラウザ(Windows CE などでは表示できません）で表示するためには、以下の外部コンバータを使用して JPEG などにコンバートすることをお勧めします。

    出力できるフォーマットは、24bit + 8bit と同様です。

  • 他に、外部コンバータを使うことで任意の画像ファイルに変換することも可能となります。

    ImageMagickというGNUのフリーソフト(convert.exe)を使うと、上記のフォーマット以外のフォーマットでのエクスポートが可能になります。

    ただし、このツール自体が DOS コマンドライン用のツールなので、UNCパスへのエクスポートはできません。

    ●ImageMagickの場所

    トップページ
    http://www.imagemagick.org/

    Convert コマンドの説明
    http://www.imagemagick.org/www/convert.html

    ダウンロード(win95/98/2000共通)
    ftp://ftp.simplesystems.org/pub/ImageMagick/win2k/ImageMagick-win2k.zip
    ※よく混んでいて、ダウンロードできません・・・。時間をおくとできるみたいです。
    場所が変わったらトップページから自分で探してください。

    ●使い方

    「セル画像のエクスポート」のダイアログにある「エクスポートのフォーマット」の中に「外部コンバータで変換出力」というのを選んでください。

    「32bit(マスク付き)」の場合、フォーマットによっては「マスクの透明部分」はなぜか「白＝透明/黒＝不透明」の方が良い場合もあります。１つためしにエクスポートしてみて、エクスポート後の画像を使用したいソフトでお確かめ下さい。また、マスク情報がコンバートされないフォーマットなどもありますので、その場合はあきらめてください。

    その他のパラメータは、通常のエクスポートの時と同様です。（24bitマスクなしはサポートしていません。8bitマスクもついでに作ってあとで消すなどしてください。)

    この状態で「開始」を押すと、更なるダイアログが現われます。ここでは、32bit(マスク付き)の場合のみ説明します。

    convert.exeをc:\windows\command\ フォルダに入れた場合の説明なので、適当なフォルダに読み替えてください。

    「外部コンバータ引数設定(32bit)」ダイアログが現われたら以下のように設定するとよいと思います。「AniLaPaintが出力する変換前のファイルのフォーマット」は「TGA」にしてください。

    １）PICTに変換する場合

    「コンバート後の拡張子」は「PICT」に、
    「32bit画像コンバート時のコマンドライン」は
    「c:\windows\command\convert.exe %1 %2」としてください。

    ※c:\windows\command\convert.exeは、実際にはあなたが置いた場所にしてください。

    ※24bitの場合は、「外部コンバータ引数設定(24bit+8bitMask)」ダイアログが表示されます。
    この状態で、「開始」ボタンをおしてください。パラメータに間違いなどがあるときはエラーメッセージが表示されます。


表示のみの画像 (*.anc;*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.jpg;*.jpeg;*.cmp;*.ras;*.pct)

ここでは、AniLaPaint で表示のみできる画像について説明します。

AniLaPaint画像の場合

つぎの２つのファイル形式は、表示のみです。
画像の種類 | ファイルの拡張子
セル画像 | anc
マスク画像 | anm

その他の画像の場合

これらの形式の画像ファイルであれば、AniLaPaintをビュアーとして使う事もできます。
また、インポート用の画像もこちらのいずれかの形式で保存してください。
画像の種類 | ファイルの拡張子
Zsoft PCX 形式 | pcx
Truevision TARGA 形式 | tga
Portable Network Graphics形式 | png
Adobe Photoshop 3.0 形式 | psd
TIFF 形式 (LZW圧縮不可) | tif
Jpeg ファイル形式 | jpg,jpeg
Lead CMP形式 | cmp
SUN Raster 形式 | ras
Macintosh Pict 形式 | pct
Windows ビットマップ 形式 | bmp
Windows メタファイル 形式 | wmf
いずれも、32bit 形式のファイルの場合、αチャンネルは無視されます。

Macintosh Pict 形式の場合マスク情報（アルファチャンネル）が付いていたりすると、AniLaPaintが一般保護違反で落ちます。これに対処することが当方ではできませんので、ご了承ください。


色アイコン ファイル (*.anila_palette; *.apl; *.csv; *.txt)

ここでは、AniLaPaint のカット袋ワークスペースに表示される色アイコンのデータファイルについて説明します。

カット袋ワークスペースの色アイコン・タブで表示される色アイコンのデータは、通常カット袋ワークスペースファイルに保存されます。

しかし、これでは他のカットとの色アイコンの共有ができません。その為に、AniLaPaint では、カット袋ワークスペースファイルから色アイコンのデータだけを切り離して別ファイルに保存することが出来ます。（メニューバー>>カット袋>>アイコンをファイルで共有（自動上書き保存））

別ファイルとして保存したデータには２種類の形式があります。どちらも、等価に扱われます。

バイナリーファイル

他のソフトでデータを変更できないようにAniLaPaint専用のバイナリーファイルで読み書きできます。
拡張子は、anila_palette となっています。

※β版では apl でしたが変更しました。できれば、ファイルの拡張子部分を apl から anila_palette にリネームしてください。もちろん、aplのままでも読めるようになっています。

このファイルのフォーマットは公開していません。このファイルは、内部にバージョンキーが設定されており、常に上位互換になりますが、下位互換ではありません。

テキストファイル

他のソフトでデータを共有したり変更したりできるように、CSV形式のテキストファイルで読み書きできます。CSV形式を扱えるソフトは、表計算ソフトなどさまざまです。
拡張子は csv または txt です。
データ形式は、「""」と「,」を使った以下のフォーマットのどちらかに限られています。

"色が分類されるタイトル名","色の名前","１６進数で２バイトずつRGBの順のデータ"

"色の名前","１６進数で２バイトずつRGBの順のデータ"


インポート オプション ファイル (*.anila_import; *.asp)

ここでは、インポート時の２値化の設定を含むインポートオプションファイルについて説明します。

インポートの２値化のオプションをファイルとして保存すると、拡張子が anila_import のバイナリファイルが作成されます。

※β版では asp でしたが変更しました。できれば、ファイルの拡張子部分を asp から anila_import にリネームしてください。もちろん、aspのままでも読めるようになっています。

このファイルのフォーマットは公開していません。このファイルは、内部にバージョンキーが設定されており、常に上位互換になりますが、下位互換ではありません。


インポート ログファイル(ImportLog.dat)

ここでは、インポート設定のログファイルについて説明します。

このファイルは、前回のインポート時の設定を記憶しておき、後で再インポートを容易にするためのバイナリーファイルです。
カット袋のフォルダに作成されます。必要の無い場合は削除しても構いません。

このファイルのフォーマットは公開していません。このファイルは、内部にバージョンキーが設定されており、常に上位互換になりますが、下位互換ではありません。


カット袋ワークスペース ファイル (AniLaProject.dat)

ここでは、カット袋ワークスペースファイルについて説明します。

カット袋ワークスペースのファイルとは、カット袋ワークスペースに表示するサムネイルのデータや色アイコンのデータを保存したバイナリファイルです。ファイルの名前はAniLaProject.datに固定されており、カット袋に指定した各フォルダに１つづつインポートの際に作成されます。
内部に、色アイコンを外部の色アイコンファイルを共有していない場合は色アイコンのデータは全てこのファイルの中に入っているので、削除しないで下さい。また、セル検のための（検）マークの情報も入っています。

このファイルのフォーマットは公開していません。このファイルは、内部にバージョンキーが設定されており、常に上位互換になりますが、下位互換ではありません。


エクスポートオプション ファイル (export.ini)

ここでは、エクスポートオプションファイルについて説明します。

カット袋フォルダ毎に、前回のエクスポートの設定値がこのファイルに保存されています。

以下のようなファイル内容となります。

[AniLaPaint\1.2\Export]
Message=このセクションのデータを決して編集しないでください。
Create=(1.2.5.11)
strDir=C:\anilapaint\anila_data\anilatest01\Export
bSubDir=1
nFormatFlag=200
nBits=-24
rgbBG=-1
bMask=1
bZoom=0
nZoom=4
bUpdateAll=0
nCountBG=2
nBackColor0=16777215
nBackName0=白
nBackColor1=10878795
nBackName1=緑

これらのパラメータは決していじらないで下さい。不正な値が設定されると、一般保護違反で落ちます。


色について

AniLaPaint はフルカラーの色を扱えますが、いくつかの色はシステム使用色として彩色などには利用できません。それらの色の役割について説明します。

AniLaPaint で編集できる画像形式は、実線画像と彩色画像のみです。

それぞれの画像について使用できる色数に制限があります。

実線画像で使用できる色について

白黒（グレースケール２５６階調）のみ使用できます。

白以外の色を境界線色と呼び、白を背景色と呼びます。

彩色画像で使用できる色について

デジタル８色（白・黒・赤・緑・青・シアン・マゼンタ・イエロー）以外の24bitフルカラーで彩色する事ができます。この彩色できる色のことを標準ペイント色と呼びます。
また、デジタル８色はシステムで使用します。

このうち１色が背景色（セルの透ける部分）となり、他の７色は境界線色として使われます。
ファイルに保存した時点で背景色は必ず白に変換されます。
境界線の７色に区別はありません。黒も赤も同じ境界線色にすぎません。


標準ペイント色

標準ペイント色は、彩色画像の編集時のみ使用できます。

標準ペイント色は、色選択クールバーの瓶（左）のボタンで選択できます。通常ここには、デジタル８色以外の全ての色が表示されます。
このボタンが押されている時にもう一度押すと、色の設定ダイアログが表示されます。
色の設定ダイアログ
ウィンドウメニューのカラーピッカーを表示しておく事で、カラーピッカーで色を変える事もできます。
ウィンドウメニューのスポイトパレットを表示しておく事で、スポイトパレットで色を変える事もできます。
カット袋ワークスペースの色アイコンを選択する事で色を変える事もできます。


背景色

背景色は、彩色画像とセル画像で使用できます。

背景色は、色選択クールバーの消しゴム（中央）のボタンで選択できます。

実線画像の場合

常に白となっており、変更はできません。

彩色画像・セル画像の場合

デジタル８色の何れかが選択可能になっています。このボタンを１回クリックすると▼の印が表示されます。この状態でもう一度このボタンを押すと、背景に使用できる色のメニューが表示されます。これを使って変更できます。
背景色メニュー
また、ビューメニューからも変更できます。
ビューメニュー
また、背景色ツールバーからも変更できます。
背景色ツールバー


境界線色

境界線色は、実線画像と彩色画像の編集時に使用できます。

境界線色は、色選択クールバーの鉛筆（右）のボタンで選択できます。

実線画像の場合

白以外の白黒グレースケールが選択可能になっています。このボタンを１回クリックすると▼の印が表示されます。この状態でもう一度このボタンを押すと、色の設定ダイアログが表示されます。
色の設定ダイアログ
ウィンドウメニューのカラーピッカーを表示しておく事で、カラーピッカーで色を変える事もできます。
ウィンドウメニューのスポイトパレットを表示しておく事で、スポイトパレットで色を変える事もできます。
カット袋ワークスペースの色アイコンを選択する事で色を変える事もできます。
ただし、何れもグレースケール以外の色を選択した場合は無視されます。

彩色画像の場合

デジタル８色のうち背景色として選択している色を除いた７色が選択可能になっています。このボタンを１回クリックすると▼の印が表示されます。この状態でもう一度このボタンを押すと、境界線色に使用できる色のメニューが表示されます。これを使って変更できます。


第３章 応用編

ホーム>>

第３章　応用編

まだ書いている途中です。・・・。

全色トレスについて


全色トレスについて

全色トレスの動画は、実線を色トレス線扱いで使うこともできます。

この場合実線画像をインポート時に作らないか、あるいは、実線画像を削除してください。


第４章 画面の各部の説明

ホーム>>

第４章 画面の各部の説明

ここでは、画面の各部分を説明します。

メインウィンドウ

ここでは、メインウィンドウについて説明します。

キャプションバー

ここでは、キャプションバーの役割について説明します。

スクロールバー

ここでは、スクロールバーの役割について説明します。

システムメニュー

ここでは、システムメニューのコマンドについて説明します。

メニューバー

ここでは、メニューバーのコマンドについて説明します。

コントロールバー

ここでは、コントロールバー（ツールバー・ステータスバー・クールバー・ダイアログバー）の役割について説明します。

ダイアログ

ここでは、各種ダイアログについて説明します。

ビュー

ここでは、AniLaPaintの３種類のビューについて説明します。


メインウィンドウ

ここでは、メインウィンドウについて説明します。

これがAniLaPaintのメインウィンドウです。以下の番号の部分をクリックすると説明が表示されます。


キャプションバー

ここでは、キャプションバーの役割について説明します。

タイトルバーとも呼ばれています。

文字の部分を左ダブルクリックすると、拡大・元のサイズに戻す機能があります。

ボタンの説明は上記のボタンをクリックしてください。

ビューおよびダイアログバーに限って、MacOSのように、タイトルバーのダブルクリックでタイトルバーだけの状態にすることができます。これは環境設定の表示で設定してください。


スクロールバー

ここでは、スクロールバーの役割について説明します。

id_ht_scroll.png (355 バイト)

この部分をスクロールバーと呼びます。縦と横に、スクロール可能な際に表示されます。

端の三角のボタンを押すとその方向へスクロールします。

また、真中のバーを左ボタンを押しながらドラッグしてもその方向へスクロールします。

ボタンとバーの間の余白をクリックすると、画面の４分の１だけその方向へスクロールします。

スクロール自体は左右上下キーで行うこともできます。
Shiftキーを押しながら左右上下キーを押すと高速スクロールになります。


システムメニュー

ここでは、システムメニューのコマンドについて説明します。

ウィンドウの左上のアイコンをクリックした時に表示されるメニューを「システムメニュー」と呼びます。
メインウィンドウと、ビューウィンドウではシステムメニューが少し異なります。
各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

メインウィンドウの場合
メインウィンドウのシステムメニュー
ビューウィンドウの場合
ビューウィンドウのシステムメニュー


元のサイズに戻す

コマンド

  • システムメニュー>>元のサイズに戻す
  • キャプションバー>> 元のサイズに戻す ボタン
  • キャプションバー>>ダブルクリック（元に戻す←→最大化）

このコマンドの意味

ウィンドウを元のサイズに戻す


移動

コマンド

  • システムメニュー>>移動 (*1)
  • キャプションバー>>マウスでドラッグ

このコマンドの意味

ウィンドウの位置を移動する

(*1) キーボードでも移動する場合


サイズ変更

コマンド

  • システムメニュー>>サイズ変更 (*1)
  • ウインドウ粋>>マウスでドラッグ

このコマンドの意味

ウィンドウのサイズを変更する

(*1) キーボードでサイズを変更する場合


最小化

コマンド

  • システムメニュー>>最小化
  • キャプションバー>> 最小化 ボタン

このコマンドの意味

ウィンドウをアイコン化する


最大化

コマンド

  • システムメニュー>>最大化
  • キャプションバー>> 最大化 ボタン
  • キャプションバー>>ダブルクリック（最大化←→元に戻す）

このコマンドの意味

ウィンドウを画面全体に広げる

ウィンドウをメインウィンドウのクライアント領域いっぱいに広げる


閉じる

コマンド

  • システムメニュー>>閉じる
  • キャプションバー>> 閉じる ボタン
  • Ctrl+F4 キー

このコマンドの意味

ウィンドウを閉じる

メインウィンドウのシステムメニューや×ボタンの場合は、アプリケーションを終了


次のウィンドウに移る

コマンド

  • システムメニュー>>次のウィンドウに移る
  • Ctrl+F6 キー

このコマンドの意味

アクティブなビューを次のビューに切り替える


メニューバー

ここでは、メニューバーのコマンドについて説明します。

メインウィンドウのタイトルの下の行にあるメニューを「メニューバー」と呼びます。
各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


ファイル

ファイルをクリックすると、ファイルとカット袋ワークスペースに関するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


新規作成(インポート)

コマンド

  • メニューバー>>ファイル>>新規作成
  • メニューバー>>カット袋>>インポート
  • コントロールバー>>ツールバー>>スタンダード>> 新規作成（インポート） ボタン
  • Ctrl+N キー

このコマンドの意味

セルアニメーションの作画方法で描がかれスキャナーで取り込まれたフルカラーの画像ファイルを、AniLaPaintで扱える形式に加工します。
詳しくは、「インポートについて」をお読みください。
このコマンドを選択すると、新規作成(インポート)ウィザードが表示されます。
新規作成(インポート)ウィザードを使いインポートした結果、次のAniLaPaint画像が新規に作成されます。
画像の種類 | ファイルの拡張子
実線画像 | anl
彩色画像 | anp


開く...

コマンド

  • メニューバー>>ファイル>>開く...
  • コントロールバー>>ツールバー>>スタンダード>> ファイルを開く ボタン
  • Ctrl+N キー

このコマンドの意味

既存の画像ファイルを開きます。
このコマンドを選択すると、「ファイルを開くダイアログ」が表示されます。
ファイルの種類によって、表示されるビューや編集可能か表示のみかが異なります。
   画像の種類 | ファイルの拡張子 | ビュー | 画像の編集
AniLaPaint画像 | 実線画像 | anl | 実線画像のビュー | 可能
彩色画像 | anp | 彩色画像のビュー
セル画像 anc セル画像のビュー

表示のみ
マスク画像 | anm
その他の画像 | Zsoft PCX 形式 | pcx
Truevision TARGA 形式 | tga
Portable Network Graphics形式 | png
Adobe Photoshop 3.0 形式 | psd
TIFF 形式 (LZW圧縮不可) | tif
Jpeg ファイル形式 | jpg,jpeg
Lead CMP形式 | cmp
SUN Raster 形式 | ras
Macintosh Pict 形式 | pct
Windows ビットマップ 形式 | bmp
Windows メタファイル 形式 | wmf
AniLaPaint画像を開いた場合で、同じフォルダのカット袋ワークスペースが開かれていない場合、カット袋ワークスペースを同時に開くかどうかをたずねてきます。
なお、既に開いているファイルの一覧は、メニューバー>>ウィンドウに表示されております。
また、最近開いたファイルの場合、メニューバー>>ファイル>>最近のファイルから開く事も出来ます。


閉じる

コマンド

  • メニューバー>>ファイル>>閉じる
  • Ctrl+F4 キー

このコマンドの意味

現在アクティブなビューを閉じます。
ビューを閉じる前に、画像が変更されている場合は保存するかどうか確認するメッセージボックスが表示されます。
画像を保存しないで閉じた場合、前回の保存時以降に加えた変更内容はすべて失われます。


カット袋ワークスペースを開く

コマンド

  • メニューバー>>ファイル>>カット袋ワークスペースを開く
  • コントロールバー>>ツールバー>>スタンダード>> カット袋ワークスペースを開く ボタン
  • カット袋ワークスペース>>アイコンメニュー>>カット袋ワークスペースを開く

このコマンドの意味

カット袋ワークスペースについては「カット袋ワークスペースについて」をご覧ください。

このコマンドにより、フォルダ選択ダイアログが表示されます。この時、新規作成で作成したAniLaPaint画像のあるフォルダを選択してください。それ以外のフォルダを選択した場合は、空のカット袋ワークスペースファイルを作る事になります。
カット袋ワークスペースを開くと、フォルダ内の画像のサムネイル一覧や、そのフォルダに関連付けられた色アイコンが表示されます。

「メニューバー>>ファイル>> 開く 開く」コマンドを実行してAniLaPaint画像を開いた時に、同じフォルダのカット袋ワークスペースが開かれていないと、開くかどうかを聞いてきます。そこでで開いた場合も同じことになります。

カット袋ワークスペースファイルの保存は常に自動的に行われます。また、一度に開けるカット袋ワークスペースは常に１つとなっております。

カット袋ワークスペースを開かなくても、AniLaPaint画像を個別に開いて編集する事はできます。しかし、色アイコンや、ビルド・リビルド・エクスポートなど、重要な機能が使えなくなります。通常は、常に編集中の画像があるフォルダをカット袋ワークスペースで開いておくことをお勧めします。

また、最近開いたカット袋ワークスペースの場合は、最近のカット袋ワークスペースから開く事ができます。


カット袋ワークスペースを閉じる

コマンド

  • メニューバー>>ファイル>>カット袋ワークスペースを閉じる
  • カット袋ワークスペース>>アイコンメニュー>>カット袋ワークスペースを閉じる

このコマンドの意味

既に開いているカット袋ワークスペースを閉じます。


上書き保存

コマンド

  • メニューバー>>ファイル>>上書き保存
  • コントロールバー>>ツールバー>>スタンダード>> 上書き保存 ボタン
  • Ctrl+S キー

このコマンドの意味

編集中のビューの画像を、ファイル名・保存場所を変更しないで上書き保存します。
ファイル名・保存場所を変更して保存したいときは、メニューバー>>ファイル>>名前を付けて保存コマンド を使います。

※表示のみの画像の場合はこのコマンドを使用できません。


名前を付けて保存

コマンド

  • メニューバー>>ファイル>>名前を付けて保存

このコマンドの意味

編集中のビューの画像に、現在とは違うファイル名を付けて保存できます。
このコマンドを選択すると、 [名前を付けて保存] ダイアログ ボックスが表示されます。
ここで、適切なファイル名を付けて保存することができます。
作業中の画像のファイル名、保存場所を変更しないで保存したいときはメニューバー>>ファイル>> 上書き保存 上書き保存を使います。

※表示のみの画像の場合はこのコマンドを使用できません。


すべて保存

コマンド

  • メニューバー>>ファイル>>すべて保存
  • コントロールバー>>ツールバー>>スタンダード>> すべて保存 ボタン

このコマンドの意味

現在編集中の全てのビューの中で、変更された画像を全て上書保存します。
変更された画像が無い場合、このコマンドは選択できないようになります。


バッチ処理

バッチ処理とは、複数のフォルダにあるカット袋ワークスペースに対して、自動的・連続的に同じ操作をする処理の事です。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


複数のカット袋の全更新ビルド

コマンド

  • メニューバー>>ファイル>>バッチ処理>>複数のカット袋の全更新ビルド

このコマンドの意味

ビルドについて詳しくは、「セル画像のビルドについて」をお読みください。

このコマンドは、メニューバー>>カット袋>> 全更新ビルド 全更新ビルドとは違い、カット袋ワークスペースを開いていなくても利用できます。
複数のフォルダを指定して、実線画像と彩色画像からタイムスタンプを比較して新しくセル画像およびマスク画像を作成する時に使います。
同名のファイルが実線画像のみの場合、実線だけのセル画像とマスク画像を生成します。
同名のファイルが彩色画像のみの場合、実線なしの（全色トレスの）セル画像とマスク画像を生成します。
このコマンドを実行すると、「セル画像を複数フォルダで一括作成」ダイアログが表示されます。
このコマンドで作成された、セル画像およびマスク画像は、カット袋ワークスペースやメニューバー>>ファイル>> 開く 開くコマンドで開いて確認する事ができます。


複数のカット袋のリビルド

コマンド

  • メニューバー>>ファイル>>バッチ処理>>複数のカット袋のリビルド

このコマンドの意味

ビルドについて詳しくは、「セル画像のビルドについて」をお読みください。

このコマンドは、メニューバー>>カット袋>>リビルドとは違い、カット袋ワークスペースを開いていなくても利用できます。
複数のフォルダを指定して、実線画像と彩色画像から全ての セル画像およびマスク画像を作成しなおす時に使います。
同名のファイルが実線画像のみの場合、実線だけのセル画像とマスク画像を生成します。
同名のファイルが彩色画像のみの場合、実線なしの（全色トレスの）セル画像とマスク画像を生成します。
このコマンドを実行すると、「セル画像を複数フォルダで一括作成」ダイアログが表示されます。
このコマンドで作成された、セル画像およびマスク画像は、カット袋ワークスペースやメニューバー>>ファイル>>開くコマンドで開いて確認する事ができます。


環境設定

コマンド

  • メニューバー>>ファイル>>環境設定

このコマンドの意味

AniLaPaint の環境設定を変更します。
このコマンドを選択すると、「環境設定」ダイアログが表示されます。
このダイアログを [OK] で戻ると、その時点から新しい環境で動作します。
この設定はレジストリに保存されるので、次回の起動時にも継続されます。


最近使ったファイル

コマンド

  • メニューバー>>ファイル>>最近使ったファイル
  • コントロールバー>>ツールバー>>スタンダード>> ファイルを開く の▼ボタン

このコマンドの意味

最近開いたファイル名が最大 10 個までメニュー表示されます。
メニューバー>>ファイル>>開くコマンドを実行してファイルを選択するよりも早く目的のファイルを開く事が出来ます。

また、ver 1.2.5.12 からは、「履歴の消去」コマンドが追加されました。このコマンドを選択すると、最近使ったファイルの一覧が消去されます。


最近使ったカット袋ワークスペース

コマンド

  • メニューバー>>ファイル>>最近使ったカット袋ワークスペース
  • コントロールバー>>ツールバー>>スタンダード>> カット袋ワークスペースを開く の▼ボタン

このコマンドの意味

最近開いたカット袋ワークスペースが最大 10 個までメニュー表示されます。
メニューバー>>ファイル>>カット袋ワークスペースを開くコマンドを実行してフォルダを選択よりも早く目的のカット袋ワークスペースを開くことができます。

また、ver 1.2.5.12 からは、「履歴の消去」コマンドが追加されました。このコマンドを選択すると、最近使ったカット袋ワークスペースの一覧が消去されます。


終了

コマンド

  • メニューバー>>ファイル>>終了
  • メインウィンドウ>>システムメニュー>>閉じる
  • メインウィンドウ>>キャプションバー>> 閉じる ボタン
  • Alt+F4 キー

このコマンドの意味

AniLaPaint を終了します。
文書に加えた変更点がまだ保存されていないときは、AniLaPaint は保存するかどうか確認するダイアログ ボックスを表示します。


編集

編集をクリックすると、ビューにおける画像の編集に関するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


元に戻す

コマンド

  • メニューバー>>編集>>元に戻す
  • コントロールバー>>ツールバー>>スタンダード>> 元に戻す ボタン
  • Ctrl+Z キー

このコマンドの意味

ビューの画像の編集時に、直前に行った編集操作をキャンセルし、画像を元に戻します。
このコマンドが正常に実行できるために、メニューバー>>ファイル>>環境設定>>環境設定ダイアログ>>Undoを正しく設定しておく必要があります。

※表示のみの画像の場合はこのコマンドを使用できません。


元に戻すの取り消し

コマンド

  • メニューバー>>編集>>元に戻すの取り消し
  • コントロールバー>>ツールバー>>スタンダード>> 元に戻すの取り消し ボタン
  • Ctrl+Y キー

このコマンドの意味

ビューの画像の編集時に、メニューバー>>編集>>元に戻すコマンドで戻した画像を取り消し、元に戻す前の状態に戻します。
このコマンドが正常に実行できるために、メニューバー>>ファイル>>環境設定>>環境設定ダイアログ>>Undoを正しく設定しておく必要があります。

※表示のみの画像の場合はこのコマンドを使用できません。


元に戻す機能の停止

コマンド

  • メニューバー>>編集>>元に戻す機能の停止
  • コントロールバー>>ツールバー>>スタンダード>> 元に戻す機能の停止 ボタン

このコマンドの意味

ビューの画像の編集時に、メニューバー>>編集>>元に戻す機能を停止します。
これは、塗りスピード高速化したい場面で元に戻す必要があまりないバケツ塗りなどの時に使います。
再び、元に戻す機能を有効にするには、このコマンドをもう一度実行します。

注意）
このコマンドを実行すると他のビューも含めて全ての元に戻すためのデータを破棄します。そのため再び「元に戻す」機能を有効にしても、全てのビューでその時点以前に戻す事はできなくなります。


ツール

ツールをクリックすると、ビューにおける画像の編集ツールに関するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、スポイトツールのみ使用できます。


選択ツール

選択ツールをクリックすると、画像表面をドラッグすることで指定した形のラバーバンドを使い、ペイントできる範囲を選択するためのツールが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、スポイトツールのみ使用できます。


矩形

コマンド

  • メニューバー>>ツール>>選択ツール>>矩形
  • コントロールバー>>ツールバー>>ペイント>> 矩形 ボタン

このコマンドの意味

画像に矩形の選択範囲を作るためのツールです。このコマンドを実行した後、画像の表面をマウスの左ボタンを押したままで動かすと、矩形の領域が指定できます。

選択された領域の内部だけペイントできます。選択されていない部分はペイントできません。
選択領域に関する操作には、選択範囲メニューや選択範囲クールバーも使います。

※表示のみの画像の場合は、このコマンドは使用できません。


楕円

コマンド

  • メニューバー>>ツール>>選択ツール>>楕円
  • コントロールバー>>ツールバー>>ペイント>> 楕円 ボタン

このコマンドの意味

画像に楕円の選択範囲を作るためのツールです。このコマンドを実行した後、画像の表面をマウスの左ボタンを押したままで動かすと、楕円の領域が指定できます。

選択された領域の内部だけペイントできます。選択されていない部分はペイントできません。
選択領域に関する操作には、選択範囲メニューや選択範囲クールバーも使います。

※表示のみの画像の場合は、このコマンドは使用できません。


なげなわツール

なげなわツールをクリックすると、画像表面をドラッグすることで、マウスが移動した軌跡のラバーバンドを使い、ペイントできる範囲を選択するためのツールが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、スポイトツールのみ使用できます。


フリーハンド

コマンド

  • メニューバー>>ツール>>なげなわツール>>フリーハンド
  • コントロールバー>>ツールバー>>ペイント>> フリーハンド ボタン

このコマンドの意味

画像にフリーハンドの選択範囲を作るためのツールです。このコマンドを実行した後、画像の表面をマウスの左ボタンを押したままで動かすと、フリーハンドの領域が指定できます。

選択された領域の内部だけペイントできます。選択されていない部分はペイントできません。
選択領域に関する操作には、選択範囲メニューや選択範囲クールバーも使います。

※表示のみの画像の場合は、このコマンドは使用できません。


自動選択ツール

コマンド

  • メニューバー>>ツール>>自動選択ツール
  • コントロールバー>>ツールバー>>ペイント>> 自動選択ツール ボタン

このコマンドの意味

画像に同じ色で連続した領域の選択範囲を作るためのツールです。このコマンドを実行した後、画像の領域を作りたい場所の色をマウスの左ボタンを押すと、その色が連続している領域が指定できます。
選択された領域の内部だけペイントできます。選択されていない部分はペイントできません。
選択領域に関する操作には、選択範囲メニューや選択範囲クールバーも使います。

※表示のみの画像の場合は、このコマンドは使用できません。


色保護ツール

コマンド

  • メニューバー>>ツール>>色保護ツール
  • コントロールバー>>ツールバー>>ペイント>> 色保護ツール ボタン

このコマンドの意味

画像に上書き禁止の色の保護領域を作るためのツールです。このコマンドを実行すると、保護されている領域に網掛けが表示されます。保護したい色をマウスの左ボタンでクリックすると、網掛けがかかり色が保護された状態になります。保護を解除したい場合は、網掛けがかかっている色を左ボタンでクリックすると、保護が解除されます。

保護された領域はペイントできなくなります。保護されていない部分はペイントできます。
保護領域に関する操作には、色保護メニューや色保護クールバーを使います。

※このコマンドは、彩色画像にのみ使用できます。


ブラシツール

コマンド

  • メニューバー>>ツール>>ブラシツール
  • コントロールバー>>ツールバー>>ペイント>> ブラシツール ボタン

このコマンドの意味

画像にブラシでペイントするためのツールです。このコマンドを実行した後、ブラシでペイントしたい場所をマウスの左ボタンを押したまま動かしてください。クールバー上のペン幅や透明度・暈し率も同時に使います。
実線画像では、背景色か境界線色で全ての部分にペイントできます。実線の付け足しなどに利用できます。

彩色画像では、標準ペイント色でペイントできますが、背景色や境界線色の部分にはペイントできません。タッチの効果などに利用できます。

※表示のみの画像の場合は、このコマンドは使用できません。


鉛筆ツール

コマンド

  • メニューバー>>ツール>>鉛筆ツール
  • コントロールバー>>ツールバー>>ペイント>> 鉛筆ツール ボタン

このコマンドの意味

画像にソリッドペン（暈けていない色）でペイントするためのツールです。このコマンドを実行した後、ペンでペイントしたい場所をマウスの左ボタンを押したまま動かしてください。クールバー上のペン幅も同時に使います。
実線画像では、背景色か境界線色で全ての部分にペイントできます。実線の付け足しなどに利用できます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


塗りつぶしツール

塗りつぶしツールをクリックすると、同じ色で画像をある領域を塗りつぶすためのツールが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、スポイトツールのみ使用できます。


バケツ

コマンド

  • メニューバー>>ツール>>塗りつぶしツール>>バケツ
  • コントロールバー>>ツールバー>>ペイント>> バケツ ボタン

このコマンドの意味

画像にバケツ（フィル）でペイントするためのツールです。このコマンドを実行した後、ペイントしたい場所をマウスの左ボタンでクリックしてください。同じ色の連続した範囲が現在の色でペイントされます。もし、色が期待した範囲を超えて漏れ出すようなら、鉛筆ツールを使って境界線が途切れている部分をふさいでからこのコマンドを実行してください。
実線画像では、背景色か境界線色で全ての部分にペイントできます。ただし、バケツを使う用途は限られています。強調表示／マスク表示になっている場合に、背景色で、連続した線を一気に消す時などに使います。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


色の置き換え

コマンド

  • メニューバー>>ツール>>塗りつぶしツール>>色の置き換え
  • コントロールバー>>ツールバー>>ペイント>> 色の置き換え ボタン

このコマンドの意味

画像の色を指定して他の色に置き換えるためのツールです。このコマンドを実行した後、マウスの左ボタンでクリックした部分と同じ色の領域全てが現在の色で置き換えられます。

標準ペイント色か背景色か境界線色で全ての部分で置き換え可能です。ただし、デフォルトで境界線色の部分は保護されているので、置き換えができません。置き換えたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※このコマンドは、彩色画像にのみ使用できます。


矩形

コマンド

  • メニューバー>>ツール>>塗りつぶしツール>>矩形
  • コントロールバー>>ツールバー>>ペイント>> 矩形 ボタン

このコマンドの意味

画像に矩形でペイントするためのツールです。このコマンドを実行した後、ペイントしたい場所をマウスの左ボタンを押しながら移動してください。すると、ペイントされる矩形の領域が反転表示されます。このとき、Shift キーを押すと正方形の領域が反転表示されます。また、Ctrl キーを押すと、最初に左ボタンを押した場所を中心にした領域が反転表示されます。ペイントする領域が決まったら、マウスのボタンを離してください。ペイントしたくない時は、マウスの左ボタンは押したままで、右ボタンをクリックしてください。すると、反転表示が消えるので、その後、左ボタンを離してください。

実線画像では、背景色か境界線色で全ての部分にペイントできます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


楕円

コマンド

  • メニューバー>>ツール>>塗りつぶしツール>>楕円
  • コントロールバー>>ツールバー>>ペイント>> 楕円 ボタン

このコマンドの意味

画像に楕円でペイントするためのツールです。このコマンドを実行した後、ペイントしたい場所をマウスの左ボタンを押しながら移動してください。すると、ペイントされる楕円の領域が反転表示されます。このとき、Shift キーを押すと真円の領域が反転表示されます。また、Ctrl キーを押すと、最初に左ボタンを押した場所を中心にした領域が反転表示されます。ペイントする領域が決まったら、マウスのボタンを離してください。ペイントしたくない時は、マウスの左ボタンは押したままで、右ボタンをクリックしてください。すると、反転表示が消えるので、その後、左ボタンを離してください。
実線画像では、背景色か境界線色で全ての部分にペイントできます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


フリーハンド

コマンド

  • メニューバー>>ツール>>塗りつぶしツール>>フリーハンド
  • コントロールバー>>ツールバー>>ペイント>> フリーハンド ボタン

このコマンドの意味

画像にフリーハンドで囲んだ領域をペイントするためのツールです。このコマンドを実行した後、ペイントしたい場所をマウスの左ボタンを押しながら移動してください。すると、マウスポインタが移動した部分が線として表示されます。現在の色で塗りたい部分をこの線で囲みます。囲んだら、マウスのボタンを離してください。なお、完全に囲む必要はありません。マウスのボタンを離した時点で、最初の点と最後の点が自動的に結ばれます。ペイントしたくない時は、マウスの左ボタンは押したままで、右ボタンをクリックしてください。すると、線が消えるので、その後、左ボタンを離してください。
実線画像では、背景色か境界線色で全ての部分にペイントできます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


ラインツール

ラインツールをクリックすると、マウスのクリックによる複数の点と、ダブルクリックによる最後の点の指定方法による、画像のペイントツールを表示します。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、スポイトツールのみ使用できます。


折れ線

コマンド

  • メニューバー>>ツール>>ラインツール>>折れ線
  • コントロールバー>>ツールバー>>ペイント>> 折れ線 ボタン

このコマンドの意味

画像に折れ線でペイントするためのツールです。このコマンドを実行した後、線を引きたい最初の場所をマウスの左ボタンでクリックしてください。すると、最初の頂点が決まります。次々と、マウスの左ボタンでクリックすることで、折れ線の頂点が決まっていきます。このとき、マウスの右ボタンをクリックすると、一つ前の頂点を解除できます。最後の頂点の部分では、マウスの左ボタンをダブルクリックしてください。クールバー上のペン幅も同時に使います。

実線画像では、背景色か境界線色で全ての部分にペイントできます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


多角形

コマンド

  • メニューバー>>ツール>>ラインツール>>多角形
  • コントロールバー>>ツールバー>>ペイント>> 多角形 ボタン

このコマンドの意味

画像に多角形をペイントするためのツールです。このコマンドを実行した後、線を引きたい最初の場所をマウスの左ボタンでクリックしてください。すると、最初の頂点が決まります。次々と、マウスの左ボタンでクリックすることで、多角形の頂点が決まっていきます。このとき、マウスの右ボタンをクリックすると、一つ前の頂点を解除できます。最後の頂点の部分では、マウスの左ボタンをダブルクリックしてください。折れ線との違いは、最初の頂点と最後の頂点が自動的に結ばれる点です。クールバー上のペン幅も同時に使います。
実線画像では、背景色か境界線色で全ての部分にペイントできます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


多角形塗りつぶし

コマンド

  • メニューバー>>ツール>>ラインツール>>多角形塗りつぶし
  • コントロールバー>>ツールバー>>ペイント>> 多角形塗りつぶし ボタン

このコマンドの意味

画像に多角形（フィル）をペイントするためのツールです。このコマンドを実行した後、最初の頂点の場所をマウスの左ボタンでクリックしてください。次々と、マウスの左ボタンでクリックすることで、多角形の頂点が決まっていきます。このとき、マウスの右ボタンをクリックすると、一つ前の頂点を解除できます。最後の頂点の部分では、マウスの左ボタンをダブルクリックしてください。多角形との違いは、線に太さが無く、内部が塗りつぶされる点です。クールバー上のペン幅も同時に使います。
実線画像では、背景色か境界線色で全ての部分にペイントできます。

彩色画像では、標準ペイント色か背景色か境界線色で全ての部分にペイントできます。ただし、デフォルトで境界線色の部分は保護されているので、ペイントできません。ペイントしたい場合は、色保護メニューか色保護クールバーの境界線色で保護解除をするか、又は、反転有効か無効にする必要があります。

※表示のみの画像の場合は、このコマンドは使用できません。


スポイトツール

コマンド

  • メニューバー>>ツール>>スポイトツール
  • コントロールバー>>ツールバー>>ペイント>> スポイトツール ボタン
  • Ctrl + 左クリック（一時的コマンド）
  • 右クリック （環境設定ダイアログ>>表示タブ内で設定した場合のみ）（一時的コマンド）

このコマンドの意味

画像の色をスポイトで拾い、標準ペイント色に選択するためのツールです。このコマンドを実行した後、拾いたい色の上で、マウスの左ボタンをクリックしてください。このツールを選択した場合、スポイトモードから復帰するには別のツールを改めて選択する必要があります。このコマンドはあくまで、ビューをスポイト専用のビューとして一時的に固定し、別のビューに色を塗る際に便利です。

同一のビューの別の場所の色をスポイトで拾いたい場合には、Ctrlキーを押しながら左ボタンをクリックをすることで、ペイントツールを変更する手間が省けます。

また、右クリックによるコンテキストメニューが必要ない方は、メニューバー>>ファイル>>環境設定>>環境設定ダイアログ>>表示タブ内の設定を変更して、右クリックをスポイトに割り当てることもできます。


色保護

色保護をクリックすると、色保護ツールで保護された色の領域や、境界線の保護状態などに関するメニューが表示されます。色保護とは、特定の色を変更禁止とする機能の事で、他には色シールド、カラーシールドなとども呼ばれます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※このコマンドは、彩色画像にのみ使用できます。


有効

コマンド

  • メニューバー>>色保護>>有効
  • コントロールバー>>クールバー>>色保護>> 有効 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドはこれらの色の保護状態を有効にします。

色の保護状態は、他に 反転有効 反転有効・ 無効 無効があります。

※このコマンドは、彩色画像にのみ使用できます。


反転有効

コマンド

  • メニューバー>>色保護>>反転有効
  • コントロールバー>>クールバー>>色保護>> 反転有効 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドはこれらの色の保護状態を反転し有効にします。つまり、保護色と非保護色を一時的に反転する機能です。これは例えば、タッチの効果など境界線だけに色を付けたい場合などに有効です。その場合、メニューバー>>色保護>> 色保護領域を常に更新 色保護領域を常に更新と合わせて使うと便利です。

色の反転状態は、他に 有効 有効・ 無効 無効があります。

※このコマンドは、彩色画像にのみ使用できます。


無効

コマンド

  • メニューバー>>色保護>>無効
  • コントロールバー>>クールバー>>色保護>> 無効 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドはこれらの色の保護状態を無効にし、どの部分でも上書きできる状態にします。つまり、保護色が設定されていても、一時的に無効にする機能です。

色の反転状態は、他に 有効 有効・ 反転有効 反転有効があります。

※このコマンドは、彩色画像にのみ使用できます。


色保護領域を常に更新

コマンド

  • メニューバー>>色保護>>色保護領域を常に更新
  • コントロールバー>>クールバー>>色保護>> 色保護領域を常に更新 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドはオン・オフのトグルになっており、オンの場合はペイント中も常に保護領域を更新していきます。

つまり、保護されている色でペイントした場合、その色はすぐに保護されてどんな色で上書きする事もできなくなります。これがデフォルトなのですが、失敗した場合はメニューバー>>編集>> 元に戻す 元に戻すで消せばよいので通常問題はおきません。

しかし、保護領域を更新して欲しくない場合もあります。それは例えば、境界線に色を付けたい場合などで、メニューバー>>色保護>> 反転有効 反転有効を利用して、境界線の部分だけにペイントできる状態にしたとします。ここに、標準ペイント色を塗ってタッチの効果を出したい時、塗った部分は境界線ではないので次々と保護されていってしまいます。ペンなどを利用した場合、ほんのちょっとはみ出ただけなどの時には元に戻すよりはそのはみ出た部分だけを修正したいのですが、色保護領域が常に更新されていると、その部分に元の色を上書きして塗ろうとしても保護されていて塗れません。こんなときには、このコマンドをオフにしておくと便利です。このコマンドをオフにすると、最後にオンだった状態の保護領域が変化しません。すなわち、反転有効にして境界線だけに色を塗れる状態にした時に、その領域が変化しないので、何度でも上塗りが可能となります。このような使い方のために、このコマンドは存在します。

もう１つの使い道は、保護された色が多い場合、元に戻すなどで複数回戻す時、その度に保護領域を作成するためにオーバーヘッドが大きくなります。一時的にこのコマンドをオフにしておくと、元に戻す動作が速くなります。

※このコマンドは、彩色画像にのみ使用できます。


設定色

設定色をクリックすると、標準ペイント色と背景色の保護状態に関するメニューを表示します。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※このコマンドは、彩色画像にのみ使用できます。


全て解除

コマンド

  • メニューバー>>色保護>>全て解除
  • コントロールバー>>クールバー>>色保護>> 全て解除 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち標準ペイント色や背景色にあたる色の保護状態を全て解除します。境界線色の保護状態はそのままです。

※このコマンドは、彩色画像にのみ使用できます。


境界線色

境界線色をクリックすると、境界線色の保護状態を表すメニューが表示されます。現在の背景色として使われている色は、選択できないようになっています。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※このコマンドは、彩色画像にのみ使用できます。


白

コマンド

  • メニューバー>>色保護>>境界線色>>白
  • コントロールバー>>クールバー>>色保護>> 白 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・白の保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


赤

コマンド

  • メニューバー>>色保護>>境界線色>>赤
  • コントロールバー>>クールバー>>色保護>> 赤 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・赤の保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


緑

コマンド

  • メニューバー>>色保護>>境界線色>>緑
  • コントロールバー>>クールバー>>色保護>> 緑 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・緑の保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


青

コマンド

  • メニューバー>>色保護>>境界線色>>青
  • コントロールバー>>クールバー>>色保護>> 青 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・青の保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


シアン

コマンド

  • メニューバー>>色保護>>境界線色>>シアン
  • コントロールバー>>クールバー>>色保護>> シアン ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・シアンの保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


マゼンタ

コマンド

  • メニューバー>>色保護>>境界線色>>マゼンタ
  • コントロールバー>>クールバー>>色保護>> マゼンタ ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・マゼンタの保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


イエロー

コマンド

  • メニューバー>>色保護>>境界線色>>イエロー
  • コントロールバー>>クールバー>>色保護>> イエロー ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・イエローの保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


黒

コマンド

  • メニューバー>>色保護>>境界線色>>黒
  • コントロールバー>>クールバー>>色保護>> 黒 ボタン

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色・黒の保護状態を変更する機能です。

※このコマンドは、彩色画像にのみ使用できます。


全て保護

コマンド

  • メニューバー>>色保護>>境界線色>>全て保護

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色にあたる色を全て保護します。標準ペイント色や背景色の保護状態はそのままです。

※このコマンドは、彩色画像にのみ使用できます。


全て解除

コマンド

  • メニューバー>>色保護>>境界線色>>全て解除

このコマンドの意味

通常、境界線色には彩色できないように保護されています。また、メニューバー>>ツール>> 色保護ツール 色保護ツールで指定した色も保護されます。このコマンドは、それらの保護された色のうち境界線色にあたる色の保護状態を全て解除します。標準ペイント色や背景色の保護状態はそのままです。

※このコマンドは、彩色画像にのみ使用できます。


選択範囲

選択範囲をクリックすると、選択ツール・なげなわツール・自動選択ツールを利用して作られた選択範囲に関するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、このコマンドは使用できません。


有効

コマンド

  • メニューバー>>選択範囲>>有効
  • コントロールバー>>クールバー>>選択範囲>> 有効 ボタン

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して作られた選択範囲外の部分の保護状態を有効にします。

※表示のみの画像の場合は、このコマンドは使用できません。


無効

コマンド

  • メニューバー>>選択範囲>>無効
  • コントロールバー>>クールバー>>選択範囲>> 無効 ボタン

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して作られた選択範囲外の部分の保護状態を無効にします。ただし、選択範囲そのものは表示されたままです。

※表示のみの画像の場合は、このコマンドは使用できません。


全て選択する

コマンド

  • メニューバー>>選択範囲>>全て選択する
  • Ctrl+A キー

このコマンドの意味

画像全体を選択範囲にします。

※表示のみの画像の場合は、このコマンドは使用できません。


選択範囲の反転

コマンド

  • メニューバー>>選択範囲>>選択範囲の反転
  • コントロールバー>>クールバー>>選択範囲>> 選択範囲の反転 ボタン
  • Shift+Ctrl+I キー

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して作られた選択範囲と選択範囲外を反転します。

※表示のみの画像の場合は、このコマンドは使用できません。


選択範囲の解除

コマンド

  • メニューバー>>選択範囲>>選択範囲の解除
  • コントロールバー>>クールバー>>選択範囲>> 選択範囲の解除 ボタン
  • Ctrl+D キー

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して作られた選択範囲を解除します。

※表示のみの画像の場合は、このコマンドは使用できません。


選択範囲の合成方法

選択範囲の合成方法をクリックすると、現在選択範囲がある場合、その選択範囲と次に指定した選択範囲の合成方法を指定するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

※表示のみの画像の場合は、このコマンドは使用できません。


新たに作る

コマンド

  • メニューバー>>選択範囲>>選択範囲の合成方法>>新たに作る
  • コントロールバー>>クールバー>>選択範囲> 新たに作る >ボタン

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して選択範囲を作成する際に、現在の選択範囲は解除して新しい選択範囲を作ります。

※表示のみの画像の場合は、このコマンドは使用できません。


加える

コマンド

  • メニューバー>>選択範囲>>選択範囲の合成方法>>加える
  • コントロールバー>>クールバー>>選択範囲>> 加える ボタン
  • Ctrl+Shift キー (選択ツール・なげなわツール・自動選択ツールで新たに作るモードの時にのみ有功)

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して選択範囲を作成する際に、現在の選択範囲に新たな選択範囲を加えます。

※表示のみの画像の場合は、このコマンドは使用できません。


差し引く

コマンド

  • メニューバー>>選択範囲>>選択範囲の合成方法>>差し引く
  • コントロールバー>>クールバー>>選択範囲>> 差し引く ボタン
  • Ctrl+Alt キー (選択ツール・なげなわツール・自動選択ツールで新たに作るモードの時にのみ有功)

このコマンドの意味

選択ツール・なげなわツール・自動選択ツールを利用して選択範囲を作成する際に、現在の選択範囲から新たな選択範囲を差し引きます。

※表示のみの画像の場合は、このコマンドは使用できません。


カット袋

カット袋をクリックすると、メニューバー>>ファイル>>カット袋ワークスペースを開くなどを使用して開いたカット袋ワークスペースを操作するためのメニューを表示します。カット袋ワークスペースを開いていない場合は選択できないメニューがあります。また、カット袋ワークスペースのウィンドウ上でマウスの右ボタンを押して表示されるメニューはこのメニューのサブセットとなっています。

カット袋ワークスペースのタブの状態によって次のどちらかのメニューが表示されます。 各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

▼タブが、実線・彩色・セルの何れかの場合
メニューバー>>カット袋 		▼タブが、色の場合
メニューバー>>カット袋


表示

表示をクリックすると、カット袋ワークスペースのサムネイル（アイコン）の表示状態を変更するためのメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

.


実線画像

コマンド

  • メニューバー>>カット袋>>表示>>実線画像
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>実線タブをクリック
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>実線画像

このコマンドの意味

カット袋ワークスペースの表示を実線画像に切り替えます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


彩色画像

コマンド

  • メニューバー>>カット袋>>表示>>彩色画像
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>彩色タブをクリック
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>彩色画像

このコマンドの意味

カット袋ワークスペースの表示を彩色画像に切り替えます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


セル画像

コマンド

  • メニューバー>>カット袋>>表示>>セル画像
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>セルタブをクリック
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>セル画像

このコマンドの意味

カット袋ワークスペースの表示をセル画像に切り替えます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


色アイコン

コマンド

  • メニューバー>>カット袋>>表示>>色アイコン
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>色タブをクリック
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>色アイコン

このコマンドの意味

カット袋ワークスペースの表示を色アイコンに切り替えます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


大きなアイコン (Windows準拠)

コマンド

  • メニューバー>>カット袋>>表示>> 大きなアイコン (Windows準拠) 大きなアイコン (Windows準拠)
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>大きなアイコン (Windows準拠)

このコマンドの意味

カット袋ワークスペースの表示を大きなアイコン (Windows準拠)に切り替えます。文字を下に持つアイコンを表示します。このアイコンの間隔はシステムの画面のプロパティーのデザインで設定したものと同一になります。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


大きなアイコン (詰めて表示)

コマンド

  • メニューバー>>カット袋>>表示>> 大きなアイコン (詰めて表示) 大きなアイコン (詰めて表示)
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>大きなアイコン (詰めて表示)

このコマンドの意味

カット袋ワークスペースの表示を大きなアイコン (詰めて表示)に切り替えます。文字を右に持つアイコンを表示します。このアイコンの間隔は詰めて表示されるので一度に多くの行を表示可能です。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


最新の情報に更新

コマンド

  • メニューバー>>カット袋>>表示>> 最新の情報に更新 最新の情報に更新
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>最新の情報に更新

このコマンドの意味

カット袋ワークスペースの表示をディスク上のファイル更新状況をチェックしなおし最新の情報に更新します。通常画像自体が更新されるとサムネイルも自動的に更新されます。しかし、外部のエディタで更新した場合など自動的には更新されない場合もあります。このような場合にこのコマンドを使ってください。色アイコンのリンク先のパレットファイルがネットワーク上にあり、他のAniLaPaintで色の情報を変更した際にもこのコマンドを使い最新の情報に更新する事ができます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


情報の更新を禁止

コマンド

  • メニューバー>>カット袋>>表示>>情報の更新を禁止
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>表示>>情報の更新を禁止
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> id_pjw_no_update.png (177 バイト) ボタン

このコマンドの意味

通常、カット袋ワークスペースの表示はをディスク上のファイル更新状況をチェックしなおし最新の情報に常に更新しています。
このコマンドでは、その機能を一時的に禁止します。サイズの大きなファイルを扱う際に頻繁なサムネイルの更新を抑止することができます。

禁止を解除した時に、自動的に更新されます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンの整列

アイコンの整列をクリックすると、カット袋ワークスペースのアイコンの順序を変更するためのメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


名前順

コマンド

  • メニューバー>>カット袋>>アイコンの整列>> 名前順 名前順
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>アイコンの整列>>名前順

このコマンドの意味

カット袋ワークスペースのアイコンの表示をに切り替えます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


時間順

コマンド

  • メニューバー>>カット袋>>アイコンの整列>> 時間順 時間順
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>アイコンの整列>>時間順

このコマンドの意味

カット袋ワークスペースのアイコンの表示をファイル更新日時順に切り替えます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


昇順

コマンド

  • メニューバー>>カット袋>>アイコンの整列>> 昇順 昇順
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>アイコンの整列>>昇順

このコマンドの意味

カット袋ワークスペースのアイコンの表示を昇順に切り替えます。つまり、名前順になっている場合には番号の小さい順に表示され、時間順になっている場合はファイル更新日時の新しい順に表示されます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


降順

コマンド

  • メニューバー>>カット袋>>アイコンの整列>> 降順 降順
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>アイコンの整列>>降順

このコマンドの意味

カット袋ワークスペースのアイコンの表示を降順に切り替えます。つまり、名前順になっている場合には番号の大きい順に表示され、時間順になっている場合はファイル更新日時の古い順に表示されます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


インポート

コマンド

  • メニューバー>>カット袋>>インポート
  • コントロールバー>>ツールバー>>スタンダード>> インポート ボタン
  • Ctrl+N キー

このコマンドの意味

このコマンドの説明は、メニューバー>>ファイル>>新規作成（インポート）をご覧ください。


全更新ビルド

コマンド

  • メニューバー>>カット袋>>全更新ビルド
  • コントロールバー>>ツールバー>>スタンダード>> 全更新ビルド ボタン
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>全更新ビルド
  • F5 キー

このコマンドの意味

カット袋フォルダ内の全ての実線画像と彩色画像の保存日時と、セル画像の保存日時を比較して、セル画像の方が古い場合、またはセル画像が存在しない場合、最新のセル画像とマスク画像をビルドします。 詳しくは、「ビルドについて」をご覧ください。

このコマンドを選択すると、セル画像の更新処理モードダイアログが表示されます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


リビルド

コマンド

  • メニューバー>>カット袋>>リビルド
  • コントロールバー>>ツールバー>>スタンダード>> リビルド ボタン
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>リビルド
  • Ctrl+F5 キー

このコマンドの意味

カット袋フォルダ内の全ての実線画像と彩色画像から、最新のセル画像とマスク画像をビルドします。詳しくは、「ビルドについて」をご覧ください。

もし、カット袋ワークスペースのセルタブ セル画像タブ で表示されるサムネイルを選択している時には、その画像のみをリビルドします。選択されていない場合はカット袋フォルダ内全てのセル画像をリビルドします。

このコマンドを選択すると、セル画像の更新処理モードダイアログが表示されます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


現在のビューの画像をビルド

コマンド

  • メニューバー>>カット袋>>現在のビューの画像をビルド
  • コントロールバー>>ツールバー>>スタンダード>> 現在のビューの画像をビルド ボタン
  • F7 キー

このコマンドの意味

現在開いているアクティブなビューの AniLaPaint 画像と同じセル番号の実線画像と彩色画像からセル画像とマスク画像をビルドします。詳しくは、「ビルドについて」をご覧ください。

このコマンドを選択すると、セル画像の更新処理モードダイアログが表示されます。

※このコマンドは、カット袋ワークスペースを開いていなくても使用できます。


クリーン

コマンド

  • メニューバー>>カット袋>>クリーン
  • Ctrl+F7 キー

このコマンドの意味

カット袋フォルダ内の全てのセル画像とマスク画像を削除してゴミ箱に移します。このコマンドは、中間ファイルであるセル画像やマスク画像を一時的に削除してディスク容量を増やしたい時などに便利です。ただし、ゴミ箱に移しただけでは、ディスク容量は変わりません。その後、ゴミ箱を空にして始めてディスク容量が増えます。もし、ゴミ箱に移す必要がなく強制的に削除したい場合は、このコマンドで表示されるメッセージボックスでOKを答える際に、Shift キーを押しておくと強制削除となります。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


エクスポート

コマンド
  • メニューバー>>カット袋>>エクスポート
  • コントロールバー>>ツールバー>>スタンダード>> エクスポート ボタン
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>エクスポート
  • F8 キー

このコマンドの意味
ビルドで作成したセル画像とマスク画像を、他のアニメーション用のムービー制作ソフトやビデオ編集ソフトやフォトレタッチソフトなどで扱える形式のファイルに変換し出力します。このコマンドを選択すると、セル画像のエクスポートダイアログが表示されます。詳しくは「エクスポートについて」をご覧ください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


色パカ チェッカー

コマンド

  • メニューバー>>カット袋>>色パカ チェッカー
  • コントロールバー>>ツールバー>>スタンダード>> 色パカ チェッカー ボタン
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>右クリックメニュー>>色パカ チェッカー

このコマンドの意味

このコマンドによって色パカ・チェッカーダイアログが開きます。

カット袋ワークスペースでマウスのドラッグなどによりサムネイルを複数選択してあるときに、選択された画像をアニメーション表示します。

どのサムネイルも選択されていない場合は、現在表示しているサムネイルの画像全てをアニメーション表示します。

ただし、選択されているかどうかは、カット袋ワークスペースにフォーカスがない場合は表示されません。サムネイルにかからない余白などをクリックすると、カット袋ワークスペースにフォーカスが移りどのサムネイルが選択されているかどうかわかります。
このアニメーション表示によって、色の塗り間違いなどによって起こる、色の点滅（色パカと呼ぶ）を発見することができます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


(検) マークを付ける

コマンド

  • メニューバー>>カット袋>>(検) マークを付ける
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> (検) マークを付ける ボタン

このコマンドの意味

カット袋ワークスペースの、 実線画像 実線・ 彩色画像 彩色・ セル画像 セルの３つのタブで表示される画像のサムネイルに(検) マークを付けます。このマークは、セル検査係の人が検査済みであることを示すために使います。このマークを使うことで、簡単な管理を行なう事ができます。

※現時点では、管理に重点を置いていません。あくまでこれはメモ程度の機能です。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


(検) マークを外す

コマンド

  • メニューバー>>カット袋>>(検) マークを外す
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> (検) マークを外す ボタン

このコマンドの意味

カット袋ワークスペースの、 実線画像 実線・ 彩色画像 彩色・ セル画像 セルの３つのタブで表示される画像のサムネイルに付けた(検) マークを外します。このマークは、セル検査係の人が検査済みであることを示すために使います。このマークを使うことで、簡単な管理を行なう事ができます。

※現時点では、管理に重点を置いていません。あくまでこれはメモ程度の機能です。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


ファイルを削除

コマンド

  • メニューバー>>カット袋>>ファイルを削除
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> ファイルを削除 ボタン

このコマンドの意味

カット袋ワークスペースの、 実線画像 実線・ 彩色画像 彩色・ セル画像 セルの３つのタブで表示される画像のサムネイルの画像ファイルを削除してごみ箱に移動します。Shiftキーを押しながらこのコマンドを選択した場合は、ごみ箱には入れずに強制削除します。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンに現在の色を追加

コマンド

  • メニューバー>>カット袋>>アイコンに現在の色を追加
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> 新しい色を追加 ボタン

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンのリストビューへ新たに現在選択している色を追加します。現在選択している色は、カット袋ワークスペースのリストビューのすぐ上に表示されている色の事です。

このコマンドを実行すると、色の追加ダイアログが表示されます。

アイコンをファイルで共有（自動上書き保存）もお読みください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンの色や名前の変更

コマンド

  • メニューバー>>カット袋>>アイコンの色や名前の変更
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> アイコンの色や名前の変更 ボタン
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>>色アイコンのダブルクリック

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンの色や名前を変更します。

このコマンドは、色アイコンを複数選択して実行する事もできます。

このコマンドを実行すると、色の設定ダイアログが表示されます。

アイコンをファイルで共有（自動上書き保存）もお読みください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンを別の分類へ移動

コマンド

  • メニューバー>>カット袋>>アイコンを別の分類へ移動
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> アイコンを別の分類へ移動 ボタン

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンを別の分類へ移動します。ここでいう分類とは、リストビューのすぐ上のコンボボックスで切り替える分類の事です。

このコマンドは、色アイコンを複数選択して実行する事もできます。

このコマンドを実行すると、色の移動ダイアログが表示されます。

アイコンをファイルで共有（自動上書き保存）もお読みください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンの削除

コマンド

  • メニューバー>>カット袋>>アイコンの削除
  • コントロールバー>>ダイアログバー>>カット袋ワークスペース>> アイコンの削除 ボタン

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンを削除します。この色アイコンはファイルではないので削除してもごみ箱へ移動するわけではありません。したがって、復活させることはできないので慎重に削除してください。

このコマンドは、色アイコンを複数選択して実行する事もできます。

このコマンドを実行すると、色の削除ダイアログが表示されます。

アイコンをファイルで共有（自動上書き保存）もお読みください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンをファイルで共有（自動上書き保存）

コマンド

  • メニューバー>>カット袋>>アイコンをファイルで共有（自動上書き保存）

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンの保存場所は通常カット袋ワークスペースファイルに内包される形となりますが、別カット間で同じ色アイコンを共有したい場合はこの機能を使い、複数カット間から共有可能な色アイコンファイルでデータを共有します。

このコマンドで新しいファイル名を指定した場合は、そのファイル名の色アイコンファイルが新たに作成されます。また、既にある色アイコンファイルを指定した場合は、そのファイルを表示します。

他のネットワークコンピュータ上のAniLaPaintを使っている人が色アイコンを追加・変更・移動・削除などをすると、一時的にこちらの表示内容との不一致が生じます。そのため、そのような変更があった場合、こちら側の表示は古いわけですので、色アイコンの追加・変更・移動・削除が一時的に出来なくなります。通用は１０秒毎に同期するようにしていますが、微妙なタイミングで同期できなかったときは、メッセージが表示された後即座に更新されます。また、メニューバー>>カット袋>>表示>> 最新の情報に更新 最新の情報に更新を実行する事で、手動で更新することもできます。

このコマンドを実行すると、共有する色アイコンの設定ダイアログが表示されます。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンをファイルに複製を保存

コマンド

  • メニューバー>>カット袋>>アイコンをファイルに複製を保存

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンを複数カット間から共有可能な色アイコンデータ（パレットファイル）を新たに作成し名前を付けて保存します。

アイコンをファイルで共有（自動上書き保存）もお読みください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


アイコンをファイルから一度に追加

コマンド

  • メニューバー>>カット袋>>アイコンをファイルから一度に追加

このコマンドの意味

カット袋ワークスペースの、 色アイコン 色のタブで表示される色アイコンのリストビューに、他の色アイコンファイルにある色アイコンを全て追加します。この場合、すでに分類・名前・色が全て一致する色アイコンが存在する場合は、２重に追加されることはありません。

アイコンをファイルで共有（自動上書き保存）もお読みください。

※カット袋ワークスペースを開いていない場合は、このコマンドは使用できません。


ビュー

ビューをクリックすると、ビュー表示に関するメニューが表示されます。現在アクティブなビューによって、選択できるメニュー項目が変わります。例えば、ＢＧ色を変更するメニューは彩色画像のビューでのみ使用できます。強調表示/マスク表示のメニューは、実践画像かセル画像のビューでのみ使用できます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


実線画像

コマンド

  • メニューバー>>ビュー>>実線画像
  • コントロールバー>>ツールバー>>ビュー切り替え>> 実線画像 ボタン

このコマンドの意味

彩色画像やセル画像を編集時にこのボタンを押すと、編集中の画像に対応する実線画像を同じ位置同じ拡大率で開きます。

このコマンドを使う前にアクティブだったビューは、 直前の画像を自動保存 直前の画像を自動保存がチェックされていると自動的に保存されます。また、 直前の画像を常に閉じる 直前の画像を常に閉じるがチェックされていると自動的に閉じられます。


彩色画像

コマンド

  • メニューバー>>ビュー>>彩色画像
  • コントロールバー>>ツールバー>>ビュー切り替え>> 彩色画像 ボタン

このコマンドの意味

実線画像やセル画像を編集時にこのボタンを押すと、編集中の画像に対応する彩色画像を同じ位置同じ拡大率で開きます。

このコマンドを使う前にアクティブだったビューは、 直前の画像を自動保存 直前の画像を自動保存がチェックされていると自動的に保存されます。また、 直前の画像を常に閉じる 直前の画像を常に閉じるがチェックされていると自動的に閉じられます。


セル画像

コマンド

  • メニューバー>>ビュー>>セル画像
  • コントロールバー>>ツールバー>>ビュー切り替え>> セル画像 ボタン

このコマンドの意味

実線画像や彩色画像を編集時にこのボタンを押すと、編集中の画像に対応するセル画像を同じ位置同じ拡大率で開きます。

このコマンドを使う前にアクティブだったビューは、 直前の画像を常に閉じる 直前の画像を常に閉じるがチェックされていると自動的に閉じられます。


前番号

コマンド

  • メニューバー>>ビュー>>前番号
  • コントロールバー>>ツールバー>>ビュー切り替え>> 前番号 ボタン
  • F11 キー

このコマンドの意味

現在アクティブなビューの画像と同じフォルダにあるアルファベット順で１つ前の画像ファイルを開きます。

ただし、このコマンドはファイル名に付けられた数字を数値として解釈していません。あくまで文字コードで解釈しているので、A9 と A10 では A10 の方が前と見なされます。AniLaPaint のインポートで名前を付けたAniLaPaint画像の場合はそれぞれ自動的に A009 や A010 のように桁数がそろうようになっているので、この問題は発生しません。独自に名前を付けたファイル（表示のみの画像）をこのコマンドを使用して開く場合はその点に注意してください。

このコマンドを使う前にアクティブだったビューは、 直前の画像を自動保存 直前の画像を自動保存がチェックされていると自動的に保存されます。また、 直前の画像を常に閉じる 直前の画像を常に閉じるがチェックされていると自動的に閉じられます。


次番号

コマンド

  • メニューバー>>ビュー>>次番号
  • コントロールバー>>ツールバー>>ビュー切り替え>> 次番号 ボタン
  • F12 キー

このコマンドの意味

現在アクティブなビューの画像と同じフォルダにあるアルファベット順で１つ後の画像ファイルを開きます。

ただし、このコマンドはファイル名に付けられた数字を数値として解釈していません。あくまで文字コードで解釈しているので、A9 と A10 では A10 の方が前と見なされます。AniLaPaint のインポートで名前を付けたAniLaPaint画像の場合はそれぞれ自動的に A009 や A010 のように桁数がそろうようになっているので、この問題は発生しません。独自に名前を付けたファイル（表示のみの画像）をこのコマンドを使用して開く場合はその点に注意してください。

このコマンドを使う前にアクティブだったビューは、 直前の画像を自動保存 直前の画像を自動保存がチェックされていると自動的に保存されます。また、 直前の画像を常に閉じる 直前の画像を常に閉じるがチェックされていると自動的に閉じられます。


直前の画像を自動保存

コマンド

  • メニューバー>>ビュー>>直前の画像を自動保存
  • コントロールバー>>ツールバー>>ビュー切り替え>> 直前の画像を自動保存 ボタン

このコマンドの意味

このコマンドがチェック状態にあるとき、 実線画像 実線画像や 彩色画像 彩色画像や 前番号 前番号や 次番号 次番号を使って画像ファイルを開いた場合に直前にアクティブだった画像を自動的に上書き保存する機能です。他のコマンドで画像ファイルを開いた場合には適応されません。

このコマンドは、 直前の画像を常に閉じる 直前の画像を常に閉じると合わせて使用する事により連続した番号の動画を効率的にペイントすることができます。


直前の画像を常に閉じる

コマンド

  • メニューバー>>ビュー>>直前の画像を常に閉じる
  • コントロールバー>>ツールバー>>ビュー切り替え>> 直前の画像を常に閉じる ボタン

このコマンドの意味

このコマンドがチェック状態にあるとき、 実線画像 実線画像や 彩色画像 彩色画像や セル画像 セル画像や 前番号 前番号や 次番号 次番号を使って画像ファイルを開いた場合に直前にアクティブだった画像を自動的に閉じる機能です。他のコマンドで画像ファイルを開いた場合には適応されません。

このコマンドは、 直前の画像を自動保存 直前の画像を自動保存と合わせて使用する事により連続した番号の動画を効率的にペイントすることができます。


ズームイン

コマンド

  • メニューバー>>ビュー>>ズームイン
  • コントロールバー>>ツールバー>>ズーム>> ズームイン ボタン
  • コントロールバー>>ダイアログバー>>クイックズームバー>> ズームイン ボタン
  • Ctrl++ キー
  • Page Up キー

このコマンドの意味

現在アクティブなビューの画像を１ステップ分だけ拡大します。


ズームアウト

コマンド

  • メニューバー>>ビュー>>ズームアウト
  • コントロールバー>>ツールバー>>ズーム>> ズームアウト ボタン
  • コントロールバー>>ダイアログバー>>クイックズームバー>> ズームアウト ボタン
  • Ctrl+- キー
  • Page Down キー

このコマンドの意味

現在アクティブなビューの画像を１ステップ分だけ縮小します。


ピクセル等倍

コマンド

  • メニューバー>>ビュー>>ピクセル等倍
  • コントロールバー>>ツールバー>>ズーム>> ピクセル等倍 ボタン
  • コントロールバー>>ダイアログバー>>クイックズームバー>> ピクセル等倍 ボタン
  • Ctrl+Alt+0 キー
  • End キー

このコマンドの意味

現在アクティブなビューの画像を拡大率１００％（つまり拡大も縮小もしていない状態）で表示させます。


画面サイズに合わせる

コマンド

  • メニューバー>>ビュー>>画面サイズに合わせる
  • コントロールバー>>ツールバー>>ズーム>> 画面サイズに合わせる ボタン
  • コントロールバー>>ダイアログバー>>クイックズームバー>> 画面サイズに合わせる ボタン
  • Ctrl+0 キー
  • Home キー

このコマンドの意味

現在アクティブなビューの画像をウィンドウのサイズにちょうど全体が表示されるように拡大率を調節して表示します。


画面サイズに幅を合わせる

コマンド

  • メニューバー>>ビュー>>画面サイズに幅を合わせる
  • コントロールバー>>ツールバー>>ズーム>> 画面サイズに幅を合わせる ボタン
  • コントロールバー>>ダイアログバー>>クイックズームバー>> 画面サイズに幅を合わせる ボタン
  • Ctrl+Home キー

このコマンドの意味

現在アクティブなビューの画像をウィンドウの幅いっぱいにちょうど入るように拡大率を調節して表示します。


画面サイズに高さを合わせる

コマンド

  • メニューバー>>ビュー>>画面サイズに高さを合わせる
  • コントロールバー>>ツールバー>>ズーム>> 画面サイズに高さを合わせる ボタン
  • コントロールバー>>ダイアログバー>>クイックズームバー>> 画面サイズに高さを合わせる ボタン
  • Ctrl+End キー

このコマンドの意味

現在アクティブなビューの画像をウィンドウの高さ（縦幅）いっぱいにちょうど入るように拡大率を調節して表示します。


拡大率で指定

コマンド

  • メニューバー>>ビュー>>拡大率で指定
  • コントロールバー>>ツールバー>>ズーム>> 拡大率で指定 ボタン
  • Ctrl+Page Up キー

このコマンドの意味

現在アクティブなビューの画像を拡大率を％で指定して表示します。このコマンドを実行すると、拡大率の指定ダイアログが表示されます。


ズーム増減量の設定

コマンド

  • メニューバー>>ビュー>>ズーム増減量の設定
  • コントロールバー>>ツールバー>>ズーム>> ズーム増減量の設定 ボタン
  • Ctrl+Home キー

このコマンドの意味

ズームイン ズームインや ズームアウト ズームアウトの１ステップの増減量を設定します。このコマンドを実行すると、拡大率の増減量の設定ダイアログが表示されます。


白

コマンド

  • メニューバー>>ビュー>>白
  • コントロールバー>>ツールバー>>背景色>> 白 ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色を白にします。


赤

コマンド

  • メニューバー>>ビュー>>赤
  • コントロールバー>>ツールバー>>背景色>> 赤 ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色を赤にします。


緑

コマンド

  • メニューバー>>ビュー>>緑
  • コントロールバー>>ツールバー>>背景色>> 緑 ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色を緑にします。


青

コマンド

  • メニューバー>>ビュー>>青
  • コントロールバー>>ツールバー>>背景色>> 青 ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色を青にします。


シアン

コマンド

  • メニューバー>>ビュー>>シアン
  • コントロールバー>>ツールバー>>背景色>> シアン ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色をシアンにします。


マゼンタ

コマンド

  • メニューバー>>ビュー>>マゼンタ
  • コントロールバー>>ツールバー>>背景色>> マゼンタ ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色をマゼンタにします。


イエロー

コマンド

  • メニューバー>>ビュー>>イエロー
  • コントロールバー>>ツールバー>>背景色>> イエロー ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色をイエローにします。


黒

コマンド

  • メニューバー>>ビュー>>黒
  • コントロールバー>>ツールバー>>背景色>> 黒 ボタン
  • コントロールバー>>クールバー>>色選択>>背景色ボタン

このコマンドの意味

現在アクティブな彩色画像のビューまたは、セル画像のビューの背景色を黒にします。


強調表示／マスク表示

コマンド

  • メニューバー>>ビュー>>強調表示／マスク表示
  • コントロールバー>>ツールバー>>ペイント>> 強調表示／マスク表示 ボタン

このコマンドの意味

現在アクティブなビューが線画画像のビューの場合強調表示します。

現在アクティブなビューがセル画像のビューの場合マスク画像を表示します。


ウィンドウ

ウィンドウをクリックすると、コントロールバーおよびビューのウィンドウに関するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


重ねて表示

コマンド

  • メニューバー>>ウィンドウ>> 重ねて表示 重ねて表示

このコマンドの意味

複数のウィンドウを重ねて表示します。


上下に並べて表示

コマンド

  • メニューバー>>ウィンドウ>> 上下に並べて表示 上下に並べて表示

このコマンドの意味

複数のウィンドウを重なり合わないように、上下に並べて表示します。


左右に並べて表示

コマンド

  • メニューバー>>ウィンドウ>> 左右に並べて表示 左右に並べて表示

このコマンドの意味

複数のウィンドウを重なり合わないように左右に並べて表示します。


アイコンの整列

コマンド

  • メニューバー>>ウィンドウ>> アイコンの整列 アイコンの整列

このコマンドの意味

アプリケーションのメイン ウィンドウの一番下にアイコン化されているアイコンを整列させます。
もし画像のウィンドウが開いていて、メイン ウィンドウの一番下の部分にかかっている場合、このウィンドウの下になっているアイコンは見えません。


すべてを閉じる

コマンド

  • メニューバー>>ウィンドウ>>すべてを閉じる

このコマンドの意味

現在開いている全てのファイルを閉じます。編集によって画像が変更されている場合は、１枚ずつ閉じる前に保存するかどうか聞いてきます。その際に、キャンセルを押すとこのコマンドは中断されます。


しおり

しおりをクリックすると、しおりに関するメニューが表示されます。しおりとは、複数のビューを開いている時に、いくつかのビューにしおりを貼る事で、しおりを貼ったビューの切り替えを容易にします。また、同じ位置、同じ拡大率でビューが切り替わるので、色パカなどのチェックにも使えます。また、このメニューと同様のコマンドを持つしおりツールバーがあります。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


現在のウィンドウにしおりを貼る／剥がす

コマンド

  • メニューバー>>ウィンドウ>>しおり>>現在のウィンドウにしおりを貼る／剥がす
  • コントロールバー>>ツールバー>>しおり>> 現在のウィンドウにしおりを貼る／剥がす ボタン
  • Insert キー

このコマンドの意味

アニメーションの色パカチェックのための同じ位置同じ拡大率でウィンドウを素早く切り替えるために、このコマンドで複数のウィンドウにしおりを貼ってください。しおりを貼った順番で、ウィンドウを切り替える事ができるようになります。

まず、しおりの貼りかたですが、メニューバー>>ウィンドウ>> 上下に並べて表示 上下に並べて表示などを使ってウィンドを並べておいて、ウィンドウをアクティブにして順番にこのコマンドを使い次々としおりを貼っていきます。

しおりを貼った後、最初に表示したいウィンドウを最大化して、任意の拡大率で色パカをチェックしたい場所を表示てください。そして、メニューバー>>ウィンドウ>>しおり、しおりツールバーなどにあるの 前のしおりへ 前のしおりや 次のしおり 次のしおりコマンドまたは、F9やF10キーでウィンドウを切り替えると、同じ場所を同じ拡大率で素早く切り替え表示してくれます。

ウィンドウを追加してしおりを貼るには、前のしおりや、次のしおりコマンドで、しおりを貼りたいウィンドウの直前に表示させたいウィンドウまで表示をすすめます。その後、メニューバー>>ウィンドウの最下行に表示されるウィンドウファイル名を使い次に記録したいウィンドウを表示させます。そして、このコマンドを実行してください。

すでにしおりが貼ってあるウィンドウに対してこのコマンドを再度実行すると、ウィンドウのしおりを剥がすことになります。しおりをすべて剥がすには、 全てのしおりを剥がす 全てのしおりを剥がすを実行してください。


前のしおりへ

コマンド

  • メニューバー>>ウィンドウ>>しおり>>前のしおりへ
  • コントロールバー>>ツールバー>>しおり>> 前のしおりへ ボタン
  • F9 キー

このコマンドの意味

現在のウィンドウにしおりを貼る／剥がす 現在のウィンドウにしおりを貼る／剥がすコマンドを使ってウィンドウに貼り付けたしおりの前の順序にあたるウィンドウを、現在の画像の位置と拡大率を保持したまま切り替え表示します。


次のしおりへ

コマンド

  • メニューバー>>ウィンドウ>>しおり>>次のしおりへ
  • コントロールバー>>ツールバー>>しおり>> 次のしおりへ ボタン
  • F10 キー

このコマンドの意味

現在のウィンドウにしおりを貼る／剥がす 現在のウィンドウにしおりを貼る／剥がすコマンドを使ってウィンドウに貼り付けたしおりの次の順序にあたるウィンドウを、現在の画像の位置と拡大率を保持したまま切り替え表示します。


全てのしおりを剥がす

コマンド

  • メニューバー>>ウィンドウ>>しおり>>全てのしおりを剥がす
  • コントロールバー>>ツールバー>>しおり>> 全てのしおりを剥がす ボタン
  • Delete キー

このコマンドの意味

現在のウィンドウにしおりを貼る／剥がす 現在のウィンドウにしおりを貼る／剥がすコマンドを使ってウィンドウに貼り付けたしおりを全て剥がします。


ツールバー

ツールバーをクリックすると、表示・非表示を切り替えられるツールバーの一覧が表示されます。すでに表示されているツールバーには、チェックマークが付いています。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


スタンダード

コマンド

  • メニューバー>>ウィンドウ>>ツールバー>>スタンダード

このコマンドの意味

スタンダードツールバーの表示・非表示を切り替えます。表示している場合はこのメニュー項目にチェックマークが付きます。


ペイント

コマンド

  • メニューバー>>ウィンドウ>>ツールバー>>ペイント

このコマンドの意味

ペイントツールバーの表示・非表示を切り替えます。表示している場合はこのメニュー項目にチェックマークが付きます。


ズーム

コマンド

  • メニューバー>>ウィンドウ>>ツールバー>>ズーム

このコマンドの意味

ズームツールバーの表示・非表示を切り替えます。表示している場合はこのメニュー項目にチェックマークが付きます。


背景色

コマンド

  • メニューバー>>ウィンドウ>>ツールバー>>背景色

このコマンドの意味

背景色ツールバーの表示・非表示を切り替えます。表示している場合はこのメニュー項目にチェックマークが付きます。


ビュー切り替え

コマンド

  • メニューバー>>ウィンドウ>>ツールバー>>ビュー切り替え

このコマンドの意味

ビュー切り替えツールバーの表示・非表示を切り替えます。表示している場合はこのメニュー項目にチェックマークが付きます。


しおり

コマンド

  • メニューバー>>ウィンドウ>>ツールバー>>しおり

このコマンドの意味

しおりツールバーの表示・非表示を切り替えます。表示している場合はこのメニュー項目にチェックマークが付きます。


ステータスバー

コマンド

  • メニューバー>>ウィンドウ>>ステータスバー

このコマンドの意味

ステータス バーの表示、非表示を切り替えます。
ステータス バーには、メニュー コマンドやツールバーのボタンを選択したときにコマンドの簡単な説明や、キーボードの特殊キーのON/OFF の状態などが表示されます。
ステータス バーが表示されているときは、メニューのこのコマンド名の横にチェックマークが表示されます。

ステータスバー


クイックズーム

コマンド

  • メニューバー>>ウィンドウ>>クイックズーム
  • コントロールバー>>ツールバー>>スタンダード>> クイックズーム ボタン

このコマンドの意味

クイックズームの表示、非表示を切り替えます。
クイックズームが表示されているときは、メニューのこのコマンド名の横にチェックマークが表示されます。

クイックズーム


スポイトパレット

コマンド

  • メニューバー>>ウィンドウ>>スポイトパレット
  • コントロールバー>>ツールバー>>スタンダード>> スポイトパレット ボタン

このコマンドの意味

スポイトパレットの表示、非表示を切り替えます。
スポイトパレットが表示されているときは、メニューのこのコマンド名の横にチェックマークが表示されます。


カラーピッカー

コマンド

  • メニューバー>>ウィンドウ>>カラーピッカー
  • コントロールバー>>ツールバー>>スタンダード>> カラーピッカー ボタン

このコマンドの意味

カラーピッカーの表示、非表示を切り替えます。
カラーピッカーが表示されているときは、メニューのこのコマンド名の横にチェックマークが表示されます。


カット袋ワークスペース

コマンド

  • メニューバー>>ウィンドウ>>カット袋ワークスペース
  • コントロールバー>>ツールバー>>スタンダード>> カット袋ワークスペース ボタン

このコマンドの意味

カット袋ワークスペースの表示、非表示を切り替えます。カット袋ワークスペースが開かれていない場合は、フォルダ参照のダイアログが表示されるので、インポートされた AniLaPaint 画像のあるフォルダを指定してください。

カット袋ワークスペースが表示されているときは、メニューのこのコマンド名の横にチェックマークが表示されます。

カット袋ワークスペース


開いているウィンドウの一覧

コマンド

  • メニューバー>>ウィンドウ>>開いているウィンドウの一覧

このコマンドの意味

AniLaPaint が現在開いているウィンドウのリストがメニューバー>>ウィンドウのいちばん下に表示されます。
また、現在アクティブになっている文書ウィンドウ名の横にチェックマークが表示されます。
次にアクティブにしたい文書ウィンドウを選択してください。

メニューバー>>ウィンドウ
↑納まらない場合は「その他のウィンドウ」メニューが表示されます。


ヘルプ

ヘルプをクリックすると、ヘルプに関するメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。


目次

コマンド

  • メニューバー>>ヘルプ>>目次

このコマンドの意味

この取扱説明書の目次を表示します。


検索...

コマンド

  • メニューバー>>ヘルプ>>検索...

このコマンドの意味

この取扱説明書を任意の文字列で全文検索します。


キーワード...

コマンド

  • メニューバー>>ヘルプ>>検索...

このコマンドの意味

この取扱説明書を設定されているキーワードの中から検索します。


クリックした場所の説明

コマンド

  • メニューバー>>ヘルプ>>クリックした場所の説明
  • コントロールバー>>ツールバー>>スタンダード>> 選択した場所の説明 ボタン

このコマンドの意味

マウスカーソルが ？付きになります。
この状態で説明の必要な場所をクリックすることで、取扱説明書中からクリックした場所の説明を検索表示します。

その場所に説明がない場合は、エラーメッセージが表示されます。エラーが表示された場合、表示されたヘルプIDをメモして、作者まで御連絡ください。次のバージョンで対処したいと思います。


作者への連絡方法

コマンド

  • メニューバー>>ヘルプ>>作者への連絡方法

このコマンドの意味

この取扱説明書の作者への連絡方法を表示します。


ユーザサポート

コマンド

  • メニューバー>>ヘルプ>>ユーザサポート

このコマンドの意味

この取扱説明書のユーザサポートを表示します。


AniLaPaint のバージョン情報

コマンド

  • メニューバー>>ヘルプ>>AniLaPaint のバージョン情報

このコマンドの意味

ご使用の AniLaPaint のバージョンを表示します。また、お使いのAniLaPaintが正式版（ベータ版でない）場合には、ここからライセンス登録を行なう事ができます。

このコマンドを実行すると、バージョン情報(AniLaPaint)ダイアログが表示されます。


コントロールバー

ここでは、コントロールバー（ツールバー・ステータスバー・クールバー・ダイアログバー）の役割について説明します。

ツールバー

ツールバーは、メニューと同じ機能をボタンとして用意したものです。
下記のドッキング状態の図では３の部分にあたります。

ステータスバー

ステータスバーは、現在のソフトの状態や、マウスの場所の１行ヘルプなどが表示されます。
下記のドッキング状態の図では７の部分にあたります。

ダイアログバー

カット袋ワークスペース
スポイトパレット
ダイアログバーは、ペイント作業を補助するための、常時表示しておけるメインウィンドウにドッキング可能なダイアログのことをいいます。
下記のドッキング状態の図では６の部分にあたります。

クールバー

クールバーもツールバーと同様に、本来メニューで選択できる項目の数々がボタンとして表示されます。
下記のドッキング状態の図では４の部分にあたります。

ドッキング状態の図

コントロールバーは初期状態でメインウィンドウにドッキングした状態となっています。以下の３４６７がコントロールバーです。

ドッキングとフローティングについて

コントロールバーのいくつかは、常にドッキング状態であったりフローティングが可能であったりまちまちです。以下にドッキングやフローティングについての情報をまとめてみました。

上辺にドッキング可能なコントロールバー

下辺にドッキング可能なコントロールバー

左辺にドッキング可能なコントロールバー

右辺にドッキング可能なコントロールバー

フローティング可能なコントロールバー


上辺にドッキング可能なコントロールバー

これは、メインウィンドウの上辺（メニューバーの下）にドッキング可能なコントロールバーの一覧です。

ツールバー

全て上辺にドッキング可能です。

ツールバーはドッキング中のサイズを変更することはできません。

クールバー

常に上辺（ツールバーの下）にドッキングした状態となります。ペイントツール選択時に、必要なツールバーなどが内部に表示されます。タブをドラッグする事で順番を変える事ができます。

クールバーはドッキング中のサイズを変更することはできません。


下辺にドッキング可能なコントロールバー

これは、メインウィンドウの下辺にドッキング可能なコントロールバーの一覧です。

ツールバー

全て上辺にドッキング可能です。

ツールバーはドッキング中のサイズを変更することはできません。

ステータスバー

常に下辺にドッキング状態となります。

ステータスバードッキング中のサイズを変更することはできません。

ステータスバー


左辺にドッキング可能なコントロールバー

これは、メインウィンドウの左辺にドッキング可能なコントロールバーの一覧です。

ツールバー

全て上辺にドッキング可能です。

ツールバーはドッキング中のサイズを変更することはできません。

ダイアログバー

全てドッキング可能です。但し、各バーの左上にあるアイコン（ アイコン アイコン アイコン アイコン ）を押したときに表示されるアイコンメニュー>>ドッキング可能にチェックが付いている場合だけ、メインウィンドウにドッキングすることができます。チェックが付いていない場合は常にフローティング状態になります。

ドッキング中のサイズは、フローティング時に変更したサイズを反映します。したがって、一旦フローティングさせてサイズを変更する事ができます。（カット袋ワークスペースに関してはドッキング中の縦幅は変更できません。また横幅はドッキング中でも変更可能です。また、クイックズームやスポイトパレットの場合の縦幅は、左上にあるアイコンを押したときに表示されるメニューの[常にアスペクト非を保持]にチェックが付いている場合は自動的に調整されます。）

カット袋ワークスペース
スポイトパレット


右辺にドッキング可能なコントロールバー

これは、メインウィンドウの右辺にドッキング可能なコントロールバーの一覧です。

ツールバー

全て上辺にドッキング可能です。

ダイアログバー

全てドッキング可能です。但し、各バーの左上にあるアイコン（ アイコン アイコン アイコン アイコン ）を押したときに表示されるアイコンメニュー>>ドッキング可能にチェックが付いている場合だけ、メインウィンドウにドッキングすることができます。チェックが付いていない場合は常にフローティング状態になります。

ドッキング中のサイズは、フローティング時に変更したサイズを反映します。したがって、一旦フローティングさせてサイズを変更する事ができます。（クイックズームやスポイトパレットの場合の縦幅は、左上にあるアイコンを押したときに表示されるメニューの[常にアスペクト非を保持]にチェックが付いている場合は自動的に調整されます。）

 スポイトパレット


フローティング可能なコントロールバー

これは、フローティング可能（メインウィンドウから切り離し可能）なコントロールバーの一覧です。コントロールバーはフローティング状態の時に、ウィンドウの端をドラッグすることで、ウィンドウサイズを変更することができます。

ツールバー

全てフローティング可能です。

フローティング中のサイズを変更することができます。

ペイント

ダイアログバー

全てフローティング可能です。

フローティング中のサイズを変更することができます。

カット袋ワークスペース
スポイトパレット

ダイアログバーのフローティング中のタイトルバーのみの表示

メニューバー>>ファイル>>環境設定 の 表示タブにある設定で、ダイアログバーのタイトルバーをダブルクリックした時に、タイトルバーのみの表示にすることができるようになります。フローティングをして使用する時に有効な機能です。もう一度タイトルバーをダブルクリックするともとのサイズに戻ります。
この設定をしても、ドッキング可能になっている時にメインウィンドウの縁近くでタイトルバーをダブルクリックするとドッキングしてしまいます。それがわずらわしい場合はドッキング可能のチェックを外してください。


ツールバー

ツールバーは、メニューと同じ機能をボタンとして用意したものです。ボタンの用途の簡単な説明は、ボタンの上にマウスカーソルを置くと、ステータスバーに表示されます。
ツールバーの表示・非表示は、メニューバー>>ウィンドウ>>ツールバーで切り替える事ができます。
ツールバーは、端をマウスの左ボタンを押しながらドラッグする事でメインウィンドウから切り離しフローティング状態で表示したり、別の場所にドッキングさせることができます。

それぞれのツールバーの詳しい情報がしりたい場合は以下のツールバーをクリックしてください。

スタンダード

ここには、基本的なボタンを集めてあります。

ペイント

ここには、彩色に関するボタンを集めてあります。

ズーム

ここには、ビューの画像を拡大・縮小するためのボタンを集めてあります。

背景色

背景色

ここには、彩色画像のビューの背景色を切り替えるボタンを集めてあります。

ビュー切り替え

ビュー切り替え

ここには、現在のビューと関連する種類や番号の画像を自動的に開くボタンを集めてあります。

しおり

しおり

ここには、複数のビューを開いている時に、いくつかのビューにしおりを付けて移動しやすくするためのボタンを集めてあります。


スタンダード

ここには、基本的なボタンを集めてあります。 このツールバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ツールバー>>スタンダードを使ってください。

カット袋ワークスペース | カット袋ワークスペースの表示、非表示を切り替えます。
クイックズーム | クイックズームの表示、非表示を切り替えます。
スポイトパレット | スポイトパレットの表示、非表示を切り替えます。
カラーピッカー | カラーピッカーの表示、非表示を切り替えます。
新規作成（インポート） | 新規作成（インポート）します。
ファイルを開く | 既存の画像ファイルを開きます。
▼ | 最近開いたファイル名が最大 10 個までメニュー表示されます。
カット袋ワークスペースを開く | カット袋ワークスペースを開きます。
▼ | 最近開いたカット袋ワークスペースが最大 10 個までメニュー表示されます。
上書き保存 | ファイル名・保存場所を変更しないで上書保存します。
すべて保存 | 全てのビューの変更された画像を全て上書保存します。
元に戻す | 直前に行った編集操作をキャンセルし、画像を元に戻します。
元に戻すの取り消し | 元に戻すコマンドで戻した画像を取り消し、元に戻す前の状態に戻します。
元に戻す機能の停止 | 元に戻す機能を停止します。
現在のビューの画像をビルド | 現在開いているアクティブなビューの画像をビルドします。
全更新ビルド | カット袋フォルダ内の全ての画像を保存日時を比較してビルドします。
リビルド | カット袋フォルダ内の全ての画像を再ビルドします。
エクスポート | カット袋フォルダ内の全ての画像をエクスポートします。
選択した場所の説明 | マウスで指定した場所の説明を表示します。

※アイコンをクリックするとより詳しい説明を表示します。


ペイント

▼ 実線画像の場合
 ペイント
▼ 彩色画像の場合
 ペイント
▼ 表示のみの画像の場合
 ペイント

ここには、彩色に関するボタンを集めてあります。このツールバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ツールバー>>ペイントを使ってください。

選択ツール>>矩形 | 画像に矩形の選択範囲を作るためのツールです。
選択ツール>>楕円 | 画像に楕円の選択範囲を作るためのツールです。
なげなわツール>>フリーハンド | 画像にフリーハンドの選択範囲を作るためのツールです。
自動選択ツール | 画像に同じ色で連続した領域の選択範囲を作るためのツールです。
色保護ツール | 画像に上書き禁止の色の保護領域を作るためのツールです。
ブラシツール | 画像にブラシでペイントするためのツールです。
鉛筆ツール | 画像にソリッドペン（暈けていない色）でペイントするためのツールです。
塗りつぶしツール>>バケツ | 画像にバケツ（フィル）でペイントするためのツールです。
塗りつぶしツール>>色の置き換え | 画像の色を指定して他の色に置き換えるためのツールです。
塗りつぶしツール>>矩形 | 画像に矩形でペイントするためのツールです。
塗りつぶしツール>>楕円 | 画像に楕円でペイントするためのツールです。
塗りつぶしツール>>フリーハンド | 画像にフリーハンドで囲んだ領域をペイントするためのツールです。
ラインツール>>折れ線 | 画像に折れ線でペイントするためのツールです。
ラインツール>>多角形 | 画像に多角形をペイントするためのツールです。
ラインツール>>多角形塗りつぶし | 画像に多角形（フィル）をペイントするためのツールです。
スポイトツール | 画像の色をスポイトで拾い、標準ペイント色に選択するためのツールです。
強調表示／マスク表示 | 線画画像のビューの場合強調表示します。 セル画像のビューの場合マスク画像を表示します。

※アイコンをクリックするとより詳しい説明を表示します。

▼ウィンドウのサイズを変えた状態（例）
ペイント


ズーム

ここには、ビューの画像を拡大・縮小するためのボタンを集めてあります。 このツールバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ツールバー>>ズームを使ってください。

ズームイン | １ステップ拡大します。
ズームアウト | １ステップ縮小します。
拡大率で指定 | 拡大率を％で指定します。
ズーム増減量の設定 | １ステップの増減量を設定します。
ピクセル等倍 | 拡大も縮小もしていない状態で表示します。
画面サイズに合わせる | ウィンドウのサイズにちょうど全体が表示されるように拡大率を調節して表示します。
画面サイズに幅を合わせる | ウィンドウの幅いっぱいにちょうど入るように拡大率を調節して表示します。
画面サイズに高さを合わせる | ウィンドウの高さ（縦幅）いっぱいにちょうど入るように拡大率を調節して表示します。

※アイコンをクリックするとより詳しい説明を表示します。


背景色

ここには、彩色画像のビューの背景色を切り替えるボタンを集めてあります。このツールバーは彩色画像以外では使用できません。このツールバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ツールバー>>背景色を使ってください。

白 | 背景色を白にします。
赤 | 背景色を赤にします。
緑 | 背景色を緑にします。
青 | 背景色を青にします。
シアン | 背景色をシアンにします。
マゼンタ | 背景色をマゼンタにします。
イエロー | 背景色をイエローにします。
黒 | 背景色を黒にします。

※アイコンをクリックするとより詳しい説明を表示します。


ビュー切り替え

ここには、現在のビューと関連する種類や番号の画像を自動的に開くボタンを集めてあります。 このツールバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ツールバー>>ビュー切り替えを使ってください。

前番号 | 現在開いているファイルと同じフォルダにあるアルファベット順で１つ前の画像ファイルを開きます。
実線画像 | 現在開いているファイルに関連する実線画像を同じ位置同じ拡大率で開きます。
彩色画像 | 現在開いているファイルに関連する彩色画像を同じ位置同じ拡大率で開きます。
セル画像 | 現在開いているファイルに関連するセル画像を同じ位置同じ拡大率で開きます。
次番号 | 現在開いているファイルと同じフォルダにあるアルファベット順で１つ後の画像ファイルを開きます。
直前の画像を自動保存 | 上記のコマンドで新しくファイルを開いた時に直前の画像を自動的に上書き保存する機能です。
直前の画像を常に閉じる | 上記のコマンドで新しくファイルを開いた時に直前の画像を自動的に閉じる機能です。

※アイコンをクリックするとより詳しい説明を表示します。


しおり

ここには、複数のビューを開いている時に、いくつかのビューにしおりを付けて移動しやすくするためのボタンを集めてあります。 このツールバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ツールバー>>しおりを使ってください。

前のしおりへ | しおりを貼った前のウィンドウを表示します。
現在のウィンドウにしおりを貼る／剥がす | ウィンドウにしおりを貼ります。
次のしおりへ | しおりを貼った次のウィンドウを表示します。
全てのしおりを剥がす | ウィンドウに貼り付けたしおりを全て剥がします。

※アイコンをクリックするとより詳しい説明を表示します。


ステータスバー

ステータスバーは、現在のソフトの状態や、マウスの場所の１行ヘルプなどが表示されます。

ここには、ファンクションキーの機能やツールバーのボタンやメニューやウィンドウの説明などが表示されます。このステータスバーの表示/非表示を切り替えるには、メニューバー>>ウィンドウ>>ステータスバーを使ってください。

左側の部分には、普段上記のようなファンクションキーの機能の説明が表示されていますが、メニューやツールバーのボタン上にマウスカーソルを持っていくと、そのコマンドの簡単な説明が表示されるようになっています。

右側の部分には、以下のキーの ON/OFF の状態が表示されます。

カナ | [カナ] キーが ON の状態
CAP | [Caps Lock] キーが ON の状態
NUM | [Num Lock] キーが ON の状態
SCRL | [Scroll Lock] キーが ON の状態


ダイアログバー

ダイアログバーとは、他のソフトではツールウィンドウとも呼ばれています。AniLaPaintではドッキング可能なダイアログ・ウィンドウのことを指します。
ダイアログバーは通常、ドッキング/フローティングが可能ですが、フローティング時のみウィンドウのサイズを変えることができます。サイズを変えたい時は、 グリップ を左ボタンを押したままドラッグして、一旦ドッキング状態からフローティング状態にします。その後、ウィンドウ枠にマウスカーソルを移動し、両矢印カーソルとなったら、左ボタンを押したままお好みの大きさにしてください。その後、ドッキングしてもそのサイズは維持されます。ただし、カット袋ワークスペースについては、ドッキング時のウィンドウの縦サイズはメインウィンドウの大きさによって自動的に最大化されます。また、このダイアログバーだけは左側のみのドッキングとなります。
各ダイアログバーにはアイコンメニューが備えられております。

それぞれのダイアログバーの詳しい情報がしりたい場合は以下のダイアログバーをクリックしてください。

クイックズーム

ここには、現在開いている画像のどの部分をどれくらい拡大するのかを簡単に指定できる機能が含まれています。また、画像編集中にカーソル位置のルーペ機能も含まれています。

スポイトパレット

ここには、AniLaPaint画像や表示のみの画像から簡単に色をスポイトで選択する機能が含まれています。画像の任意の位置を拡大表示したり、スクロールしたりすることができるので、狭いウィンドウ表示でも細かな部分でも色を選択する事ができます。

カラーピッカー

ここには、任意の色をカラーバーから選択したり、数値で色を作成したりする機能が含まれています。

カット袋ワークスペース

ここには、新規作成で１カット毎にフォルダ単位で作成されたAniLaPaint画像を管理しやすくするために、サムネイル表示やファイルの編集、削除、色パカチェック用のアニメーション表示、名前付き色アイコンパレットなどの便利な機能が含まれています。


クイックズーム

ここには、現在開いている画像のどの部分をどれくらい拡大するのかを簡単に指定できる機能が含まれています。また、画像編集中にカーソル位置のルーペ機能も含まれています。

機能の説明

長方形の部分
画像に表示されている長方形の部分が、下図のように現在の編集画面の表示範囲です。
編集画面
この長方形と編集画面の表示位置は常に連動しており互いに更新されます。
この長方形をクイックズーム上で変更するには、クイックズームの画像をマウスの左ボタンを押しながらドラッグして新しい長方形を設定してください。また、単に長方形を移動したいだけの場合は、クイックズームの画像をマウスの左ボタンで１クリックしてください。

クイックズームには、ビュー上のマウス移動を拡大表示するルーペ機能があります。
ビューの上でマウスを移動すると現在のマウス位置の拡大画像がこのダイアログバーに表示されます。この機能やルーペの拡大率は、アイコンメニューで設定可能になっています。

ボタンの説明

グリップ | ドッキング時にこのグリップをマウスの左ボタンを押したままドラッグすると、ドッキングする位置を変える事ができます。
アイコンメニュー表示 | クイックズームの機能に関するメニューを表示します。
拡大 | ビューの画像を１ステップ拡大します。
縮小 | ビューの画像を１ステップ縮小します。
ピクセル等倍 | ビューの画像を拡大も縮小もしていない状態で表示します。
画面サイズに合わせる | ビューの画像をウィンドウのサイズにちょうど全体が表示されるように拡大率を調節して表示します。
画面サイズに幅を合わせる | ビューの画像をウィンドウの幅いっぱいにちょうど入るように拡大率を調節して表示します。
画面サイズに高さを合わせる | ビューの画像をウィンドウの高さ（縦幅）いっぱいにちょうど入るように拡大率を調節して表示します。

※アイコンをクリックするとより詳しい説明を表示できるものもあります。


スポイトパレット

ここには、AniLaPaint画像や表示のみの画像から簡単に色をスポイトで選択する機能が含まれています。画像の任意の位置を拡大表示したり、スクロールしたりすることができるので、狭いウィンドウ表示でも細かな部分でも色を選択する事ができます。

機能の説明

AniLaPaint画像や、表示のみの画像から色を選択することができます。

最初に、アイコンメニューから上記の画像をパレット画像として開いてください。

画像が表示されたら、画像の任意の部分をマウスの左ボタンでクリックして色を選択してください。この色は、標準ペイント色として設定できます。また、カット袋ワークスペースの色アイコンとして色を追加したり、カラーピッカーでこの色を受け取る事もできます。

また、画像上をマウスの左ボタンを押したままドラッグすると、長方形が描画されその部分を拡大表示することができます。一旦拡大表示された後、もう一度マウスの左ボタンを押したままドラッグすると、こんどは手のひらカーソルになり、画像を拡大表示したままスクロールすることができます。再び画像全体を表示するには、マウスの左ボタンをダブルクリックしてください。

色の履歴
スポイトパレットで色を設定すると、過去５つまでの履歴をボタンとして表示します。これらのボタンを押す事で過去に選択した色を再び設定する事が容易に出来ます。

ボタンの説明

グリップ | ドッキング時にこのグリップをマウスの左ボタンを押したままドラッグすると、ドッキングする位置を変える事ができます。
スポイトパレットのアイコンメニュー | スポイトパレットの機能に関するメニューを表示します。
ズームモード | 機能の説明の拡大表示と同じです。
拡大表示を解除 | 機能の説明のダブルクリックと同じです。つまり拡大表示を解除します。

※アイコンをクリックするとより詳しい説明を表示できるものもあります。


カラーピッカー

ここには、任意の色をカラーバーから選択したり、数値で色を作成したりする機能が含まれています。

カラーピッカー | モノクロボタン ボタン → | カラーピッカー（モノクロ）
 | カラーボタン ボタン ←
▲カラーモードの時 |  | ▲モノクロモードの時

機能の説明

このカラーピッカーからあらゆる色を選択することができます。
現在の標準ペイント色 | この部分は現在の標準ペイント色を現しています。
色のチャート | この部分をマウスの左ボタンでクリックすると、その場所の色が次の標準ペイント色に設定されます。また、カット袋ワークスペースへもこの色が送られるので色アイコンとしてこの色を追加したりすることもできます。
色チャートをドラッグ中の画面 マウスの左ボタンを押したままドラッグすると、左図のように、標準ペイント色の部分が上下２段に表示されます。これによって直前の選択色と比較しながら次の色を選択することができます。

例えば、肌の明るい色がもう決まっている時、最初に肌の明るい色を標準ペイント色に設定しておき、この部分の色の差を見ながら影の色を決めるような事ができます。

Ｖ

前述の虹色に表示されている部分ですが、実は左図のようにＶのラジオボタンがオンになっている時にだけこのように表示されます。他のラジオボタンがオンになっている時にはまた別の色で表示されます。
スライダー | Ｖ（バリュー・明度）がオンになっていると、Ｖ（明度）が左図のようにスライダー部分に設定されます。そして、Ｈ（ヒュー・色相）とＳ（サチュレーション・彩度）がそれぞれ横軸と縦軸に設定され、虹色のような色の選択部分が表示されていたのです。
ＨＳ ＨやＳのラジオボタンをオンにした場合は、オンにした部分が同じようにスライダー部分に反映され、残りの２つの要素が横軸と縦軸に設定されるので、色の選択部分が上記の表示とは全く異なることになります。
Ｒ（赤）Ｇ（緑）Ｂ（青）のラジオボタンをオンにした場合も同様です。

色の履歴
この部分には、直前までにカラーピッカーで選択した色の履歴を表示しています。これはマウスでクリックする事でいつでも呼び出せますが、覚えているのはここに表示されている５つ分だけです。

このページの一番上で説明している通り、カラーピッカーは常にボタン一つでカラーモードとモノクロモードを変更することができます。

AniLaPaint では、カラーの色を塗れるのは彩色画像の編集時のみです。彩色画像の場合はどちらのモードを使っても、選択した色が常に標準ペイント色に設定されます。しかし、実線画像の編集では、カラーは使えません。実線画像の場合ではカラーモードで選択した色は無視されます。そのかわり、モノクロモードで選択した色は境界線色に設定され、その色で実線を追加する事ができます。

ＨＳＶＲＧＢを数値で設定する事で色を選択する事もできます。この場合、エディットボックスにマウスカーソルを持っていき、左クリックする事でその場所に直接数値を入力する事が可能となります。AniLaPaint では、これらの数値は全て、０から２５５の値を取る事にしています。

Ｈは角度ＳやＶはパーセントで指定するものが一般的なのですが、AniLaPaint が呼び出している LEADTOOLS の DLL が０から２５５を使用しているために、そのような仕様となってしまいました。実は過去のベータ版でこの数値を内部的に角度やパーセントに変換処理するようプログラムしていた次期がありましたが、変換によるタイムラグや変換することで誤差がどうしても発生し、ＨＳＶとＲＧＢを同時に表示する時に不都合が生じるなどありましたので、すなおに０から２５５にすることにしました。

別のソフトとの色の数値のやり取りをする場合は、必ずＲＧＢの値の方を参考にしてください。

ボタンの説明

グリップ | ドッキング時にこのグリップをマウスの左ボタンを押したままドラッグすると、ドッキングする位置を変える事ができます。
カラーピッカーのアイコンメニュー | カラーピッカーの機能に関するメニューを表示します。

※アイコンをクリックするとより詳しい説明を表示できるものもあります。


カット袋ワークスペース

ここには、新規作成で１カット毎にフォルダ単位で作成されたAniLaPaint画像を管理しやすくするために、サムネイル表示やファイルの編集、削除、色パカチェック用のアニメーション表示、名前付き色アイコンパレットなどの便利な機能が含まれています。

機能の説明

タブ | この部分をタブといいます。４つのアイコンが表示されています。それぞれのアイコンには次の意味があります。
実線画像 | カット袋フォルダ内の実線画像ファイルのサムネイルを表示します。
彩色画像 | カット袋フォルダ内の彩色画像ファイルのサムネイルを表示します。
セル画像 | カット袋フォルダ内のセル画像ファイルのサムネイルを表示します。
色アイコン | カット袋ワークスペースに結び付けられた色アイコンを表示します。

１）サムネイルを表示した場合
カット袋フォルダ | この部分には、現在のカット袋フォルダ名が表示されています。（カット袋ワークスペースの横幅を広げないと全てを見る事ができないこともあります。）

画像-リストボックス
このようにリストボックスの部分に上記タブに応じたAniLaPaint画像のサムネイル一覧を表示します。AniLaPaintはアニメーションのセル重ねやセル番号に基づいてファイル名が付けられており、ここにはＡセルからＺセルのいずれかのセルが全て表示されています。

画像-コンボボックス となっていることから、このサムネイルの一覧はＢセルであることがわかります。

画像-コンボボックス２ この部分をコンボボックスと呼びます。このコンボボックスはマウスでクリックすると右図のように、ＡセルからＺセルまでのうち、カット袋内に存在するセルが一覧表示されます。これを選択する事によって、例えば、Ａセルをサムネイルに表示させることができます。

これらのサムネイルをマウスでダブルクリックすることにより、画像ファイルを開く事ができます。実線画像や彩色画像の場合、ここから開いて編集すると便利でしょう。また、このサムネイルは編集して画像を変更すると自動的に更新されます。したがって、左図のようにどの画像が彩色されているかどうかを簡単に見分ける事ができます。

画像-選択
サムネイルをクリックすると左図のように選択表示されます。これはクリックした場合には１つだけ選択されますが、マウスの左ボタンを押しながらドラッグするとラバーバンド（四角形の点線）が表示されて複数のサムネイルを選択する事も可能です。また、１つを選択してから、Ctrlキーを押しながら次々とクリックしていくと不連続の複数選択ができます。（Shiftキーの場合連続の複数選択）
これらは、Windowsの仕様に準拠しています。

画像-ツール
このように、サムネイルを選択してから図のボタンを押すと、選択した画像に以下のような作業をすることが可能です。
色パカチェック 色パカチェック機能です。
選択画像をアニメーション表示することにより、色の塗り間違いをチェックするのに使います。
※ただし、何も選択していない場合は現在表示されているサムネイルの画像全てをアニメーション表示します。
(検)マークを付ける サムネイルに(検)マークを付加します。
選択画像に(検)マークを付ける事により、その画像が検査済みであることを示します。
(検)マークを外す サムネイルの(検)マークを削除します。
一旦付けた(検)マークを取り除きたい時に使います。
ファイルを削除 選択された画像ファイルを削除します。
通常Windowsのごみ箱に削除されたファイルが移動されるので、ディストップのゴミ箱の中から直前に削除したファイルを復活する事ができます。ただし、Shiftキーを押しながらこのボタンを押すと、完全削除となり復活はできません。
情報の更新を禁止 情報の更新を禁止します。
サムネイルや、色アイコンの情報の自動更新を一時禁止します。

より詳しい説明は、上記のアイコンをクリックすると表示されます。

カット袋ワークスペース上で、マウスの右ボタンをクリックすると、下図のようなコンテキストメニューが表示されます。このメニューから、上記の機能を実行する事もできます。また、ここには他のメニューもあります。それぞれの機能の説明はメニューを直接クリックしてください。

▼タブが実線・彩色画像の場合
実線・彩色画像 - コンテキストメニュー

▼タブがセル画像の場合
セル画像 - コンテキストメニュー

また、カット袋ワークスペースのより完全なメニューが、メニューバー>>カット袋に表示されています。こちらから実行する事も出来ます。

２）色アイコンを表示した場合
色アイコン-ファイル名 | この部分には、カット袋ワークスペースにパレットファイルがリンクされている場合は、その名前が表示されます。リンクされていない場合は、カット袋フォルダ名を表示します。（カット袋ワークスペースの横幅を広げないと全てを見る事ができないこともあります。）

色アイコン
このようにリストボックスの部分に色アイコンの一覧が表示されます。色アイコンには任意の分類を定義でき、分類毎にアイコンが整理されています。
色アイコン-コンボボックス となっていることから、現在表示中の色アイコンは「男」分類のものであることがわかります。このコンボボックスをクリックすると、貴方がこのパレットに付けた分類の名前の一覧が表示され、表示する分類を変える事ができます。

このバーの部分に現在の標準ペイント色が表示されています。

色アイコンをマウスでクリックすると、その色が標準ペイント色となります。

色アイコンをマウスでダブルクリックすると、色アイコンに付けた名前の変更や色自体の変更をすることができます。

色アイコン-選択
色アイコンをクリックすると左図のように選択表示されます。これはクリックした場合には１つだけ選択されますが、マウスの左ボタンを押しながらドラッグするとラバーバンド（四角形の点線）が表示されて複数の色アイコンを選択する事も可能です。また、１つを選択してから、Ctrlキーを押しながら次々とクリックしていくと不連続の複数選択ができます。（Shiftキーの場合連続の複数選択）
これらは、Windowsの仕様に準拠しています。

色アイコン-ツール

このように、色アイコンを選択してから図のボタンを押すと、選択した画像に以下のような作業をすることが可能です。
新しい色を追加 現在の標準ペイント色を色アイコンに追加します。
新しい色アイコンを追加するには、スポイトパレットやカラーピッカーやビューのスポイトツールなどの機能を使って、色を標準ペイント色に設定した後にこのボタンを押してください。色の分類と名前を設定すると新たな色アイコンが作られます。
アイコンの色や名前を変更 色アイコンの色の名前や色自体を変更します。
この機能は、色アイコンを直接ダブルクリックしても同じです。ダイアログが表示され、色の名前を変更したり、色自体を変更する事ができます。
アイコンを別の分類へ移動 色アイコンを別の分類へ移動または複製します。
時には色アイコンを別の分類へ移動したいことがあります。色アイコンを選択してこのボタンを押すと居ろアイコンを別の分類へ移動または複製することができます。
色アイコンを削除 色アイコンを削除します。
色アイコンを選択してこのボタンをおすと、選択された色アイコンを削除する事ができます。色アイコンは、サムネイルとは違い Windows のごみ箱に送られたりする事はありません。削除には細心の注意をはらってください。
情報の更新を禁止 情報の更新を禁止します。
サムネイルや、色アイコンの情報の自動更新を一時禁止します。

より詳しい説明は、上記のアイコンをクリックすると表示されます。

カット袋ワークスペース上で、マウスの右ボタンをクリックすると、下図のようなコンテキストメニューが表示されます。このメニューから、上記の機能を実行する事もできます。また、ここには他のメニューもあります。それぞれの機能の説明はメニューを直接クリックしてください。

色アイコン - コンテキストメニュー

また、カット袋ワークスペースのより完全なメニューが、メニューバー>>カット袋に表示されています。こちらから実行する事も出来ます。


アイコンメニュー

アイコンメニューとは、ダイアログバーの左上のボタンを押した時に表示されるメニューのことを現しています。

それぞれのアイコンメニューの説明は以下をクリックしてください。

アイコンメニュー表示 クイックズームのアイコンメニュー

アイコンメニュー表示 スポイトパレットのアイコンメニュー

アイコンメニュー表示 カラーピッカーのアイコンメニュー

アイコンメニュー表示 カット袋プロジェクトワークスペースのアイコンメニュー

ダイアログバーの説明は以下をクリックしてください。

カット袋ワークスペース
スポイトパレット


クイックズームのアイコンメニュー

クイックズーム上の アイコンメニュー表示 アイコンをクリックするとメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

マウス位置の拡大表示

このメニュー項目にチェックが付いていると、編集中の画像のマウス位置をクイックズームに拡大して表示します。以下の何れかのメニュー項目のチェックが付いている拡大率で表示します。この機能はルーペ機能とも呼ばれています。
２倍に拡大・４倍に拡大・８倍に拡大・１６倍に拡大


スポイトパレットのアイコンメニュー

スポイトパレット上の アイコンメニュー表示 アイコンをクリックするとメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

また、ver 1.2.5.12 からは、「履歴の消去」コマンドが追加されました。このコマンドを選択すると、最近使ったファイルの一覧が消去されます。

パレット画像を開く

パレットに使用したい画像を選択して開きます。

パレット画像を閉じる

現在使用中のパレット画像を閉じます。

最近開いたパレット画像の一覧

最近パレット画像として使用したファイルの一覧が表示されます。


カラーピッカーのアイコンメニュー

カラーピッカー上の アイコンメニュー表示 アイコンをクリックするとメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

標準色と常に同期

カラーピッカー以外（スポイトパレット・カット袋ワークスペースなど）で標準ペイント色が変更された時に、カラーピッカーをそれらの色と同期して更新する時にはチェックマークを付けてください。


カット袋プロジェクトワークスペースのアイコンメニュー

カット袋プロジェクトワークスペースの アイコンメニュー表示 アイコンをクリックするとメニューが表示されます。各コマンドの説明は、以下のメニュー項目をクリックすると表示されます。

また、ver 1.2.5.12 からは、「履歴の消去」コマンドが追加されました。このコマンドを選択すると、最近使ったカット袋ワークスペースの一覧が消去されます。


常にアスペクト比を保持

このメニュー項目は、以下のダイアログバーのアイコンメニューに表示されます。

クイックズーム
スポイトパレット

このメニューにチェックマークが入っていると、ダイアログバーのサイズを変更した時に、アスペクト比（画像の縦横の比率）を保持したままサイズを変更することになります。つまり、横だけ広げたり縦だけ広げたりする事はできなくなり、サイズ変更時には必ず縦横同時に変更されるようになります。

このチェックマークを外すと、画像はウィンドウサイズに合わせて変形表示されます。


ドッキング可能

このメニュー項目は、以下のダイアログバーのアイコンメニューに表示されます。

カット袋ワークスペース
スポイトパレット

このメニュー項目にチェックマークが付いていると、これらのダイアログバーはメインウィンドウの左右の辺ににドッキングできる状態になります。（ただし、カット袋ワークスペースは左のみ）

メインウィンドウにドッキングさせたくない場合は、このチェックマークを外してください。


非表示

このメニュー項目は、以下のダイアログバーのアイコンメニューに表示されます。

カット袋ワークスペース
スポイトパレット

このメニュー項目は、これらのダイアログバーを個々に非表示にするために使います。再び表示する場合は、コントロールバー>>ツールバー>>スタンダードにあるボタンを使うか、メニューバー>>ウィンドウにあるメニューを使用して表示してください。


クールバー

クールバーもツールバーと同様に、本来メニューで選択できる項目の数々がボタンとして表示されます。その他にも、ペンのサイズを指定するエディットボックスなど、その時々の状態によって必要なツールを動的に切り替えて表示します。
この部分は、主にコントロールバー>>ツールバー>>ペイントまたは、メニュバー>>ツールで現在選択しているのペイントツールの状態によって自動的に変化します。クールバーは、ツールバーとは違い、表示・非表示やフローティング状態をユーザが指定する事はできません。各クールバーの左に表示されているグリップをマウスの左ボタンでドラッグすると、表示順番を並べ替える事ができます。（ツールバーなどとは違い、位置情報などは終了後は保持されません。）

それぞれのクールバーの詳しい情報がしりたい場合は以下のクールバーをクリックしてください。

色選択

色保護

範囲選択

ペン幅

透明度・暈し率

適応領域

色情報


色選択

色選択クールバーは、実線画像か彩色画像を編集している時にのみ使用可能となります。また「色について」の項目もご覧ください。

標準ペイント色 | 標準ペイント色を使って彩色します。 このボタンが押されている時にもう一度押すと、カラーピッカーダイアログが表示されます。 ※ただし、実線画像編集時には選択できません。
背景色 | 背景色を使って彩色します。 ボタンが押されている時( 背景色 )にもう一度押すと、彩色画像の場合のみ背景色の変更メニューが表示されます。 ※ただし、彩色画像編集時のブラシツールの場合には選択できません。
境界線色 | 境界線色を使って彩色します。 ボタンが押されている時( 境界線色 )にもう一度押すと、実線画像の場合は白黒のカラーピッカーダイアログが表示され、彩色画像の場合は境界線色の変更メニューが表示されます。 ※ただし、彩色画像編集時のブラシツールの場合には選択できません。

※アイコンをクリックするとより詳しい説明を表示します。


色保護

色保護クールバーは、彩色画像の編集時にのみ表示されます。

有効 | 色の保護状態を有効にします。
反転有効 | 色の保護状態を反転して有効にします。
無効 | 色の保護状態を無効にします。
色保護領域を常に更新 | 常に保護領域を自動更新していきます。
全て解除 | 保護された色のうち標準ペイント色や背景色にあたる色の保護状態を全て解除します。
境界線保護のボタンを表示 | 境界線保護のボタンを表示します。
境界線保護のボタンを隠す | 境界線保護のボタンを隠します。
白 | 境界線白の保護状態を変更します。（押されていると保護有功です。以下同）
赤 | 境界線赤の保護状態を変更します。
緑 | 境界線緑の保護状態を変更します。
青 | 境界線青の保護状態を変更します。
シアン | 境界線シアンの保護状態を変更します。
マゼンタ | 境界線マゼンタの保護状態を変更します。
イエロー | 境界線イエローの保護状態を変更します。
黒 | 境界線黒の保護状態を変更します。

※アイコンをクリックするとより詳しい説明を表示します。


選択範囲

選択範囲クールバーは、実線画像や彩色画像の編集時に「選択ツール」「なげなわツール」「自動選択ツール」を使って設定した選択範囲が存在する時に表示されます。

有効 | 選択範囲外の部分の保護状態を有効にします。
無効 | 選択範囲外の部分の保護状態を無効にします。
選択範囲の反転 | 選択範囲と選択範囲外を反転します。
選択範囲の解除 | 選択範囲を解除します。
新たに作る | 常に新しい選択範囲を作ります。
加える | 常に新たな選択範囲を加えます。
差し引く | 常に新たな選択範囲を差し引きます。

※アイコンをクリックするとより詳しい説明を表示します。


ペン幅

ペン幅クールバーは、実線画像や彩色画像の編集時に「 ブラシツール ブラシツール」「 鉛筆ツール 鉛筆ツール」「 折れ線 ラインツール・折れ線」「 多角形 ラインツール・多角形」のいずれかを選択した際に表示されます。

このエディットボックスの値はピクセル単位でペン幅の半径となります。

実線画像・彩色画像の違いと境界線色かそうで無いかの違いで、前回の異なる値を記憶しています。


透明度・暈し率

透明度・暈し率クールバーは、実線画像や彩色画像の編集時に「 ブラシツール ブラシツール」を選択した際に表示されます。

このエディットボックスの値は百分率で設定します。

透明度は、１００％だと完全に透明となります。０％だと不透明となります。

暈し率は、１００％だとペン幅の中心から端まで全てグラデーション状態に暈します。０％だと、暈しません。


適応領域

適応領域とは、 [image] 色の置き換えツール選択時に表示されます。

左側のエディットボックスは、ピクセル数を入力します。このピクセル数は、右のコンボボックスの状態によって意味が異なります。

●全ての領域

クリックした場所と同じ色の部分を全て現在の選択色で置き換えます。
したがって、ピクセル数には意味がありません。

●ピクセル以上の領域

クリックした場所と同じ色の部分で、指定したピクセル数以上の大きさを持つ領域を全て現在の選択色で置き換えます。

●ピクセル以下の領域

クリックした場所と同じ色の部分で、指定したピクセル数以下の大きさを持つ領域を全て現在の選択色で置き換えます。


色情報

現在開いている画像の、マウスカーソル位置の実画像のピクセル単位の位置(x,y)とその場所の色の値(r,g,b)を表示します。

10 の部分をクリックすると、色の値を 10・16 進数に切り替えることができます。


ダイアログ

ここでは、各種ダイアログについて説明します。

ファイルダイアログ

フォルダ選択ダイアログ

プログレスダイアログ

環境設定のダイアログ

ビューの拡大縮小に関するダイアログ

カット袋ワークスペースに関するダイアログ

バージョン情報(AniLaPaint)


ファイルダイアログ

このダイアログは、ファイルを開くときに表示されます。Windows98以降はダイアログのサイズを変更できます。

以下のオプションが設定できます。

ファイルの場所(I)

開きたい画像が保存されているフォルダやドライブを選択します。

ファイル名(N)

開きたい画像ファイルの名前を入力または選択します。リスト ボックスには、[ファイルの種類]ボックスで選択したファイル形式に対応する拡張子を持ったファイルが一覧表示されます。

ファイルの種類(T)

開きたい文書のファイル形式を選択します。▼ボタンを押すと次の一覧が表示されます。AniLaPaintでは、AniLaPaint形式のファイル(anp/anl)のみペイントが可能となっております。他の形式を選んだ場合は、ビューアとしてのみ開きます。ビューアでも色をスポイトツールで選択することは可能です。

複数の形式をまとめて表示（編集可能＆表示のみ）
[全ての画像]
AniLaPaint ファイル形式以外にも、あらゆる表示可能な画像ファイルを表示します。
[ AniLaPaint画像(*.anl,*.anp,*.anc) ]
AniLaPaint ファイル形式全てを表示します。
編集可能な画像

[AniLaPaint 彩色画像(*.anp) ]
AniLaPaint ファイル形式のうち彩色用の画像のみを表示します。
[AniLaPaint 実線画像(*.anl) ]
AniLaPaint ファイル形式のうち実線用の画像のみを表示します。

表示のみ対応の画像

[AniLaPaint セル画像(*.anc) ]
AniLaPaint ファイル形式のうち完成セル画像のみを表示します。
[Zsoft PCX形式(*.pcx)]
Zsoft PCX形式の画像のみを表示します。(マルチ形式には未対応です）
[Truevision TARGA形式(*.tga)]
Truevision TARGA形式の画像のみを表示します。
[Portable Network Graphics形式(*.png)]
Portable Network Graphics形式の画像のみを表示します。
[Adobe Photoshop 3.0形式(*.psd)]
Adobe Photoshop 3.0 形式の画像のみを表示します。
[TIFF形式(*.tif)]
TIFF形式の画像のみを表示します。(マルチ形式・LZW圧縮形式には未対応です）
[Jpeg ﾌｧｲﾙ形式(*.jpg,*.jpeg)]
Jpeg ﾌｧｲﾙ形式の画像のみを表示します。
[Lead CMP形式(*.cmp)]
Lead CMP形式の画像のみを表示します。
[SUN Raster形式(*.ras)]
SUN Raster形式の画像のみを表示します。
[Macintosh Pict形式(*.pct)]
Macintosh Pict形式の画像のみを表示します。
[Windows ﾋﾞｯﾄﾏｯﾌﾟ形式(*.bmp)]
Windows ﾋﾞｯﾄﾏｯﾌﾟ形式の画像のみを表示します。
[Windows ﾒﾀﾌｧｲﾙ(*.wmf)]
Windows ﾒﾀﾌｧｲﾙの画像のみを表示します。
[全てのﾌｧｲﾙ(*.*)]
全てのﾌｧｲﾙを表示します。

開く(O)

指定したファイルを開きます。

ｷｬﾝｾﾙ(ESC)

なにも開かずに、ダイアログを閉じます。


フォルダの選択ダイアログ

フォルダを選択必要がある場合にこのダイアログが表示されます。

「フォルダ選択」の下に表示されている行は、どんな理由でフォルダを選択するのかということと、現在選択中のフォルダのパスが表示されます。（パスは、全ては表示されません）

フォルダツリーの＋印をクリックすると、そのフォルダの下のサブフォルダが表示されます。再びサブフォルダを非表示にしたい場合は、－印をクリックします。

フォルダの名前を選択すると、フォルダアイコンが開いた絵になります。このフォルダが現在選択されているフォルダとなります。

ＯＫボタンを押すと、決定です。
キャンセルボタンを押すと、フォルダの選択を中止します。


プログレス・ダイアログ

idd_progress.png (1204 バイト)

プログレスバーは処理の進行状況を表しています。

中止の時は[中止]か[ESC]キーを押してください。

これが表示されている間は、AniLaPaint の他の機能を使うことはできません。


環境設定のダイアログ

AniLaPaintの動作に関していくつか自分の好みに応じて設定できる項目があります。このような設定を環境設定を呼びます。ここでは、環境設定の種類と意味について説明します。

環境設定をする方法

メニューバー>>ファイル>>環境設定コマンドを選択すると環境設定ダイアログが表示されます。

環境設定の詳細

環境設定は、種類に応じて次の項目がタブとして表示されています。それぞれの詳細は以下のリンクをお読みください。
表示
色
ＵＮＤＯ
ファイル
インポート／ビルド
通知


表示

AniLaPaint のビューの表示に関する項目を設定します。

●彩色画像を開く時の背景色

彩色画像やセル画像を開いたときの背景色を白・赤・緑・青・シアン・マゼンタ・イエロー・黒から選択することができます。
□但し既に別の彩色(セル)画像が開いているときは、その背景色を使う。
これをチェックした場合は、他に彩色画像またはセル画像が開いていてビューがアクティブのときには、ここで決めた背景色ではなくそのビューの背景色の設定を継承して新しい画像を開きます。

●ファイルを開いたときの拡大率

画像を開いたときの最初の表示サイズを設定します。
○幅と高さを合わせる
ビューのサイズいっぱいに画像を拡大（または縮小）して、全体が見えるように表示します。
○ピクセル等倍
画像の１ピクセルをディスプレイの１ピクセルとして表示します。

●右クリック

ビューの上でマウスの右クリックすると、カーソル位置の色をスポイトする動作となります。
これらの動作を変更する場合、以下の項目をチェックしてください。
□画像編集時の右クリックでポップアップメニューを表示
右クリックがポップアップメニューの表示となります。

●キャプションバーのダブルクリック

キャプションバーをダブルクリックすると、ビューの場合ウィンドウを最大化する動作となります。また、ダイアログバーの場合ウィンドウをメインウィンドウにドッキングする動作となります。
これらの動作を変更する場合以下の項目をチェックしてください。
□キャプションバーのみの状態に変化（Ｍａｃ的動作）
キャプションバーをダブルクリックすると、Ｍａｃｉｎｔｏｓｈのようにウィンドウがキャプションバーのみの状態となります。

●マウスカーソル形状

ツールメニューで選択したツールの状態とカーソルの形状についての設定です。
○ツールの絵を表示
現在選択しているツール毎にツールの絵をカーソルに表示します。
○クロスカーソルのみ
上級者向けです。常にカーソルは＋カーソルのみとなります。（ただし、ペンやラインツールなどの反転領域の表示はあります）
□色保護部分でのシールドマークを表示しない
保護されている部分は通常シールドマークをカーソルに表示しています。これを選択することでこのシールドマークを表示させないようにできます。


色

AniLaPaintでの色に関する設定をまとめてあります。

●スポイトやパレット等から、システム使用色を選択した場合の動作

AniLaPaintは通常のペイントソフトとは異なり、ビューによって使用できる色が異なったり、色の一部をシステム使用色として境界線色や背景色として使っています。そのため、全ての色をスポイトやパレットで選択できるわけではありません。そのようなシステム使用色をスポイトやパレットで選択した場合の動作をここで設定します。
○そのまま使う
その色に応じて背景色や境界線色のモードに切り替えます。
○変更して使う
非システム使用色で近い色に変更して使用します。これは、比較的アバウトな色の設定で塗る場合にはお勧めです。
○使わない
そのような色がスポイトで選択できないようにします。これは、厳密な色の設定で塗る場合にお勧めです。
□ビープ音を鳴らす
システム使用色をスポイト機能でクリックした時にビープ音を鳴らしユーザに伝えます。

●カラーピッカーの色の同期

カラーピッカーのデフォルトの状態を設定します。この設定はカラーピッカーのアイコンメニューでも同様に設定できます。
□常に同期させる
他の部分で色を選択したりした場合、カラーピッカーの現在の値を常に同期して更新します。この機能を使うと、他で色をスポイトするたびにカラーピッカーを更新するので、遅いマシーンではこの機能を使わない方が良いかもしれません。


UNDO

画像編集時に編集前の状態に戻す操作の回数を指定します。

●Ｕｎｄｏ（元の戻す）の回数

メモリーまたはハードディスクの状態によっては最高３００回前の状態まで戻すことができます。
この値を大きくしすぎると、元に戻す作業時に容量不足でエラーメッセージが表示されることがあります。その場合は、この値を減らしてください。通常１０回程度でよいと思います。

●Ｕｎｄｏ（元に戻す）情報の作成方法

画像編集時に画像の変更をＵｎｄｏ情報として記憶しますが、その記憶する情報の作成方法を指定できます。この設定は、ペイント時の速度と関係があります。これを変更するとペイントが速くなることもありますので、試してみてください。
▼差分
画像の変更をＸＯＲ差分で保存します。遅いマシーンでは差分を作成するのに時間がかかり、ペイントが遅くなることもありますが、Ｕｎｄｏ情報が小さくなるのでお勧めです。
▼複製
画像全体を保存します。１枚が大きい画像の場合、Ｕｎｄｏの回数の設定によっては莫大なＵｎｄｏ容量を必要とするので、あまりお勧めではありません。が、遅いマシーンではこちらのほうが速くなる場合もございます。Ｕｎｄｏ回数を少なめにしてお試しください。

●Ｕｎｄｏ（元に戻す）情報の保存場所

Ｕｎｄｏ情報をどこに保存するかを設定します。デフォルトではWindowsのテンポラリフォルダとなっています。ここの設定は、Ｕｎｄｏが保存できる十分な容量のある場所を指定してください。
○メモリに保存
Ｕｎｄｏ情報をメモリに保存します。メモリ容量が大きい方は、ディスクに保存するよりもペイントおよびＵｎｄｏが速くなりますが、メモリが少ない方はＯＳのディスクスワップが発生したりしてきわめて遅くなる危険があります。メモリ容量についての知識のあるかたのみご使用ください。
○指定フォルダに保存
Ｕｎｄｏ情報をディスクに保存します。デフォルトではWindowsのテンポラリフォルダが自動的に設定されています。できれば、「参照」ボタンを押して、できるだけ空き容量が大きくて速いＨＤＤを指定しなおしてください。このＨＤＤの速さが直接ペイントやＵｎｄｏの速度に影響します。
□データ圧縮
Ｕｎｄｏ情報のデータをＲＬＥ圧縮します。これによって、Ｕｎｄｏ情報のサイズが小さくなるので、ディスクが節約できます。ただし、圧縮によってペイントやＵｎｄｏの速度が多少遅くなります。速いコンピュータでこれをチェックしても遅くなったことが感じられないような場合にお使いください。


ファイル

AniLaPaint では、実線画像(*.anl)、彩色画像(*.anp)、セル画像(*.anc)、マスク画像(*.anm)の４種類の画像ファイルを扱います。これらは、AniLaPaint 画像ファイルと呼びますが、拡張子が違うだけで内部はすべて同じ汎用フォーマットで構成されています。

この内部のフォーマットをここで決めます。

たとえば、PhotoShopの「指定形式で開く」でここで指定した形式を指定すると、AniLaPaintの画像ファイルをそのまま開いて編集することができます。

圧縮フォーマットを選択すると、展開・保存には時間がかかりますが、ディスクの容量を押さえる働きがあります。（デフォルトでは PNG 圧縮フォーマットになっています。）無圧縮フォーマットを選択すると、ディスクの容量はかかりますが、素早い展開・保存で編集時のストレスが減ります。

※ドライブスペースなどを利用して、ドライブを圧縮ドライブなどにしている人は、この設定を無圧縮フォーマットにして、圧縮はドライブスペース任せにすることで保存の速度を上げるということもできます。


インポート／ビルド

インポート時やビルド時の動作をここで設定します。

●インポートやビルド中のスレッドの優先度を指定

これは、ＯＳについて良く知っている方の設定です。プログラムは、ＯＳによって時間割を与えられており、ＣＰＵを使用できる優先度がそれぞれに決まっています。ここでは、インポートやビルド機能のＯＳから見た優先度を設定します。
項目の上の値の方が優先度が高くなります。一番上の項目にすると、インポートやビルドの処理は早くなりますが、マウスなどのレスポンスなどの優先度は低下します。通常デフォルトのままご使用ください。
○フォアグラウンド実行時
インポートやビルドが終わるまで他の操作をしないモードの場合の、スレッド優先速度を指定します。
○バックグラウンド実行時
インポートやビルドを行っている最中もAniLaPaintの他の操作を行えるモードの場合の、スレッド優先度を指定します。デフォルトではLOWESTになっていますが、IDOLにするとフォアグラウンドの操作が止まっている間（オペレータが手を休めているなどのつかの間）バックグラウンドの動作が速くなります。つまりフォアグラウンド優先ですが、可変速度となります。

●ビルドのパラメータ設定

ビルドするの画質の設定ボタンを押すとビルドの環境設定ができます。


通知

インポートやビルドの処理が終了した時のメッセージとしてサウンドなどを鳴らすことができます。鳴らしたい音楽などのファイルを選択して、プレビューで確認してください。

ファイルの拡張子が関連付けられていて、Playアクションの動作がシェル上で定義されている必要があります。


ビューの拡大縮小に関するダイアログ

ここでは、ビューの拡大縮小に関するダイアログについて説明します。

拡大率の指定

拡大率の増減量の設定


拡大率の指定

拡大率を指定してください。

拡大率で指定 拡大率で指定コマンドを選択した際に表示されます。

値の上限は、入れてみなければわかりません。できるだけ拡大したい場合は 500 % にして [ OK ] を押します。すると、（もし 500 % は無理でも）最大拡大率で表示します。


拡大率の増減量の設定

１ステップの拡大率の増減量を設定します

ズーム増減量の設定 ズーム増減量の設定コマンドを選択した際に表示されます。

ズームイン ズームインおよび ズームアウト ズームアウトコマンド実行時に１ステップでどれだけ拡大率を増減させるかを設定します。これは、１００％以上と１００％以下で設定を変えることができます。


カット袋ワークスペースに関するダイアログ

カット袋ワークスペースを開いているときにさまざまなダイアログが表示されます。ここでは、カット袋ワークスペースに関するダイアログを説明します。

新規作成（インポート）ウィザード

色アイコンに関するダイアログ

色パカ・チェッカー

セル画像のビルドに関するダイアログ

エクスポートに関するダイアログ


新規作成（インポート）ウィザード

インポートウィザードは[次へ]ボタンを押す事で、ダイアログが順番に表示されていきます。「インポートについて」もお読みください。

新規作成（インポート）する方法

メニューバー>>ファイル>> 新規作成（インポート） 新規作成コマンドを選択すると新規作成（インポート）ウィザードが表示されます。

新規作成（インポート）の詳細

新規作成はウィザード形式のダイアログで設定を行います。ウィザード形式なので、個々のページを設定したら「次へ」ボタンで進んでいきます。個々のページの詳細は以下のリンクをお読みください。

新規作成（インポート）
新規ファイルを保存する場所の設定
スキャン画像ファイルの選択
スキャン画像ファイルにセル番号を付ける
合成伝票の設定
２値化パラメータの設定
上書きファイルの確認
インポート開始

インポートが始まると、インポートが終わるまでインポート処理ダイアログで進行状況を表示します。


新規作成（インポート）

最初のページは説明文です。以下のメッセージが表示されます。より詳しい説明については「セルアニメーション作画方法」をご覧ください。

● AniLaPaint 画像を新規作成します！

AniLaPaint は、あらかじめ紙に書いた絵をコンピュータで取り込んでおいた線画に彩色するプログラムです。したがって、他のスキャナソフトなどで、あらかじめ自分の鉛筆画を24bitフルカラーの画像ファイル(BMPなど)に保存しておいてください。絵の黒い線は濃い鉛筆（Ｂ・２Ｂ）などで描いてください。

影や色分けの境界線は、赤などの原色に近い色鉛筆（硬質の赤が良い）で描いてください。効率よく塗るために、同じ色の領域が完全に線で囲まれているようにしてください。そのような画像ファイルから AniLaPaint 画像を新規作成します。準備ができている方は「次へ」を押してください。

戻る なし
次へ 新規ファイルを保存する場所の設定


新規ファイルを保存する場所の設定

ここでは、どのフォルダに新規ファイルを作成するかを決めます。このフォルダのことをAniLaPaintではカット袋と呼びます。

AniLaPaintの新規画像を保存する場所

ここに、既存のカット袋フォルダを指定します。現在既にカット袋が開かれている場合はそのフォルダがデフォルトで選択されています。
「参照」ボタンを押して、フォルダの選択ダイアログを表示して既存のフォルダを指定することもできます。
ここに存在しないフォルダを指定すると、「次へ」ボタンが押せないようになりますので注意してください。

上記の場所の下に新たなフォルダを作る

最初に[参照]ボタンを押して親に当たるフォルダを選択してください。
次にこの部分に、新たに作成するフォルダの名前を書いて、[という名前のフォルダを作成する]ボタンを押してください。これで、新たにフォルダが作成されます。

前回と同じ条件でもう一度、新規作成しなおす

もし、前回のインポートのやり直しをしたい場合は、前回のログがそのフォルダに存在すれば押せるようになっているので、このボタンをおしてやり直すことができます。

戻る 新規作成（インポート）
次へ スキャン画像ファイルの選択


スキャン画像ファイルの選択

ここで、スキャン画像ファイルの指定をします。スキャン画像については、「インポートについて」をご覧ください。

「表(L) スキャン画像ファイルの一覧 」にファイル名を追加するために「表に追加(A)」ボタンを押してください。すると、ファイルダイアログが表示されます。このファイルダイアログは複数ファイルの選択ができます。マウスの左ボタンを押しながらドラッグすると四角で囲まれたファイルが選択されます。また、Ctrlキーを押しながらAを押すとフォルダ内の全てのファイルを選択することもできます。

表に追加したフォルダ名を削除したい場合は、選択したものを削除するための [ 表から削除 ] ボタンと、全てを白紙に戻す [ 白紙に戻す ] ボタンがあります。

戻る 新規ファイルを保存する場所の設定
次へ スキャン画像ファイルにセル番号を付ける


スキャン画像ファイルにセル番号を付ける

ここでは、スキャン画像にセル番号を割り当てていきます。動画に合成親などの指定がある場合は、合成番号にも割り当てていきます。割り当てた画像だけがインポートされます。

● まず、「スキャン画像(S)」から A セルに割り当てるものを選択表示します。

スキャン画像が順序良く並んでいれば、A セルに割り当てるものをマウスの左ボタンを押しながらドラッグすることで複数選択して一気にセル番号を振ることができるので、複数選択してください。

● 「セル(C)」のところが A になっていることを確認します。

● 「セル(C)」のすぐ下の「 > 」ボタンを押してください。これで、選択されていたスキャン画像は、「番号(Ｕ)」のほうへ移動して番号付けがなされます。

● もし番号が飛び番号の場合などは、「欠(K)>」ボタンを利用します。これは空の番号が振らて１行ずれます。「番号(Ｕ)」の表に欠番が挿入される位置は、選択されている行の上になります。

● もし A セルのみで、スキャン画像が順番通りの場合は、「 >> 」ボタンを押すだけで一気に番号付けができます。

● もしスキャン画像の選択を間違えて、「番号(Ｕ)」の方へ送ってしまった場合は、 [ < ] や[ << ] を使うことで「スキャン画像(S)」の表に戻すことができます。

● 合成伝票を使う場合は「合成親(G)」のチェックボックスをオンにしてください。

● 「セル(C)」を切り替えつつ、全てのスキャン画像を振り分けてください。インポートは「番号(Ｕ)」の欄と「合成親(G)」の欄にあるものしか処理しません。

● つぎに、「番号(Ｕ)」の中で実線画像あるいは彩色画像のどちらか一方のみインポートする場合などには、それらの番号を選択して「L 実線」か「P 彩色」のチェックボックスをオフにしてください。「番号(Ｕ)」の表の[LP]の部分が変化します。

● 合成伝票を使う場合、一般的に合成子には A-1' などのダッシュ付きの記法が使われます。「番号(Ｕ)」の中で合成子に指定したい番号を選択して「合成子 cHiled」のチェックボックスをオフにしてください。「番号(Ｕ)」の表の番号にダッシュが付きます。

● もし画像を確認したくなったら、「スキャン画像(S)」「番号(Ｕ)」「合成親(G)」のどの部分にあるファイルでもダブルクリックすれば、画像が表示されます。（「表示(V)」ボタンでも同様）

戻る スキャン画像ファイルの選択
次へ 「合成親(G)」のチェックボックスのオン/オフの状態によって違います。
        オン 合成伝票の設定 / オフ　２値化パラメータの設定


合成伝票の設定

ここでは、合成伝票を入力します。合成伝票の説明に関しては、市販のアニメ制作の教本などを参考にしてください。

ここでは、 Ａイ ＋ Ａ１' → Ａ１ つまり、Ａイ と Ａ１' を合成して Ａ１ を作るという指定の場合を述べます。

● 「(A)セル」と「(C)セル」を共に「Ａセル」にします。

● 「(Ｇ)合成伝票」の欄に 「Ａ－１ ＝ Ａ－１'」と表示されていて、「(D)合成可能な画像」の欄には 「Ａ－イ」 が表示されている必要があります。

表示されていない場合は、「戻る」で戻って次の事を確認してください。

「合成親(G)」の欄に「Ａ－イ」がありますか？

「番号(Ｕ)」の欄の「Ａ－１」をクリックして選択すると、その右にある「合成子 cHild」がチェックされていますか？

この点を確認の上、それらを設定してください。

● 「(Ｇ)合成伝票」の欄の「Ａ－１ ＝ Ａ－１'」を選択します。次に「(D)合成可能な画像」の「Ａ－イ」を選択します。

● 「追加(+) >」ボタンを押してください。すると、「(E)合成リスト」に「Ａ－イ」と表示されます。

● 以上で設定は終了です。「(Ｇ)合成伝票」の欄が「Ａ－１ ＝ Ａ－イ ＋ Ａ－１'」となっているはずです。

● 次に、本当にずれずに合成されるかどうか確認したい場合は、「プレビュー(P)」ボタンを押してください。このボタンが押されると合成伝票の設定通りに合成されます。

画面が見づらい場合は、以下のオプションをしていできます。

「4bitRGB」 薄くて見づらい場合にチェックしてください。

「コントラスト(Ｆ)」 コントラストを上げると見やすくなります。

「＋」 拡大

「－」 縮小

「×」 全体

※これらの設定は一時的なものです。この画面が見やすくするための設定に過ぎません。この設定が、インポートに影響することはありません。（つまり、プレビューしなくてもインポートできます。）

● 「欠番にも合成（Ｋ）」は、たとえば「Ａイ ＋ Ａロ → Ａ１」などの様に、合成子（Ａ－１'）がなくても「Ａ－１」を作成したい場合にチェックを付けてください。（一つ前のダイアログで「Ａ－１ 欠番」なっている必要があります。）

● 「合成親のみ（Ｏ）」は、たとえば「Ａ１' ＋ Ａ２ → Ａ１」などの様に、合成親に普通のセル（Ａ－２）を指定したい場合などにチェックを付けてください。

戻る スキャン画像ファイルにセル番号を付ける
次へ ２値化パラメータの設定


２値化パラメータの設定

ここでは、スキャン画像をもとに実線画像(*.anl)と彩色画像(*.anp)を生成するためのパラメータを設定します。

実線画像は色トレス線をできるだけ拾わないように、彩色画像は境界線に穴が空いて彩色時に色がもれないように、ここで調節します。

（図は省略）

  • 最初にプレビューしたい画像を選択します。通常、Ａ－１などの最初のセル番号の画像が自動的にプレビューされます。この画像を変更するには、「セル(A)」を変更し「セル番号(Ｅ)」に表示されるセルを選択してください。別の画像が読み込まれて「スキャン画像」と「プレビュー画像」が更新されます。
  • 「スキャン画像」の選択部分を拡大して表示したい場合は「全体表示(Z)」のチェックをオフにしてください。
  • 「更新(U)」のチェックをオフにすると、「プレビュー画像」が表示されません。複数のパラメータを一度に変更したい場合などに便利です。
  • 「P彩色」は彩色画像のプレビューをします。
  • 「L実線」は実線画像のプレビューをします。「強」は強調表示です。ノーマル・２値・選択範囲の３パターンで切り替わります。
  • 「窓　拡大・縮小」ボタンは、彩色画像と実線画像の２つを同時にプレビューするかどうか切り替えることができます。つまり３画面表示になるのでディスプレイにある程度の解像度がないとダイアログがはみ出ます。
  • 「全体」ボタンは、１画像全体をプレビューします。
  • 設定ファイル 「読込」ボタンは、ファイルから以前に「書込」した設定を全てのタブ（スキャン画像補正・色変更・基本色・補助色）に読み込みます。
  • 設定ファイル「書込」ボタンは、現在の全てのタブ（スキャン画像補正・色変更・基本色・補助色）の設定をファイルに保存します。

    • 保存した設定は「読込」ボタンからファイルを選択すれば復元できます。ファイル名は動画マンの名前やスキャナーの名前にしておくと便利です。
  • 初期値「記憶」は、現在の全てのタブ（スキャン画像補正・色変更・基本色・補助色）の設定を初期値としてレジストリに保存します。これは、ダイアログを表示した初期状態のタブ内のデフォルト値を変更するためにあります。
  • 初期値「呼出」はタブ内の値を変更後、ダイアログを表示した初期状態に戻したいときに押してください。
  • 「スキャン画像補正」タブでは、スキャン画像を補正して２値化しやすくするための各種設定があります。２値化の前処理として行われます。正常にトレス線が２値化できない場合はここの値を変更してください。このタブ内の値の意味は次のとおりです。

    • チェックボックスをチェックした機能のみ働きます。「回転」がもっとも最初に処理されます。次に「明るさ」「コントラスト」「シャープネス」がチェックした順に番号が表示されるのでその順番で処理されます。最後に白と黒のしきい値からレベル補正がかかります。

    • 「明るさ」は画像の明度要素を調節します。大が明るく、小が暗くです。R, G, B の明度を個別に増減させたい場合は、右のエディットボックスの数値の増減をそれに加えます。

    • 「コントラスト」は画像のコントラストを変更します。実線の線が薄いときに使うなどします。

    • 「シャープさ」は画像のシャープさを変更します。これを小の方にすると暈しの働きがあります。暈すことで、色トレス線が太くなり色の漏れが減ります。

    • 「白しきい値」は、これ以上の明度のピクセルは白と見なすことです。オフの場合は表示されている数値に関わらず常に２５５です。

    • 「黒しきい値」は、これ以下の明度のピクセルは黒と見なすことです。オフの場合は表示されている数値に関わらず常に０です。

    • 白と黒のしきい値は、レベル補正のための数値です。ただしCMYK成分の明度(Kプレーン)にのみ適応されます。白と黒のしきい値の間の明度はフルレンジで（引伸ばし）リマップします。このコマンドは、「実線画像」の線のコントラストを高めるために「コントラスト」エフェクトよりも有効な手段です。

    • 「回転」はスキャン画像を時計周りに回転します。小数点第２位まで設定できます。通常はスキャン時に適正な角度でスキャンする方が効率的です。９０度・１８０度・２７０度回転以外では画像サイズが変わるのであまり使用しない方が良いです。
  • 「色変更」タブでは、トレス線の色を変更する時や、複数の色トレス線を１つの色にまとめたりするのに使えます。例えば、「黄緑」の色鉛筆は「黄」と「緑」のまだらの線となってしまうので、「黄」を「緑」に変換して、「緑」の線として２値化することができます。
  • 「基本色」タブでは、基本的な２値化後の後処理です。

    • 「彩色画像」の「黒」・「赤」・「緑」・「青」は、トレス線の使用/不使用のチェックと太さを設定します。ただし、この太さの設定は、色の濃淡の淡の部分をどのくらいまでトレス線に含めるかという設定です。最高で２５０の明度のかなり淡い部分のトレス線も拾うので太くなります。したがって、コントラストの強い画像の場合太さはあまり変化しません。

    • 「ゴミ削除」は、明らかに線でない単独のドットのゴミを自動で削除するフィルタです。これはプレビューですら時間のかかる処理です。このドット値は実線画像の場合、NXNの辺のドット数です。つまりこの正方形の中にすっぽり入るドットはゴミとみなし削除します。AniLaPaintでは、実線画像のゴミはそのまま最終画像まで出てしまいます。この機能を生かすことで、後で１枚ずつ実線画像のゴミを取り除く手間が省けるのでお勧めです。画像のDPIにもよりますが、20ドットくらいが良いでしょうか。彩色画像の場合、実線画像以上に時間はかかりますが厳密に同じ色の連続するドット数を計算します。実は彩色画像のゴミはAniLaではビルドの際に自動的に全て消去されるので、ここでゴミを取る意味はあまりありません。それでもあえてこの機能がある意味は、色トレス線に他の色のドットがまとわりつくのを自動で削除したい特殊な場合のための機能です。通常はオフでかまいません。「色トレス線ゴミ削除方法」ボタンは、その際のドットゴミを削除するか本来のトレス線と同じ色に変換するかを選択することができます。

    • 「実線画像」は、実線画像の線の濃さを設定できます。TVに出力する場合、あまり濃いと線がぎらついたように見えます。だから薄めにした方が良いですが、事前にテストケースを作りTVに出力する実験などをして各自自分の好みの線の濃さにしてみてください。実線の濃さは、ビルド時にも変更できるので、あえてここではデフォルトのまま通す方が良いような気もします。
  • 「補助色」タブは、「彩色画像」の「シアン」・「マゼンタ」・「イエロー」の使用/不使用と太さを設定します。太さに関しては先の説明と同様なので省略します。

戻る スキャン画像ファイルにセル番号を付ける又は合成伝票の設定
次へ 上書きファイルの確認


上書きファイルの確認

ここでは、インポートするフォルダに実線画像、彩色画像が既に存在する場合にのみ表示されます。

「既存の画像(U)」の部分に既に存在する画像ファイルを表示しています。Lは実線画像、Pは彩色画像が存在することを表しています。これらは、画像のセル番号を選択して「実線（L)」または「彩色（P)」を選んで「表示(V)」ボタンを押せば右側に表示されます。

全て上書きしても良い場合「全て上書きします（Y)」のチェックをオンにしてください。それから、[次へ]進んでください。

上書きしたくない場合、[戻る]で戻って設定をやり直してください。

既に塗ったところへ上書きしてしまわないように十分注意してください。

戻る ２値化パラメータの設定
次へ インポート開始


インポート開始

ここまでで、インポートの設定は全て終わりました。ここでは、インポートの実行モードや内部フォーマットなどを設定しインポートを開始します。

実行モード(M)

実行モードの速度に関しては、環境設定のインポート/ビルドで変更できます。
[フォアグラウンドで実行]
インポートが終了するまで AniLaPaint の他の処理は行いません。
[バックグラウンドで実行]
インポートを裏で実行して AniLaPaint の他の処理も同時に使えるようにします。インポートの処理スピードが低下します。

作成する画像の内部フォーマット

これは環境設定のファイルで指定した状態になっています。変更の必要はありません。ここで変更しても環境設定には反映されません。あくまで一時的な変更に使います。

インポートするフォルダに今回の設定をログとして保存(L)

[する]
もう一度同じ設定で、インポートしたいときにこのログが使えます。このログを使って再インポートするには新規ファイルを保存する場所の設定の「前回と同じ条件でもう一度、新規作成しなおす」ボタンで行います。ログファイル名は、ImportLog.datです。
[しない]
ログを保存しません。

完了

インポートを実行開始します。

戻る 上書きファイルの確認
完了 インポート処理


インポート処理

インポート処理中の状況表示です。

インポート処理が、バックグラウンドで行われている場合は、他の AniLaPaint のコマンドも同時に使えます。

フォアグラウンドで行われている場合は、終了するまで他の AniLaPaint のコマンドは受け付けません。

処理を途中で中止する方法

中止する場合は、[処理中止]ボタンを押してください。
すると、確認のメッセージダイアログが表示されるので、[はい]を選択します。
しばらくすると、[処理中止]ボタンが[閉じる]に変るので、これを押します。


色アイコンに関するダイアログ

色アイコンとは、カット袋ワークスペースに結び付けられた名前つきの色のアイコンをあらわします。「色アイコンデータ」についてもお読みください。

カット袋ワークスペース 右図の色アイコンの画面の下にある 色アイコンメニュー のボタンを押したときに表示されるダイアログについて説明します。
色の追加 色の追加
色の設定 色の設定（アイコンの左ダブルクリック）
色の移動 色の移動
色の削除 色の削除

また、右クリックメニューなどから次のコマンドを選択した場合のダイアログについて説明します。

パレットファイル-リンクの設定


色の追加

新しい色を追加 新しい色を追加コマンドを実行して表示します。

色を、タイトルで分類し、名前を付けることができます。

タイトル

タイトルで分類できます。例えば、キャラクターの名前などです。
タイトルは最大で５０個まで付けることができます。

色に付ける名前

色に名前を付けることができます。アニメーションの色では、ハイライト（Ｈｉ）、ノーマル、１号影、２号影などもいっしょに付けておくと便利です。
たとえば、「肌の色 - Hi」「肌の色」「肌の色 - １号」などのように付けます。「カット袋」では、名前はソートされて表示されるので「Hi - 肌の色」などのようにすると、順番がとびとびになり見にくくなります。「色の名前 - 明るさ」の順で付けたほうが良いと思います。


色の設定

アイコンの色や名前の変更 アイコンの色や名前の変更コマンドを実行して表示します。

色や色に付けた名前を変更できます。

色の選択方法は、カラーピッカーと同様です。


色の移動

アイコンを別の分類へ移動 アイコンを別の分類へ移動コマンドを実行して表示します。

選択された色を、他の分類へ移動します。

移動先はすでにあるものから選んでも、新たにタイトルを付けることもできます。

複写チェックボックスをチェックすると、元の場所の色アイコンを残したまま別の分類に色をコピーします。


色の削除

アイコンの削除 アイコンの削除コマンドを実行して表示します。

削除して良い場合は「はい」を押してください。だめな場合は「いいえ」

複数選択した場合は、「全てはい」と「中止」ボタンが表示されます。

複数選択した場合は、「はい」や「いいえ」を押すと次の色について聞いてきます。

「全てはい」は、複数選択したもの全て削除します。

「中止」は、削除を中止します。ただし、それまでに「はい」を選んだ色については削除されます。


共有する色アイコンの設定

アイコンをファイルで共有（自動上書き保存）コマンドを実行して表示します。

カット袋ワークスペースに、外部のパレットファイルをリンクとして結び付けます。

リンクということは、同じパレットファイルを複数のカット袋から参照できるということです。

通常、ある作品を作るときには、同じパレットを複数のカットから使用します。

そのような場合に、パレットファイルをリンクして使用したら便利です。

リンクを貼る

リンクせずに、カット袋内にパレットを入れる場合はこのチェックを外してください。

パレットファイルのパス名(F)

パレットファイルの絶対パスを指定します。
存在しないファイル名を付けてリンクをする場合は、「新規のファイル」と見なされます。
▼ボタンを押すと過去に設定したファイルから選択できます。

参照...(B)

このボタンを押して直接ファイルを選択したり、新規のファイルであってもファイルを作成したいフォルダに移動して新しいファイル名を付けて「開く」ボタンを押せば、面倒な絶対パスの入力は避けられます。


色パカ・チェッカー

色パカ チェッカー 色パカチェッカーコマンドを実行して表示します。

これは、カット袋の現在のセルを全てアニメーション表示することで、色パカ（塗り間違い）などを発見するための機能です。

普通のムービーファイル化するソフトではなく、単に画像を全て読み込んで順に切り替え表示をするだけなので、速度などはいいかげんです。マシーンに十分なスペックがある場合のみfpsの設定が有効になりますが、通常はゆっくりとなります。

また、全ての画像を読み込めるだけの実メモリが必要です。実メモリが不足している場合は、読み込み中に警告が表示されこのダイアログを開くことができません。画像数が多い場合は、カット袋ワークスペースでいくつかのサムネイルを選択して、右クリックメニューからこのコマンドを実行し選択された画像のみ読み込むようにしてください。

「再生」「停止」ボタンはトグル方式になっています。再生中は下にあるボタン類は表示されません。再生中に色パカが見つかったら、「停止」ボタンを押して、[ < ][ > ]ボタンを使い問題のある画像へ移動し、[ 編集 ]ボタンを押すと、その画像が編集できます。

プレビューされる画像は、ディスク上と、現在の編集途中のどちらか最新のものを使います。

しかし、セルのサイズがすべて同一であるというのは前提です。アニメーション表示の場合は左上を揃えて表示しますが、停止中の表示では100%で表示でないと、小さい画像は自動的拡大してしまいます。サイズが異なる場合は、100% で表示してください。


セル画像のビルドに関するダイアログ

ここでは、セル画像のビルドに関するダイアログを説明します。「ビルドについて」もお読みください。

セル画像の更新処理モード

セル画像のビルド・パラメータ

境界線の色・詳細設定

セル画像を複数フォルダで一括作成

セル画像のビルド処理


セル画像の更新処理モード

現在のビューの画像をビルド 現在のビューの画像をビルド・ 全更新ビルド 全更新ビルド・ リビルド リビルドコマンドを実行して表示します。

３つのコマンドのうちどのコマンドで実行したかは、上の２行のコメントを読むと分かるようになっています。

実行モード

フォアグラウンドで実行
インポートが終了するまで AniLaPaint の他の処理は行いません。
バックグラウンドで実行
インポートを裏で実行して AniLaPaint の他の処理も同時に使えるようにします。インポートの処理スピードが低下します。

ビルド開始

ビルドを開始し、進行状況をセル画像のビルド処理ダイアログに表示します。

△次の処理を禁止する（デバッグ用オプション）

これは、ビルドが自動的な処理なので、ユーザの方が思い描いていたように色トレス線などを自動的に除去してくれないときがあります。そんな場合、なぜ除去してくれないのかを調べるためにビルドの処理の過程の一部を禁止する機能です。あくまで、ビルドアルゴリズムの問題点を割り出すためのデバッグ用オプションですので、通常はチェックしないでください。

ビルドする画質の設定

このボタンを押すと、セル画像のビルド・パラメータダイアログが表示されます。


セル画像のビルド・パラメータ

環境設定のインポート／ビルドタブや、セル画像の更新処理モード、セル画像を複数フォルダで一括作成ダイアログにあるボタンから呼び出します。

パラメータは、Windowsのレジストリに保存され、ユーザ毎に１つの設定のみ保存されるので、カット袋毎に変えることはできません。また、どのようなビルドについても同じ値が用いられます。

これらの値を変更しても、全更新ビルドなどによって全てのファイルが更新されるわけではありません。このパラメータを変更した後、新たなパラメータで確実にビルドを行いたい場合は、一度、クリーンを実行してカット袋内のセル画像をすべて削除してください。

これらのパラメータをいじって、計算をもっと省略して速度アップにつなげたりできます。以下にこれらのパラメータの意味を説明します。

決定

パラメータをレジストリに保存し、今後のデフォルト値とします。

中止

パラメータを設定しません。

戻す

レジストリに最後に保存した値に戻します。

初期値

AniLaPaint出荷時の値にします。

●塗り残し穴検査

穴の大きさ（０～１００）

その数値のピクセルの半径の円が入らない穴を塗り残し部分として埋めます。

捜査角（５～９０）

上記の円内の全てのピクセルを調べると時間がかかるので、指定角度毎に半径上のピクセルのみ調べます。例えば、１０度毎の場合、10/20....170/180 と18本の半径上の点のみを調べます。数値を大きくすると円内のドットを見落として、穴が埋まらないこともあります。

●トレス線の除去

捜査最短（０～１０）

トレス線を置き換える色を探す時に、指定距離（ピクセル単位）以内のものが見つかればこれで良しとする。この数値を小さくすると、もっとも近い色を真面目に探し続けますが、大きくすると、不真面目に捜査の過程で最初に指定距離以内のものが見つかれば、それ以上探しません。不真面目であるほど速度は速くなります。

捜査最長（０～１００）

トレス線を置き換える色を探す時に、見つからない場合、指定距離（ピクセル単位）まで探しつづけます。
見つからない場合、実線の最暗色の明度の灰色となりますので、数値を大きくしてみてください。また、色の侵食が気になるようなら、１０ドット以下にしてみてください。侵食が減ります。
この数値は、かなり小さくしないと速度はそれほど変わりません。

捜査角（５～９０）

トレス線を置き換える色を探す時に、指定角度毎に上記の捜査をします。小さくした方が、正しい近色を探し当てますが、速度は低下します。複雑でないキャラの場合、９０度毎でも問題なかったりします。

※これを９０にすると、かなり速くなります！

実線内最短（０～１０）

例えば、細い眉毛など実線画像では細眉毛の間が見えるのに、彩色画像だと境界線が太くて間に色が置ける隙間がない場合、通常の方法で実線の下の色を決めると、一番距離的に近い色が肌色となり、細い眉毛の間が眉毛の色ではなく肌色となってしまい、塗り残しのようになってしまいます。これを防ぐために、このような細い部分でつぶれてしまって色がぬれない所を強制的に実線の色に置き換える機能です。その時に実線画像げ現在使われているグレーの中の一番暗い色（色カーボン機能を使った場合は黒とは限らない）で埋められます。この数値は、どんな細さの線までを処理するかの値です。

●境界線

実線を２値とする（オン・オフ）

実線部分は実線画像を使いますが、AniLaPaintでは実線画像を８ビットのグレースケールで管理しております。この画像をビルド時に２値化してセル画像に貼り付ける機能です。主な用途は、AniLaPaintからエクスポートした後、他のソフト上でアンチエリアスをかける必要があるときなどに使います。GIF画像など、カラーキーで抜きたい場合なども、実線が２値であった方が都合の良いときなどに使います。
※（注意）ここで、２値を選択しても、エクスポート時に縮小をかけると、自動的にアンチエリアスがかかってしまいます。エクスポート時には縮小をしないでください。

[数値」未満(しきい値)は黒

実線を２値にする場合のみ設定可能です。２値化する場合、実線画像の線の色の範囲をこの数値によって白と黒に分けます。０にすると純粋な黒のみ選択されます。２５５にすると、一番薄い部分まで全ての実線部が選択されます。選択された部分が２値化により、セル画像に貼り付ける実線の部分となります。

色の境界を２値とする（オン・オフ）

通常AniLaPaintでは、ノーマル色と影色の境界を、境界線の幅の部分だけアンチエリアスをかけますが、これを行わないようにします。その場合は、常に最も近い色か中間色になります。

中間色（オン・オフ）

色の境界を２値にする場合のみ選択できます。中間色を選択すると、境界線を、ノーマル色と影色などの２色の中間色にします。

境界線の色・詳細設定

このボタンを押すと、境界線の色・詳細設定ダイアログが表示されて、ビルドの実線の濃さの均一化や２値化や色トレス線の消し方などの細かい設定ができます。


境界線の色・詳細設定

セル画像のビルド・パラメータダイアログの「境界線の色・詳細設定」のボタンで開きます。

▼２値以外を選択した場合の表示画面

▼２値を選択した場合の表示

これらのパラメータで、実線の下や色トレス線の部分に置き換える色をどう表現するか決めます。

決定

パラメータをレジストリに保存し、今後のデフォルト値とします。

中止

パラメータを設定しません。

戻す

レジストリに最後に保存した値に戻します。

初期値

AniLaPaint出荷時の値にします。

●実線の合成方法

２値

実線を２値化します。こちらがオンの時と同じです。

多値

実線画像をそのまま使います。こちらがオフの時と同じです。

[数値」未満(しきい値)は黒

こちらをお読みください。

実線の濃さの平均値を常に一定にたもつ（０～２５５）
実線を多値にする場合のみ選択できます。これを選択すると、ビルド時に実線の濃さを自動的に一定の濃さに調節します。方法は１枚の実線画像の中に含まれる線の色の平均値を計算し、その平均値が常に一定なるように、ここで設定した値との差の分だけ、明度を増減することで行っています。これを設定しておくと、１カット内の鉛筆の線の濃さが途中で変化してもある程度は、補完できます。しかし、インポート時に黒く潰れてしまったり、薄すぎて強弱のメリハリがない線はうまく変換できません。

※暗くしすぎると、グレースケールの線が２値に近づきますし、明るくしすぎると、実線がとんで見えなくなってしまいます。TV画面に出力する時に、ここで線を薄めにしてさらにムービー編集ソフト上でフリッカの削除機能をオンにして出力すると、とてもきれいな実線の表示ができます。ここの値はビデオボードなどとの相性ですので、いろいろ変えて実験してみて決めてください。

色カーボン（オン・オフ）
セルアニメで、実線を黒いカーボンでセルに転写することは良く知られていますが、まれに、茶色などのカーボンを使って線の明度を若干下げることで、画面に柔らかい印象を表現する場合があります。
このように、実線を任意の色に変換することで、線に色付けを行なう機能です。黒以外の色は「設定」ボタンを押して追加してください。ここで一度設定すると、システムのレジストリに保存され、次回起動時にも使えます。ただし、レジストリはアンインストールすると消されてしまいますので、後で再び必要な場合は、CSVファイルに書き出しておくと安全です。ただし、「""」と「,」を使って、以下のフォーマットになります。

"色の名前","１６ビットのRGB値"

●色トレス線の色の補完方法

２値

色トレス線を２値（明色と暗色の間はギザギザ）にします。色の境界を２値とするがオンで中間色がオフと同じ意味です。

３値

色トレス線を３値（明色と暗色と中間色で間がギザギザ）にします。色の境界を２値とするがオンで中間色がオンと同じ意味です。

多値（ペントレス）

色トレス線の中に置く色を明色と暗色のグラデーション（多値）にします。グラデーションがペンでトレスしたような質感になります。

多値（スムーズ）

色トレス線の中に置く色を明色と暗色のグラデーション（多値）にします。グラデーションがアンチエリアスに近いスムーズな質感になります。

色の割合（０～１００）

色の境界を２値とした場合に選択できます。これは、色トレス線内に作る明色と暗色の境界をどちらの辺により近づけるかを設定できます。５０の場合色トレス線のど真ん中で明色と暗色を分けます。

色トレス線部分の細線化
色の境界を３値・多値にした場合に選択できます。これは色トレス線を細線化したいときに使います。
細くした結果、新たな色の境界を「明色側に」置くか、「中央に」置くか、「暗色側に」置くかを決めて、細くする方法を「数値」「％以下の線」で細線化するか「数値」「ピクセル以下の線」で細線化するかを決められます。また、ビルドのアルゴリズム上「細線化を前処理として行う」か「細線化と色の補完を同時に行う」かで結果が異なります。
角を強調する
色の境界を多値（スムーズ）にした場合に選択できます。これは、スムーズの場合尖った部分の色トレス線が角が取れてしまったような画像になるのを防ぐ機能です。ここでいう角度はピクセルの連続の角度なので、かなり拡大された状態での値のため、かなり大きめに１７５度がデフォルトになっています。拡大すれば、普通の曲線は１７５度以上の直線に近い線となります。尖った部分は、拡大しても１７５度以下になるのでこれで判断しています。強調係数は、１～９９９までの値です。１が角を強調するをチェックしていない状態と同じです。値を大きくすると、角のコントラストが高くなりエッジを強調します。デフォルトは５００倍です。

Core ReTas 用の画像を作る方法

上記の設定で、実線も色トレス線も２値にしてください。

Core ReTas では、後でアンチエリアスや、フリッカーフィルタが働きます。ですので、２値にすることで AniLaPaint からエクスポートした画像を読み込めるようになります。 AniLaPaint では、色トレス線を手作業で消す必要は無いので、その分だけ手間暇を稼げると思います。また、色トレス線を自動消去するので線パカが存在しません。（２値にするとビルドも早くなります）

※ただし、エクスポート時にエクスポートダイアログで新たに追加したオプション「24bit マスク無し（透明キー白）」にして「画像縮小」をチェックせずに出力してください。


セル画像を複数フォルダで一括作成

複数のカット袋の全更新ビルドか複数のカット袋のリビルドコマンドで表示します。

複数のフォルダを選択して一気に、セル画像の全更新ビルドまたはリビルドを行います。

上の２行のメッセージに（バッチビルド）とあれば全更新ビルドのことです。（バッチリビルド）とあればリビルドです。

セル画像を作成（更新）したフォルダの一覧表

ここには、ビルドしたいカット袋フォルダを指定します。現在のカット袋ワークスペースは最初から表示されます。

表に追加

このボタンを押して、連続にビルドしたいカット袋フォルダを追加してください。

表から削除

表の選択されている行を削除します。

白紙に戻す

表から全ての行を削除します。

ビルドする画質の設定

セル画像のビルド・パラメータダイアログを表示します。

一括ビルド開始

ビルドを開始し、進行状況をセル画像のビルド処理ダイアログに表示します。


セル画像のビルド処理

セル画像の更新処理モードやセル画像を複数フォルダで一括作成からビルドを開始した場合に表示されます。

セル画像のビルド処理中です。

セル画像のビルド処理が、バックグラウンドで行われている場合は、他の AniLaPaint のコマンドも同時に使えます。フォアグラウンドで行われている場合は、終了するまで他の AniLaPaint のコマンドは受け付けません。

中止する場合は、[処理中止]ボタンかウィンドウの[×]を押してください。

すると、確認のメッセージダイアログが表示されるので、[はい]を選択します。

しばらくすると、[処理中止]ボタンが[閉じる]に変るので、これを押します。


エクスポートに関するダイアログ

ここでは、セル画像のエクスポートに関するダイアログを説明します。「エクスポートについて」もお読みください。

セル画像のエクスポート

外部コンバータ引数設定(24bit+8bitMask)

外部コンバータ引数設定(32bit)


セル画像のエクスポート

エクスポート エクスポートコマンドを実行して表示します。

現在のカット袋のセル画像を外部のソフトで読めるフォーマットに変換して出力します。詳しくは「エクスポートについて」をご覧ください。

全ての設定はエクスポートを行った時の状態となります。カット袋毎別々の状態がexport.iniファイルに保存されます。

①マスク付きセル画像を出力するフォルダ

どこへエクスポートすれば良いかを指定します。通常、AniLaPaint のデータとは別のフォルダを指定します。デフォルトでは AniLaPaint の下に Export というフォルダを作ります。

②参照..

フォルダ参照ダイアログを表示します。これには新しいフォルダを作る機能はありませんが、親フォルダを選び [ OK ] したら①のボックスに選んだフォルダ名が表示されるので、これに新しいフォルダ名をキーボードで書き加えてください。その場合、フォルダの仕切り文字 \ を忘れないようにしてください。ここで、絶対パスを指定しない場合、カレントドライブのカレントディレクトリからの相対パスとなります。
(例)
参照によって選られたフォルダ名 → D:\DATA1\CUT001
その下に新しくフォルダを作る場合 → D:\DATA1\CUT001\EXPORT

③A, B ... セルごとにサブフォルダを作ってエクスポート (8bitﾏｽｸは AM, BM...)

①のボックスで、D:\DATA1\CUT001\EXPORTとなっているときは、その下に A, B, などのフォルダを作り、セル毎に分類しながらエクスポートを行います。つまり、D:\DATA1\CUT001\EXPORT\A\A001.TGAなどというようにエクスポートされます。
このチェックボックスの意味は、プレミアや AnimeStudioII などのソフトがフォルダ指定によりＡセル全てだとかＢセル全てと読み込める仕様になっているので、それにあわせるためのものです。
出力画像が 24bit + 8bit の場合は 8bit のマスクを AM, BM などのフォルダに入れます。

④エクスポートするファイルのフォーマット

どのソフトで読み込むかを決めて、そのソフトで読み込める形式を選択します。詳しくは、「エクスポートできる画像」をお読みください。

⑤マスクの透明部分

[K 黒 = 透明 / 白 = 不透明]
マスクの黒の部分を透明として、白の部分を不透明として認識するソフトで使用するときに、これを選択してください。
[S 白 = 透明 / 黒 = 不透明]
マスクの白の部分を透明として、黒の部分を不透明として認識するソフトで使用するときに、これを選択してください。

※ ④で[外部コンバーターで変換出力]を選択した場合、外部コンバータによってはマスクを反転してしまうものがあります。その場合は、そのコンバータで十分テストをしてから選択してください。

⑥ファイル更新

[T ﾌｧｲﾙ作成日時による更新]
ファイルの日時を調べて、既に最新のエクスポートされたファイルが存在しない場合に限りエクスポートします。ビルドの画質の設定を行った場合は、必ず[A全て更新]にしてください。
[A 全て更新]
どんな場合でも全てをもう一度エクスポートします。

⑦画像縮小

縮小してエクスポートする場合にはこのチェックボックスにチェックを付けてください。そして、以下のうちから選択してください。
[VGA (640x480)]
アスペクト比を無視して 640 x 480 ピクセルに縮小します。
[W (640x□)]
横幅は 640 に揃えます。横幅の縮小率を元にアスペクト比を変更しない縮小をかけます。
[H (□×480)]
縦幅は 480 に揃えます。縦幅の縮小率を元にアスペクト比を変更しない縮小をかけます。
[2 分の 1]
縦横のピクセル数を２分の１にした縮小をかけます。
[3 分の 1]
縦横のピクセル数を３分の１にした縮小をかけます。

⑧開始 ＆ 中止

エクスポートを始める場合は [ 開始 ] ボタンを、中止する場合は [ 中止 ] ボタンを選択してください。


外部コンバータ引数設定(24bit+8bitMask)

セル画像のエクスポートでフォーマットに「外部コンバータで変換出力」を選択し24bit出力で開始した場合に表示されます。

MS-DOS プログラムなどの外部コンバータの引数を指定します。

MS-DOS 仕様なので、UNCパスには対応していません。

①AniLaPaintが出力する変換前のファイルのフォーマット

AniLaPaint が外部コンバータに送るためのテンポラリファイルのファイル形式を指定します。
外部コンバータが認識できるファイル形式を指定しておいてください。

②コンバート後の拡張子

ここに、外部コンバータが出力するファイルに付けられる拡張子を指定します。 AniLaPaint は、この拡張子のファイルが外部コンバータによって生成できるようにパラメータ %2 を生成するために使います。

③ 24bit 画像コンバート時のコマンドライン

使用するコンバータによります。 %1 と %2 を必ず挿入して記述してください。
%1は、AniLaPaint によって出力されるテンポラリファイル名の挿入される場所を表しています。
%2は、外部コンバータによって出力されるファイル名です。このファイル名を AniLaPaint 生成してこの位置に貼り付けます。また、実際に変換できたかどうかを判断するのにも使います。ですから、外部コンバータで AniLaPaint が生成するファイル名(%2)以外のファイル名では出力しないでください。また、この仕様がない（つまり出力するファイル名をコマンドラインで決められない）コンバータは仕様できません。
※当方は、コマンドラインの記述に関する質問は受け付けません。あなたがお使いの外部コンバータのマニュアルを良く読んで記述してください。

④ 8bit 画像コンバート時のコマンドライン

③と同様です。


外部コンバータ引数設定(32bit)

セル画像のエクスポートでフォーマットに「外部コンバータで変換出力」を選択し24bit出力で開始した場合に表示されます。

MS-DOS プログラムなどの外部コンバータの引数を指定します

MS-DOS 仕様なので、UNCパスには対応していません。

①AniLaPaintが出力する変換前のファイルのフォーマット

AniLaPaint が外部コンバータに送るためのテンポラリファイルのファイル形式を指定します。
外部コンバータが認識できるファイル形式を指定しておいてください。

②コンバート後の拡張子

ここに、外部コンバータが出力するファイルに付けられる拡張子を指定します。 AniLaPaint は、この拡張子のファイルが外部コンバータによって生成できるようにパラメータ %2 を生成するために使います。

③ 32bit 画像コンバート時のコマンドライン

使用するコンバータによります。 %1 と %2 を必ず挿入して記述してください。
%1は、AniLaPaint によって出力されるテンポラリファイル名の挿入される場所を表しています。
%2は、外部コンバータによって出力されるファイル名です。このファイル名を AniLaPaint 生成してこの位置に貼り付けます。また、実際に変換できたかどうかを判断するのにも使います。ですから、外部コンバータで AniLaPaint が生成するファイル名(%2)以外のファイル名では出力しないでください。また、この仕様がない（つまり出力するファイル名をコマンドラインで決められない）コンバータは仕様できません。
※当方は、コマンドラインの記述に関する質問は受け付けません。あなたがお使いの外部コンバータのマニュアルを良く読んで記述してください。


バージョン情報(AniLaPaint)

AniLaPaint のバージョン情報コマンドで表示します。

現在使用中のバージョンが表示されます。

ライセンス・キー登録もここから行います。

バージョンの表記法については「バージョン番号について」をご覧ください。


ライセンス・キー登録

β版ではできません。


ビュー

ここでは、AniLaPaintのビューウィンドウに関して説明します。

AniLaPaintのビューには次の３種類があります。

実線画像のビュー 　実線画像のビュー

彩色画像のビュー 　彩色画像のビュー

セル画像のビュー 　セル画像のビュー


実線画像のビュー

実線画像での作業について

実線画像の編集作業は、ゴミなどを除去したり、不必要な実線を除去することです。
注意しなければならないことは、色選択クールバーが消しゴムになっているかどうかです。境界線になっていると線を追加することになります。

ゴミの発見を容易にするために、 強調表示 強調表示などを利用しましょう。
クイックズームと併用すれば好きな場所のズームが容易です。

最終的なセル画像に、この実線画像がそのまま合成されます。

ただし、境界線の色・詳細設定で線の濃度をカット単位でビルド時にそろえることができます。

マウスによる操作ついて

左クリック 現在のツールの状態による編集。

右クリック スポイト動作。（ただし環境設定でメニュー表示に変更可能）

[Ctrl] + 左クリック スポイト動作。

[Shift] + 左ドラッグ 手のひらカーソルによるスクロール （ただし、スクロールが始まったら Shift キーは離してください）

左ドラッグ バケツ系ツールの場合のみ手のひらカーソルによるスクロール。


彩色画像のビュー

彩色画像での作業について

彩色画像での編集作業は、色を塗ることです。そのためのツールやツールバーが用意されています。

ゴミなどは、背景色にしか隣接していないものはセル画像のビルド時に自動的に除去されます。抜き指示の×なども他の色に接していなければ自動的に除去されます。

境界線に色を付ける必要がある場合は、色保護クールバーの反転有効を使います。タッチなどの処理や、塗り色とは違う色で境界線を染める場合に使います。

境界線は何もしなければビルド時に自動的に隣接する色に置きかえられます。

境界線の色は、黒でも赤でも AniLaPaint 上では等しく「境界線」として認識されます。黒だから実線、赤だから色トレス線というわけではありません。実線か色トレス線かをプログラムが判別するのは以下の方法でセル画像のビルド時に行われます。

実線画像の同じ位置のピクセルが黒(0～179)で、彩色画像のその位置に境界線がある場合、その境界線のピクセルは「実線」であると判別されます。

実線画像の同じ位置のピクセルが白(180～255)で、彩色画像のその位置に境界線がある場合、その境界線のピクセルは「色トレス線」であると判別されます。

ですから、「実線」か「色トレス線」であるかを決めるのは、あくまで「実線画像」なのです。

全体が色トレスの場合は、境界線を隣接する色で染める必要はありません。そのような場合は、実線画像そのものを削除すれば済むわけです。

同様に、部分的に鉛筆で書いた線を色トレスに変更したい場合は実線画像のその部分の黒線を消去してください。

連続する番号の画像の色パカをチェックするにはビュー切り替えツールバーをお使いください。

不連続な番号の画像の色パカをチェックするにはしおりツールバーをお使いください。

また、アニメーション表示により色パカをチェックするにはカット袋ワークスペースでアニメ表示したいセルを複数選択して、右クリックメニューから色パカチェッカーを選択してください。

クイックズームと併用すれば好きな場所のズームが容易です。

マウスによる操作ついて

左クリック 現在のツールの状態による編集。

右クリック スポイト動作。（ただし環境設定でメニュー表示に変更可能）

[Ctrl] + 左クリック スポイト動作。

[Shift] + 左ドラッグ 手のひらカーソルによるスクロール （ただし、スクロールが始まったら Shift キーは離してください）

左ドラッグ バケツ系ツールの場合のみ手のひらカーソルによるスクロール。


セル画像のビュー

セル画像での作業について

セル画像での編集作業はありません。ただ、ビルドの出来具合を確認するだけです。

AniLaPaintでは背景との境界にフリンジが発生しません。背景色を変更することで確認できます。

穴の部分を確認するには、 マスク表示 マスク表示を使います。

連続する番号の画像の色パカをチェックするにはビュー切り替えツールバーをお使いください。

不連続な番号の画像の色パカをチェックするにはしおりツールバーをお使いください。

また、アニメーション表示により色パカをチェックするにはカット袋ワークスペースでアニメ表示したいセルを複数選択して、右クリックメニューから色パカチェッカーを選択してください。

クイックズームと併用すれば好きな場所のズームが容易です。

黒の実線がゴミとして残った場合は、実線画像を再編集した後、セル画像の更新ビルドを行ってください。色が間違っていた場合は、彩色画像を再編集した後、セル画像の更新ビルドを行ってください。色トレスの部分に不必要なにじみが出た場合は、彩色画像のその部分の色トレス線を手動で塗ってください。
境界線の色・詳細設定などを変更して、線の質や境界線のスムーズさなどを変更したい場合は、必ずリビルドしてください。

マウスによる操作ついて

左クリック 現在のツールの状態による編集。

右クリック スポイト動作。（ただし環境設定でメニュー表示に変更可能）

[Ctrl] + 左クリック スポイト動作。

[Shift] + 左ドラッグ 手のひらカーソルによるスクロール （ただし、スクロールが始まったら Shift キーは離してください）

左ドラッグ スポイトツールの場合のみ手のひらカーソルによるスクロール。


第５章 よくある質問(FAQ)

ホーム>>

第５章 よくある質問(FAQ)

ここでは、今までに受けた質問をもとに、ＦＡＱをまとめました。

[FAQ01] インストールしても起動しない


[FAQ01] インストールしても起動しない

AniLaPaintはインストーラを起動することで、スタートメニューやディスクトップに登録され、いつでも実行できるようになります。

しかし、アップグレード版のインストーラで新しいパソコンへインストールした場合は、必要なシステムファイル（ＤＬＬ）がインストールされません。そのために起動できないことがあります。その場合、AniLaPaint起動時に、「必要なシステムファイルが不足しています。フルセット版のインストーラでインストールし直してください。」というメッセージが表示されます。

また、フルセット版でインストールしたにもかかわらず、上記メッセージが出る場合は、ＯＳのシステムファイルが古いことが考えられます。例えば、ＡｎｉＬａＰａｉｎｔはＡｃｔｉｖｅＸの技術を使用して作られていますが、このＡｃｔｉｖｅＸはそもそも、Ｗｉｎｄｏｗｓ９５やＮＴ４．０の発売当初には欠けていました。これらは、ＯＳのファイルの一部なのでAniLaPaintのインストーラに含める事ができません。ＭＳ社は、ＯＳのシステムファイルのアップグレードのために、ＩＥやＯｆｆｉｃｅなどの自社製品をインストールする事を推奨しております。

ＡｎｉＬａＰａｉｎｔが正常に起動するためには、少なくとも、ＩＥ４．０１ＳＰ２以上のインストーラに含まれているシステムファイルのバージョンが必要です。また、２０００年問題に対処するためにもこのバージョン以上のシステムファイルが必要です。

※Ｗｉｎｄｏｗｓ９８ や ２０００ などでは、システムファイルが古いために起動できないと言う事はありえません。フルセット版をインストールすれば必ず起動します。起動しない場合は、作者へ連絡してください。

以下に ＡｎｉＬａＰａｉｉｎｔで 使用するシステムファイルのうちバージョンに依存しそうなものを解説します。

●Windows サポートAcriveX(*1)

これらのファイルは、LEADTOOLS ActiveX から呼ばれる可能性のある基本的なDLLです。IE3.02未満の場合には含まれておりません。
WININET.DLL INLOADER.DLL URLMON.DLL HLINK.DLL
HLINKPRX.DLL OLEAUT32.DLL STDOLE2.TLB
※通常DLLは、次のシステム起動時から有効になります。
※これらのファイルは、フルセット版にも含まれておりません。ＩＥなどのＭＳ社の９８年以降の製品をインストールしてください。

●MFC DLL &OLE サポート DLL(*2)

同名の異なるバージョンのファイルが存在します。常に最新のバージョンをお使い下さい。初期のWindows95出荷時には、AniLaPaintで使用するDLL のバージョンより一部古いものが使われています。
MFC40.DLL MFC(ver4.0)コアコード
MFC42.DLL MFC(ver6.0)コアコード
MFC40LOC.DLL 日本語対応MFC(ver4.0)共有リソース
MFC42LOC.DLL 日本語対応MFC(ver6.0)共有リソース
MSVCRT.DLL Ｃランタイム共有DLL
MSVCRT40.DLL Ｃランタイム共有DLL(MFCver4.0&6.0用)
OLEPRO32.DLL Ｍｉｃｒｏｓｏｆｔ　ＯＬＥプロパティサポートＤＬＬ
Regsvr32.exe (*3)のOCXの登録に使います
※通常DLLは、次のシステム起動時から有効になります。
※これらのファイルは、フルセット版に含まれております。アップグレード版には含まれておりません。

●Windows DLL

CTL3D32.DLL ３ＤコントロールサポートＤＬＬ
COMDLG32.OCX コモンダイアログコントロール
COMCTL32.DLL コモンコントロールＤＬＬ
※ＣＴＬ３Ｄ３２．ＤＬＬは、ＯＳ毎に別物です。別のＯＳのものをコピーしてはいけません。
※ＣＯＭＣＴＬ３２.DLLは、ＩＥ４で変更されました。ＡｎｉＬａＰａｉｎｔでは変更後のバージョンを必要とします。
※ＯＳの一部なので、勝手に配布できません。最新版を手に入れたい方は、IEの最新版などをインストールしてください。

●LEADTOOS ver7.0j ActiveX(*3)

AniLaPaintのコアをしめるOCX です。AniLaPaintは、LEAD社と文化オリエント社からライセンスを受けて使用しています。
LFBMP70N.DLL BMP読み書き LFTGA70N.DLL TGA読み書き
LFCMP70N.DLL CMP読み書き LFTIF70N.DLL TIF読み書き
LFFAX70N.DLL FAX読み書き LFWMF70N.DLL WMF読み書き
LFPCT70N.DLL PCT読み書き LTFIL70N.DLL ファイル読み書き
LFPCX70N.DLL PCX読み書き LTIMG70N.DLL イメージ処理
LFPNG70N.DLL PNG読み書き LTKRN70N.DLL LEADTOOLSカーネル
LFPSD70N.DLL PSD読み書き LTTWN70N.DLL TWAINサポート
LFRAS70N.DLL RAS読み書き LTOCX70N.OCX コントロール
※これらのシステムファイルはフルセット版に含まれております。アップグレード版には含まれておりません。
※インストール時にLTOCX70N.OCXは自動的に登録されます。ただし、(*1)(*2)のファイルがシステムにある事が前提です。ない場合は登録に失敗します。したがって、ＩＥのアップグレードを先におこなってください。


[FAQ02] 存在するフォルダにもかかわらず存在しないとメッセージがでる

共有条件が「フルアクセス」になっていないフォルダを、インポート・カット袋ワークスペース・パレットファイルのリンク・エクスポートなどで設定すると、「存在しません」といわれることがあります。必ず、AniLaPaintでアクセスするフォルダの共有条件は「フルアクセス」にしておいてください。NTFS を使用している場合なども、書き込み禁止フォルダへのアクセス時に上記の現象が起こります。

※画像のローダとして使うだけなら、「読込み専用」でも可能です。


[FAQ03] 彩色画像編集時の[元に戻す/元に戻すの取り消し] の速度が遅い

彩色画像編集時に 元に戻す 元に戻すや 元に戻すの取り消し 元に戻すの取り消しコマンドを実行すると、画像の状態を編集の前や後に変化させることができますが、速度が遅いと感じる場合があります。
これは、そこそこ速いマシーンでは気にならない程度ですが、遅いマシーンでもこれをすばやくする方法があります。

まずは、環境設定のUndo の項目で、Undo情報を速いハードディスクに変えてみてください。情報を保存する場所をハードディスクにしてある限り、Undoの数をいくつに設定しても速度的には同じです。ポイントは、速いディスクにすることと、データ圧縮しないことと、Undo情報の作成方法を複製にすることです。速いマシーンでは差分の方がデータが小さくなりディスクに書き込む時間が短くてすむので、結果的に速くなることもありますが、遅いマシーンでは差分を計算する時間そのものがネックとなります。

つぎに、これが最も効果的なことですが、元に戻す動作の際に、彩色画像の境界線の部分に自動的にマスクをかける処理がデフォルトで入るので、これを行わないというテクニックです。通常、境界線に色を塗ったりしない限り、ファイルを開いたときから境界線の部分に変化は無いはずです。つまり、元に戻す動作を行った際にいちいち色の保護領域の変化をチェックする必要は無いはずなのです。このデフォルトの動作を行わないように、 色保護領域を常に更新 色保護領域を常に更新をオフにしておきます。これは、境界線だけではなく、ユーザが保護を指定した色の領域も変化させない場合のみ有効な手段です。しかし、以外にこのような場合は多いはずです。これをオフにしただけでおかなり速くなると思います。

お試しください。


第６章 バージョンアップによる変更点

ホーム>>

第６章 バージョンアップによる変更点

ここでは、現在に至るまでのAniLaPaintのバージョンアップによる変更点を掲示しています。

[1997/06/25～1998/04/10] ver1.0 ～ ver1.2β4
[1998/06/10] ver1.2 β５
[1998/12/27] ver1.2 β5.4
[1999/06/01] ver1.2 β5.5
[1999/06/23] ver1.2 β5.6
[1999/10/25] ver1.2 β5.7Preview1～6
[1999/11/16] ver1.2 β5.7Preview7
[1999/11/17] ver1.2 β5.7Preview8
[1999/12/12] ver1.2 β5.7Preview9
[1999/12/18] ver1.2 β5.7Preview10


[1997/06/25～1998/04/10] ver1.0 ～ ver1.2β4

  • ver1.0 ( 97/06/25 )

    • 友達の要望で、アニメ用の簡単な色塗りソフトを開発。当時は、ニュートン社の OCX を使用した。

  • ver1.1 ( 97/11/27 )

    • ver1.0 のバグフィックス版。

  • ver1.2β１ ( 98/03/13 )

    • OCX を LEADTOOLS 社のものに変更したことで、白紙からプログラムを書き直した。これに伴って、シェアウェア制作を決意する。

  • ver1.2β２ ( 98/03/26 )

    • 修正されたバグ

      • 「線画画像」の編集画面で編集範囲を指定したにも関わらず、指定外の部分まで消去できてしまうバグ。
      • 「カット袋」のパレットに色を「追加」した際に、リストコントロールが初期化され真っ白になってしまうバグ。
      • 「カット袋」のパレットから色を「削除」しようとすると、致命的なエラーとなり、落ちてしまうバグ。
      • 「カット袋」の「セル画像のビルド」で「線画画像」が真っ白な場合、MFC のランタイムエラーとなり、落ちてしまうバグ。

  • ver1.2 β３ （ 98/04/06 )

    • 修正されたバグ

      • 外部ファイルへのエクスポートで画像縮小時にαチャンネルの不透明の部分へぼかしの残骸がのこっていた（実害はないはずだ）が、見栄えがわるいので、それを除去するようプログラムを修正した。
      • セル画像をビルドする際に、変更済みの彩色画像ではなく、未変更のファイル上のデータを使ってしまう場合があった。そこで、ビルドの前には未保存のデータを必ず保存するようダイアログを表示することにした。

    • 追加された機能

      • 「カット袋」内のサムネイルアイコンを詰めて表示できるようにした。
      • 「カット袋」内の実線・彩色・セル画像に検査済みのマークを表示可能にした。
      • メニュー「開く」などで、表示されるファイルダイアログでのファイルフィルタを変更。最初に「サポートしている全ての画像」を表示するようにした。
      • AniLaPaint で読み込める形式の画像フォーマットpcx/tga/png/psd/bmp/wmf/tif/jpg/cmp/ras/pctを開いた場合、画像ビュアーを兼ねるようにした。
      • 彩色画像の編集メニューに「色シールドの解除」を追加。
      • 今まで右にしかドッキングできなかった「スポイトパレット」「クイックズーム」「カラーピッカー」を左にもドッキングできるようにした。

  • ver1.2 β４ ( 98/04/10 )

    • 修正されたバグ

      • セル画像のビルドの際、実線画像または彩色画像のどちらかが無い場合ビルドが行われないバグ。
      • スキャン画像のインポートやセル画像のビルド時、バックグラウンド処理にしたとき、処理が終了しても「カット袋」のサムネイルが更新されないバグ。

    • 追加された機能

      • メニューの「表示(V)」に「色パカチェック バー」を追加。


[1998/06/10] ver1.2 β５

  • 修正されたバグ

    • インポート、セル画像ビルド時の処理中に[Enter]キーを押すと異常終了する。

    • バケツカーソル時にドラッグすると手のひらカーソルになるが、水平または垂直にドラッグした場合は手のひらカーソルが表示されず（スクロールされず）塗ってしまうバグ

    • ペンのカーソル位置に彩色できなかった。（軌跡に彩色していた。）

    • タッチペン選択時に背景色を変更すると、マスクが解放され、全ての部分に彩色できてしまった。

    • カット袋のドッキング時のサイズの計算間違いが起こることがあった。

    • インポート時に（合成に使用しないただの）欠番があると異常終了する。

  • 追加された機能

    • インポート時の変更

      • １番目にインポート先のフォルダ設定をもってきた。
      • 合成伝票を使用しない場合、「合成伝票の設定」のページを表示しないようにした。
      • 上書きするファイルがない場合は、「上書きの確認」のページを表示しないようにした。
      • ２値化のパラメータ設定を彩色画像と実線画像で分けていたが、これを１つのパラメータで可能にした。
      • スキャン画像のファイルダイアログで複数のファイルを選択した場合、２バイト文字がパスの途中にあった場合、正確に読めなかった MFC の不具合を他の方法で回避した。
      • プレビューボタンを押さなくてもパラメータを変更した場合、常に自動的に更新されるようにした。
      • プレビューに、スキャン画像と彩色画像（実線画像）の2画面を表示するようにした。
      • スキャン画像上を、手のひらカーソールでスクロールさせることで、プレビュー位置を変更できるようにした。
      • プレビューした画面に直接、塗りのテストが行えるようにした。
      • 全ての画像に対して同一の回転（１００分の１度単位）をかけることができるようになった。
      • １画像全体のプレビューが可能になった。（この画面でも塗りテスト可）
      • 実線・色トレス線の各々について、太さを調節できるようにした。

    • バッチ処理（インポート・セル画像ビルド・エクスポート）終了時に音声や音楽を鳴らせるようにした。

    • 編集時の機能追加

      • 画像編集時 Shift キーは押している間は手のひらカーソルになり、スクロールできるようにした。
      • クイックズームにマウスカーソル位置の画像の拡大機能を付けた。（２倍・４倍・８倍・１６倍に拡大できる）
      • タッチペンの機能に、境界線の消去（背景色で彩色）を付けた。
      • オープンツールバーを追加。このツールバーによって、現在編集中の画像と関連する、次の画像・前の画像・線画画像・彩色画像・セル画像を簡単に開くことができる。このツールバーで編集対象を移動した場合、移動前の画像を自動的に保存したり、閉じたりすることができる。また、移動前の拡大位置を保持したまま、画面を切り替えるので、色パカの発見などにも役立つ。（なお、汎用フォーマットの画像でも、同一フォルダ上の画像を名前順に次々と開くことができるので便利。）
      • 実線画像の修正（線の追加）ができるようにした。（おまけ機能レベル）
      • 現在編集中の画像の、色を変更する機能を追加。バケツ（フィル）機能の色指定バージョンとも考えられる。マウスでクリックした色を含む領域全てを、現在の選択色に置き換えます。選択範囲がある場合はその範囲内のみ影響します。

    • カット袋への追加機能

      • 色パカチェッカーを追加。これは、Ａセル・Ｂセル毎にアニメーション表示することで、色パカやスキャン時のカタりなどを発見すること目的としたダイアログです。（サムネイルを選択すると選択したものに限定できる。）

    • ヘルプへの対応

      • ヘルプの目次に対応
      • 状況依存ヘルプ（Ｆ１キーとＳｈｉｆｔ＋Ｆ１キー）に対応。

    • その他の変更

      • ファンクションキーなどのショートカットをいくつか変更
      • 右クリックメニューを整理
      • ネットワークコンピュータ以下のフォルダでもほぼ問題なく動くみたいです。（家にLANがないので、友人宅などで時々チェックする程度。動作確認の報告求む。）
      • ファイルを開く＆保存ダイアログの状態を保持するようにした。（前回終了時と同じフォルダ状態で開ける）
      • アンインストールにも対応
        • Tikuwa氏(RXQ01346@niftyserve.or.jp)制作のかなり優れたインストーラだと私が感じている、MakeSetを使って制作しました。作者には大変感謝しています。

    • 今回対応できなかったこと（β６では対応するつもり）

      • 茶カーボンなどのような実線に色を付けるビルド処理
      • CoreReTas対応のエクスポート
        • ※Msayuki Tanakaさん、数々の御指摘ありがとうございます。今回かなり対応できました。遅々たる開発速度ですが、これからもよろしくお願いいたします。

    • お知らせ

      • β６が出るのはかなり時間がかかると思います。
      • しばらく（たぶん３ヶ月くらい）、職場が変り、全くプログラムをやる時間的余裕がなくなるからです。
      • ただし、β５に致命的なバグなどがあれば、β５のマイナーバージョンとして対応はします。
      • 機能追加などについての御意見は、常に受け付けています。

    • メモ

      • 今回のゴールデンウィークは、ヘルプの勉強と制作ですべてなくなった(T_T)


[1998/12/27] ver1.2 β5.4

☆β5.4では、試用期間を1999/12/31まで延長しました

  • 修正されたバグ

    • インポート時のバグ

      • インポート時のニ値化パラメータの設定で、境界線の太さがおかしい(1.2.5.1 fix)
        • ある色の境界線の太さを調節するのに、他の色の太さまでかわってしまう。
      • インポート時のニ値化パラメータの設定で、実線画像の濃さを変更(1.2.5.1 fix)
        • 実線画像を生成するプログラムを変更しました。β4 の生成ルーチンのほうが奇麗だったのでちょっと元にもどしました。
      • インポート時のニ値化パラメータの設定で、設定ファイル[書込]ボタンがネットワーク(UNCパス)に非対応(1.2.5.2 fix)
        • 設定ファイルの書き込み先が、UMCパスの場合 RuntimeError になる。そのため、インポート設定の書込みがネットワークドライブに作成できません。
      • インポート実行中、「A-1彩色画像保存中…」と表示された直後、RuntimeErrorが発生することがある(1.2.5.3 fix)
        • MOやフロッピなどのディスクのライトプロテクトや（HDDの場合も）容量不足、IOエラーが発生すると、RuntimeErrorになってしまいます。エラーの原因を表示して、RuntimeErrorを起こさないようにしました。
      • すでに開かれている実線画像・彩色画像に、上書きインポートされた場合の更新結果が表示されない(1.2.5.3 fix)
        • 上書きインポートで画像を更新したにもかかわらず、インポート前に開かれていた実線画像・彩色画像が更新されませんでした。

    • カット袋ワークスペースのバグ

      • 前回起動時にカット袋にしておいたフォルダが移動または消失した際に、Windos95をフリーズさせてしまうバグ(1.2.5.4 fix)
        • あるはずのフォルダが消えてしまったときに起こる。(1.2.5.3では、不完全でした)

    • スポイトパレットのバグ

      • 前回起動時に表示しておいた画像が移動または消失した際に、Windos95をフリーズさせてしまうバグ(1.2.5.4 fix)
        • あるはずのファイルが消えてしまったときに起こる。

    • カラーピッカーのバグ

      • スライドバーおよびカラーバーをクリックまたはスライドさせた際に、使用色が変更されなかったバグ(1.2.5.4 fix)

    • 編集時のバグ

      • 「全て保存」コマンドで、「実線画像」が保存できないバグ。(1.2.5.1 fix)
        • 「全て保存」のボタンで更新中の「実線画像」を保存できない。
        • 「彩色画像」は保存できます。
      • 実線画像が白一色の場合に強調表示すると、"LEADエラー 空きメモリが不足しています" と出ます(1.2.5.2 fix)
        • 特殊の場合ですが。実線を使わず、全色トレスにしたいと考え、実線画像を白紙にしたときに起こります。
        • 全色トレスの場合は、実線画像を白紙にするのではなく、実線画像のファイルを削除したほうが効率的です。
      • [ファイルメニュー>自動ファイル検索>直前の画像を常に閉じる] のフラグが次回起動時まで保存されていないバグ(1.2.5.3 fix)
        • F11 や F12 キーを使い前後の番号の画像を開く時に、上記のメニューで直前の画像を常に閉じることができます。
        • この設定が、AniLaPaintを再起動するとリセットされてしまいます。
      • 編集中に画像の位置が左上に移動してしまう不具合。(1.2.5.3 fix)
        • mfc42.dllCのバージョンによっては、このような現象がおきます。MFC ver6.0 の DLL がなぜか、 mfc42.dll というファイル名で出荷されているので、MFC ver4.2 を使用していた多くのソフトでdllとのちぐはぐが起きて異常な現象を起こします。
        • これは、プログラムのバグではなく、システムのバグですが、一応対処しました。

    • ビルド時のバグ

      • 画像を更新したのに、ビルドされない時がある(1.2.5.3 fix)
        • カット袋からビルドする時には起こりませんが、[ツールメニュー>セル画像の一括更新ビルド]をおこなうときに起こります。
        • ビルドはディスク上の画像に対して行ないますが、編集した画像がまだ保存されていないときはビルドされません。
        • カット袋でのビルドと同様に、編集画面を全て保存するかどうかユーザに問い合わせ、保存するを選択した場合のみビルドが開始されるようにしました。
      • すでに表示されているセル画像・マスク画像に、ビルドの更新結果が表示されない(1.2.5.3 fix)
        • ビルドによってセル画像・マスク画像が更新された場合、すでに開いているセル画像に結果が反映されていませんでした。

    • エクスポート時のバグ

      • エクスポート時のダイアログに、「中止」ボタンで中止できないときがある。(1.2.5.1 fix)
        • 中止ボタンはＡセルからＢセルへ切り替わるときのみしか効きませんでした。

    • フィックスされていないバグ

      • 実線画像がインポート時に薄かった場合、ビルドで実線の中に黒いドットが混じる
        • 実線画像は、濃い目にインポートしてください。これは、ビルドのプログラムでは、実線上の色判定不能の点を、純粋の黒としてしまいます。
        • 薄い実線の場合、黒いドットが出てしまうために、出来上がりがにギザギザな線になってしまいます。
      • エクスポートで、PICT を選んだとき、生成された画像がおかしい。
        • AniLaPaintでは、LEADTOOLS の PICT セーブ機能を使っていますが、どうやらこのルーチンが不正なファイルを作っているようです。LEADTOOLS自体のバグなので、当方は対処できません。
        • 無論、このPICTが正常に読めるソフトも存在するようです。
        • 対策……エクスポート後に使うソフトでこのフォーマットがちゃんと読めるようなら使ってください。もしそうでないなら、別のフォーマットを使うか、「外部コンバータによる変換」機能により PICT に変換できるコンバータを自分で用意して使用してください。


[1999/06/01] ver1.2 β5.5

  • 修正されたバグ

    • カット袋ワークスペースをルートフォルダにも作れるようにした

      • 通常ドライブのルートディレクトリや、ネットワークコンピュータのルートフォルダにカット袋ワークスペースを置くことができなかったバグをフィックスしました。
      • 画面のプロパティで大きなフォントを選択しても表示が乱れないようにした
      • 大きなフォントを選択時に、画面のすべてのダイアログの文字やコントロールなどがリサイズされずに、互いに重なり合ってしまうために表示が乱れるバグをフィックスしました。

    • 「画面のプロパティ」の設定でディスプレイを 24bit フルカラー以外で使用すると、ペイント情報バーの「ビン」や「消しゴム」などのボタンの部分がうまく表示されなかったバグを修正。 (Build May 29)

    • メニューがOSによっては、重なって表示されてしまうバグを修正。 (Build Jun 1)

  • 追加された機能

    • カラーピッカーの反応速度や操作関連の改善

      • 常に、数値データを書き換えているなど、不必要な処理で反応が遅かった
        → 内部的なコードを改善して、以前より速くした。
      • グレースケールのカラーピッカーが無い
        → カラーピッカーにグレースケールモードを追加した。
      • 数値入力中にカーソルキーを押しても、画面のスクロールのほうにまわってしまう
        → 数値入力中のカーソルキー有効にした。
      • 数値を入力しても、カラーピッカーが更新されない。（カレットの移動のみに更新される仕様）
        → 数値を変更した後、無入力状態（２秒程度）があれば、自動的にカラーピッカーが更新されるようにした。
      • 直前の色との比較をしながらの色の選択ができない
        → 色を選択中に直前の色との比較ができるようにした。

    • メニューの改善

      • 開いた画像によってメニュー構成が変化するのはわかりにくい
        → 常に一定のメニュー構成とし、使えない機能を淡色表示とした。
      • メニュー構成が一般的でなくわかりにくい
        → 要望の多かった PhotoShop に似たメニュー配列に変更した。
      • 最近のソフトは、メニューにアイコンが付いているので、ボタンのアイコンを覚えやすいのだが・・・
        → メニューにアイコンを表示するようにしました。
        （※ 画面のプロパティでメニューのフォントサイズを変更してもこの部分は変更されません）
      • インポートでは分かり難い
        → インポートを「新規作成」という名前に変えた。

    • ツールバーの改善

      • 最近のソフトは、フラット形式のボタンでかっこいいのだが・・・
        → フラット形式にしました。（これによって IE4.02 以上の環境でないと動かなくなりました）
      • ツールウィンドウの表示・非表示をボタンから行えたら・・・
        → 「スタンダード」ツールバーに追加しました。
      • 最初に起動したときに、あまり使わないボタンまで表示されて分かりにくい
        → 初回起動時に必要最小限のボタンしか表示しないようにした。

    • ペイント情報バーの改善

      • ペン幅の入力が、ウィンドウを開くごとに初期化されて10にもどってしまう
        → ペン幅の入力をウィンドウ毎ではなく、一元化した。さらに、「実線画像」と「彩色画像のペン」と「彩色画像の境界線ペン」の３つのペン幅を記憶するようにした。
      • 選択色や背景色の表示がただのインジケータに過ぎない
        → 選択色・背景色をボタンにして分かりやすく「絵の具ビン」のアイコンと「消しゴム」のアイコンとした。さらに、境界線色のボタンも追加して、この３つの色アイコンから選択できるようにした。（現在は使えるツールが限定されています）。また、タッチペンのボタンはオン・オフのトグルとして、このボタンが押されている間には、３つの色アイコンを変更して、全ての色をタッチペンの色として使えるようにした。
      • ウインドウ画面が狭いと、ペイント情報バーが全て表示されない
        → IE4.02 のクールバーを採用することによって、画面が狭いと２段表示になったり、表示の順番をドラッグでずらすことが可能になった。また、必要な情報だけを表示するようにした。

    • ペイントツールバーの改善

      • 境界線ペンやタッチペンモードに切り替えたときに毎回、ペンの色を聞いてくるのがわずらわしい・・・
        → 「このダイアログは普段は表示しない」にチェックすると、同じボタンを２度押した場合のみ表示するようにした。
      • フォルダ選択ダイアログの改善
      • フォルダ選択ダイアログが、いちいちマイコンピュータにもどってしまう
        → それぞれ（カット袋や新規作成やエクスポートなど）の現在選択中のフォルダ位置を初期表示することとした。何も選択されていない場合はマイコンピュータ位置を表示。

    • 左クリックをスポイト機能に

      • 他のソフトでは左クリックでスポイトなのに・・・
        → 環境設定（プロパティ）のなかの表示メニューに、左クリックを従来の「コンテキストメニュー」ではなく、スポイトにする設定を追加した。

    • 新規作成（インポート）時に自動的にカット袋を開く

      • 新規作成（インポート）後、わざわざ毎回カット袋を開くのがわずらわしい
        → 新規作成（インポート）時に自動的にカット袋を開きます。また、インポート中にカット袋のサムネイルも更新していきます。ただし、新規作成時にはパレットファイルはリンクされません。（手動でリンクしてください）


[1999/06/23] ver1.2 β5.6

  • 修正されたバグ

    • 実線画像にペンで実線を追加するときに、強調モードで実線が引けないバグ

      • 強調モードでも実線を引けるようにしました。

    • セル画像の更新ビルド時に、実線が薄いと黒のドットが入ってしまうバグ

      • 近隣の色を探してトレス線を削除しますが、その作業で色が見つからなかった場合、実線の下の色を黒にしていました。濃い色の実線で今まで使用されていた方は、気が付かなかったと思いますが、あえて薄い実線を付けようとすると起こっていました。
      • 今回のバージョンでは、色の判定不能な点は、もっとも暗い実線の色をプログラムで判定して使うようにしました。これで、薄い実線画像であっても、きれいにセル画像が作られるはずです。

  • 追加された機能

    • 起動に関する改善

      • 必要な OCX や DLL が無くて起動できない場合エラーメッセージを出す
        • 例えば LEADTOOLS OCX が無かったり comctl32.dll のバージョンが古かったりすると、今まではダブルクリックをしても、起動しませんでした。その際エラーメッセージも何も表示しませんでした。これを表示するようにしました。

    • セル画像のビルドに関する改善

      • ビルドに必要なメモリ容量を３分の１に
      • ビルドのアルゴリズム改善で速度アップ
      • ビルドのパラメータを設定可能に
        • パラメータをいじって、計算をもっと省略して速度アップにつなげたりできます。
        • 色カーボンへの対応。
        • CoreReTas 用の２値の画像の出力への対応など。

    • エクスポートの改善

      • ２４ビット出力時に、マスク無しの出力ができるようにした

    • ペイント情報バーの改善

      • 背景や境界線ペンの変更をプルダウンメニューにした

    • ペイントツールの改善

      • 折れ線・多角形・多角形塗りつぶしのツールを追加

    • アイコンパレットの改善

      • 名前の変更時に色も変更できるようにした
      • ＣＳＶ形式のファイルから読み書きができるようにした


[1999/10/25] ver1.2 β5.7Preview1～6

履歴

β5.7 Preview1 99/09/16
β5.7 Preview2 99/10/01
β5.7 Preview3 99/10/11
β5.7 Preview4 99/10/17
β5.7 Preview5 99/10/20
β5.7 Preview6 99/10/25

β5.7で大幅にGUIが変更され、取扱説明書の制作が追いつかなくなり、したがって、新規のユーザ向けではなくなったので、Preview版ということにした。

  • 修正されたされたバグ

    • 「ゴソゴソ」等ように、\エンと同じ文字コードを含む２バイト文字列の名前の（カット袋）フォルダに対してAniLaProject.datが書き出されないバグ。

    • 編集中のカット袋の名前を表示するボックスで、パスの途中のスペース以降が表示されません。

    • カット袋を開くと、作業時や終了時に一般保護違反が起きる。

    • カット袋のパレットを読み込み時に、一般保護違反が起きる。

    • 色を表示するボックスが現れますが、ここで閉じ括弧がダブっています。

    • カット袋の色アイコンのダブルクリックで出る [色の設定] ダイアログで、HSV・RGB のアクセラレータキーが設定されているのに効かない。

    • ダイアログのアクセラレータキーが 重複指定部分がある。（全てのダイアログを確認し、新たにアクセラレータキーを追加しました。）

    • ダイアログの文字が、「画面のプロパティ」「大きいフォント」使用時に全て表示されないバグ。

    • カット袋の色パカチェックで、拡大時にスクロール位置が左上にリセットされてしまうバグ。

    • メニューが更新されていないところがある。

    • メモリ不足などのエラー対策処理が間違っていたバグ。（「カット袋」「ペイント編集」の部分のみのフィックス）

    • NTの場合メニューの縦幅が広がってしまうバグ。

    • CSV への色アイコンの読み書きのルーチンでファイルの後ろにゴミが付いてしまうバグ

    • 新規作成時、２値化の設定ダイアログでエディットボックスの数値を変更後[Enter]や[Alt+N][Alt+B]を押すと、プレビューの画面などが、次のページにも表示されてしまうバグ

    • 新規作成時、実際には作成しない番号のスキャン画像まで一端ロードしてしまうために、時間的ロスが生じるバグ

    • 新規作成時、[黒しきい値]を使うと、「実線画像」に白いプチプチ穴ができてしまうバグ

    • セル画像のビルド時、β5.6 では、色トレスが背景との境界の場合、マスクの縁にアンチエリアスがかからないバグ(β5.5までは正常)

    • セル画像のビルド時、β5.6 では、実線の塗り面側のマスク部分に抜けができてしまうバグ(β5.5までは正常)

    • ペン幅１ドットの鉛筆ツールで彩色しているとき、保護領域をドラッグしてまたぐと、継続してペイントできない。また保護領域内からペイントをはじめてられない。(β5.7 Preview 1～5で発生)

  • 追加した機能

    • Undo の最適化。

      • β5.6 までは全て非圧縮の状態で画面全体のコピーをメモリ内に持つことで、最大過去１０回前までの Undo を可能にしていました。ただしこの方法では、過去の履歴画像のために大量のメモリが消費され、メモリの少ない環境では肝心の編集操作にメモリがうまく割り当てられずメモリスワップなどが頻発するという問題がありました。
      • β5.7 では、全ての Undo 画像を、HDD 上に確保することで、メモリの無駄な消費を押さえることが出来るようになりました。また、HDD容量さえあれば、100回までの Undo が可能になります。
      • また、従来の画面全体のコピーを履歴に持つ方法に加え、差分情報を履歴に持つ方法を加えました。この差分情報の履歴の利点は、小さい範囲を塗った場合など、変更された最小四角形の差分情報のみをHDDに保存するために、ディスク容量の節約と、ディスクアクセスの高速化が実現できました。
      • （※差分情報の場合は、１つ前の画像をメモリ上に持つため、若干メモリ使用量が増えます。ただし、複数の編集ウィンドウを開いても、非アクティブなウィンドウでは１つ前の画像はメモリから削除されていますので、全体で常に１つ分の画像メモリしか必要ではありません。）
      • さらに、400MHz以上の速いマシーンをお使いの方には、それらの履歴を圧縮してディスクに保存することで更なるディスク容量の節約も可能です。
      • これらの設定は[ﾌｧｲﾙ(F)]→[環境設定(P)]→[Undo]の中にあります。初回起動時には、Undo回数 1 回、Undo情報 複製、保存場所 指定フォルダとなっております。指定フォルダには Windows のテンポラリフォルダが指定されていますが、これは、出来るだけ速いドライブに変更してください。存在しないフォルダ名を指定した場合、[OK]を押した時に、新しくフォルダを作るかどうかたずねてきますので「はい」を選択してください。
      • Undo画像データは ~UD + [16進数] +.TMP という名前のファイル名となります。圧縮しないばあいはBMP 形式で 圧縮した場合はPSD 形式で保存されています。Undo情報を「複製」にしておいた場合のみ、なんらかのトラブルで AniLaPaint が一般保護違反で終了した場合など、ここに履歴が残っていますので、そこから復旧することも出来ます。ﾌｧｲﾙの作成日時がもっとも新しいものが最新の情報です。
      • （これは裏業です。将来は、エラー終了時の自動復帰機能を付けるつもりですが、それまでの間はこれを利用してください・・・。）

    • ペイントツールの最適化。

      • ペイントツールのプログラムは、全て白紙から書き直しました。無駄な処理などが減っているのと、適切なエラー処理を書き加えました。
      • β5.6 から、ツールと[色選択]のボタンを切り離しています。[色選択]には左から[ペイント用の色][背景色（消しゴム）][境界線色]です。（[境界線色]は線を引く以外は使用しないでください。バケツで面を塗るとビルドが遅くなります。）
      • (ブラシを除く)全てのツールで消しゴムが使えるようになりました。
      • 新たに、[ﾂｰﾙ(T)]→[自動選択ツール(W)]と[ブラシツール(B)]を付け加えました。
      • [自動選択ツール]は、クリックした場所の同一色の連続範囲を選択するものです。以前の[境界内ペン]は、このツールとの組み合わせで可能になります。
      • [ブラシツール]は、周りがぼけたペンです。これは、機能上[境界線]や[背景色]の上には引けないようにしてあります。色も[ペイント用の色]のみ可能です。（実線画像の場合は逆です）

    • タッチペンに代わる色保護機能

      • β5.7では、以前の[色シールド]機能と[タッチペン]の機能が統合され[色保護]として、一元的に管理されるようになりました。
      • β5.6 にあった、タッチペンボタンは無くなり、[色保護(C)]メニューがこれを代行します。クールバーにも[色保護]が表示されます。
      • 普段は[境界線]が保護されています。これは[色保護(C)]メニューの[有効(Y)]が押されている状態です。以前のタッチペンのような、境界線に色を塗る場合には、[反転有効(R)]を押すことで実現できます。
      • これは、通常の色保護の反転だとお考えください。ですから、[ﾂｰﾙ(T)]→[色保護ツール(C)]で、色を保護した状態の反転状態となります。色を保護していない場合は、[境界線]のみ保護されているために、[反転有効(R)]で[境界線]のみ保護されていない状態となり、タッチペンの効果が実現できます。また、[無効(N)]では、全ての色を保護しません。
      • 以前のタッチペンはあくまでペンの機能のみでした。そのため、境界線にそってマウスでなぞる必要がありました。今回のバージョンからペイントツールと色保護を分離されたことで、[境界線]に色を塗るツールは、ペンには限りません。
      • [ﾂｰﾙ(T)]→[塗りつぶしツール(K)]→[フリーハンド範囲(F)]のツールを使い、境界線をマウスで囲むように動かして、タッチペンの効果を素早く出すことも可能です。連続した範囲ならば、バケツなどを使うことも出来ます。
      • （ただし、ブラシは半透明なので[境界線色]や[背景色]の上には塗れません。）
      • [境界線色(L)]では、境界線の色毎に保護を設定することができます。[設定色(C)]→[全て解除]は、以前の[色シールド解除]です。保護を設定した全ての色を解除します。
      • 境界線の状態が変わった場合、[保護領域の更新(U)]を押して、新しい保護の状態へ更新してください。

    • 選択範囲の強化

      • 色保護の他に、範囲選択による保護機能があります。今回追加した機能は、一時的に選択範囲を無効にするために[選択範囲(S)]→[無効(N)]メニューを追加しました。
      • また、[全て選択する(A)]や[選択範囲の解除(D)]や[選択範囲の反転(I)]を追加しました。
      • また、[自動選択ツール]を加えました。
      • 選択範囲を、追加、削除する機能を追加しました。
      • [Shift] キーを押しながらドラッグすると、範囲の追加となります。
      • [Alt]+[Ctrl] キーを押しながらドラッグすると、範囲の削除となります。クールバーの[選択範囲]のボタンに、キーを押さない標準の範囲指定モードをあらわす十字ボタンが３つ並んでいます。

    • 新規作成時の２値化の設定ダイアログの強化

      • 初回アクティブ時に、一番若い番号のスキャン画像を自動ロードするようにしました。
      • 「彩色画像」の作成時にしか働かなかったゴミ削除機能を、「実線画像」の作成時にも働かせるようにした。
      • ゴミ削除機能は、「彩色」「実線」個別に働かせることができるように、チェックボックスを追加しました。
      • ※ AniLaPaint では彩色画像にゴミがあっても、ビルド時に大概は消去されます。したがって、「実線」のみにチェックを付ける方が良いと思います。
      • エディットボックスに数値を入力では、プレビューの即時更新が効きませんでしたが、0.8秒入力が無いとプレビューを自動更新するようにしました。
      • 「スキャン画像」「彩色画像」「実線画像」の３つの画像を横に並べて表示するモードを追加しました。[Alt+6]キーか「窓 拡大/縮小」ボタンを押すことで状態が変化します。
      • （※拡大する場合、画面が小さいとはみ出てしまうことがあります。）
      • プレビューするセル番号を選択してあっても、別ページに移動して戻るとＡセルに戻ってしまいましたが、状態を保持するように仕様を変更しました。

    • ファイルメニューに 「最近使ったファイル(F) >」「最近使ったカット袋ワークスペース(R) >」ポップアップを追加。ツールバーの「ファイルを開く」と「カット袋ワークスペースを開く」ボタンにドロップダウンボタンを追加。それぞれの最近の履歴が表示されるようにした。

    • ファイルを開くで開いた(anp/anl/anc)ファイルと連動して、カット袋も開くようにした。

    • スポイトパレットバーのパレット画像を拡大するためのボタンを追加。

    • ビルドの設定で、色カーボン一覧へCSVファイルから読み込む場合、タイトル付きのCSVであっても読み込めるようにした。

    • ビルドの設定で、色カーボン一覧の「設定」ボタンに「リセット」を追加した。

    • エクスポート時に、「24bitマスクなし」を選択した時に、任意の背景色を指定できるようにした。また、背景との境界部分も実線画像のスムーズな線になるようにした。

    • 実線画像を保存する時に、彩色画像の同じ位置に追加された線の複写を促すメッセージボックスを追加。

    • カット袋の色パカチェックが速すぎて見えない。（fpsと駒数の設定を追加しました）


[1999/11/16] ver1.2 β5.7Preview7

  • 修正されたバグ

    • カット袋プロジェクトファイルにパレットファイルをリンクしていない場合、カット袋を開いた時に異常終了してしまうことがあった。

    • 色トレスが背景との境界の場合、実線を２値でビルドしようとす、背景に接するトレスラインが黒になってしまう。(Preview 6のみ)

  • 既存の問題点

    • 画像修正や彩色中に処理修了時に表示しているウィンドウがブレるときがあります。

      • 実害はありません。原因は LEADTOOLS と MFC6.0 の相性です。

    • 彩色画像の Undo/Redoで毎回、マスク領域の更新が起こる。

      • 複数前に戻る時は、一旦[色保護]メニューの[色保護領域を常に更新]をオフにしてください。

  • 追加した機能

    • セル画像の更新ビルドのオプションの変更

      • 今までの「多値(中間色)」を「多値(ペントレス)」としました。このモードでは、かぶらペンでセルに色トレスしたような色トレス線が見える感じでビルドします。
      • 新しい「多値(スムーズ)」というモードは、色の境界をよりスムーズな状態でビルドします。（これがデフォルトです）
      • 「多値」の場合の「中間色の混合の割合」の仕様を変更しました。
      • 今までは、単に境界線上の色の明暗を増減する機能でしかありませんでした。そのため、片方の色の境界が２値に近いギザギザな状態になってしまいました。
      • 新しい仕様では、明色・暗色どちらかの色に沿って境界線の幅を細くし、その部分を(ペントレス)または(スムーズ)処理を行なうことで、ギザギザな状態になりにくくします。
      • 「２値」の時「色の境界の割合」オプションを追加しました。
      • これは、今までは無条件に線の中心が色の境界になっていました。
      • このオプションによって、明色・暗色どちらかの色へ色の境界を近づけることが可能になりました。
      • 内部的に、色の判定ルーチンを強化することで、より奇麗な画質が生成されるようにしました。
      • β5.5/5.6 では、この判定ルーチンを省略しすぎたために、速くなりましたが問題も多くなりました。その反面、β5.7 では、きちんと判
      • 定するので速度は遅くなります。

    • カット袋ワークスペースでのファイル削除

      • 今回から、ファイルをごみ箱へ移動するようにしました。
      • [Shift]キーを押しながらメニューを選択すると、強制削除となります。

    • 多角形ツールのカーソル変更

      • 塗りつぶす多角形を反転表示していましたが、フリーハンドのように範囲の線だけ表示するようにしました。

    • 色保護の領域更新の仕様を変更

      • [色保護]メニューの[色保護領域を常に更新]をトグル方式にしました。
      • これが選択されている時には、境界線の変更時やUndo・Redo時に自動的に色保護領域が更新されます。このチェックを外すことで、保護領域の自動更新を一時ストップすることができます。

    • 環境設定に[編集]タブを追加

      • ここでは、システム使用色をスポイトやカラーピッカーなどで拾った場合の処理を選択できます。これを使えば、従来のようにRGB(0,0,0)などの境界線色を選択した場合に、RGB(1,1,1)などの近い色に変更することができます。（デフォルトで変更するようになってます）

    • ファイルを開いた時の背景色の設定

      • β5.7 Preview6 までは、初回起動時のみに環境設定で指定した背景色で開くようにしていました。
      • これを、従来のように、常に環境設定で指定した背景色で開くように変更しました。
      • なお、今開いている画像と同じ背景色で開きたい場合もあると考えて「但し、既に別の彩色画像が開いている時は、その背景色を使う」というチェックボックスを環境設定に追加しました。

    • 元に戻す機能の停止を追加

      • [編集]メニューに「元に戻す機能の停止」を追加しました。
      • これが選択されると、全てのビューでUndoができなくなりますが、反面、ペイント速度は速くなります。Undoの必要が無い場合に有効な機能です。


[1999/11/17] ver1.2 β5.7Preview8

  • 修正されたバグ

    • カット袋ワークスペースのファイル削除時に一般保護違反

      • Shell32.dll のバージョンが古いと起こります。(Win95/NT4 でIE4のShell融合をしていない場合)
      • 古いバージョンの Shell32.dll でも正常にごみ箱へ移動できるようにしました。

    • 選択色がウィンドウの切り替えによって変わってしまう

      • セル画像や一般の画像ファイルを開いて、スポイトで色を拾っても、彩色画像のウィンドウに戻すと、選択した色が戻ってしまうバグを修正しました。

    • メニューのフォントが大きいと文字が切れてしまうバグ

      • ちょっと縦幅を広げました。


[1999/12/12] ver1.2 β5.7Preview9

  • 修正されたバグ

    • セル画像のマスク表示で手のひらカーソルがでないバグ

  • 追加した機能

    • セル画像のビルドのオプションの変更

      • 色トレス線の細線化オプションを付けた。
      • 色トレス線の判定時に角の強調オプションを付けた。
      • デバッグビルドをするための、部分処理禁止オプションを付けた。
        • ※これらのオプションを変更しても[ビルド]では、ファイル日時による更新ビルドなので、更新されないセル画像があります。オプションを変更後、全てを新しいオプションでビルドしたい場合は、リビルドを行ってください。

    • [リビルド]を追加。

      • これは、カット袋で選択したものがあれば、そのファイルの作成日時に関係なく、再ビルドするコマンド。もし、選択したものがなければ、カット袋全体のセル画像を再ビルドする。

    • [ビューの画像のビルド]を追加。

      • 現在のビューに関係するセル画像を再ビルドするコマンド。

    • [クリーン]を追加。

      • カット袋のセル画像を全て消去するコマンド。

    • メニューの更新。

    • カット袋の下に良く使うコマンドはツールバーとして追加。


[1999/12/18] ver1.2 β5.7Preview10

  • 修正されたバグ

    • 最近のファイルを開こうとすると一般保護違反が起きるバグ（重要）

      • Preview9 のみで起こります。プログラムに一行余計な行をいれてしまったため。

    • 色アイコンを他の分類へ移動すると、色がおかしくなるバグ（重要）

      • β5.5以降の全てのバージョンで起こります。原因は、VC4 と VC6 のコンパイラの仕様の違いによるものです。

    • ビルドをバックグラウンドで行う時に、選択不可能なるべきメニューがならないバグ。

      • ビルド・エクスポートなどの処理は同時に行えないので、ビルド中はメニューを選択できないようにすべきでした。

    • 対応する彩色・実線画像が無いのに現在のビューの画像をビルドが選択できてしまうバグ。

      • 何もビルドできないのに、選択できるのはおかしいので選択できないようにしました。

    • ビルド中にアイコン化ボタンを押した場合の処理が違うバグ

      • Preview 9 で、ビルド中にアイコン化ボタンを押した時、バックグラウンド状態で実行の場合は従来どおり、そうでない場合はメインウィンドウもアイコン化するようにしたつもりだったが、動作が全く逆だった。

    • ビルドのウェイトのかけ忘れのバグ

      • バックグラウンド実行の場合、表でペイントしやすいように裏のビルドにウェイトをかけていたが、Preview 9 でビルド部分を全面的にリライトした際に入れ忘れていた。
      • ただし、β5.6まではかなりウェイトを入れて、バックグラウンドのビルドやインポートが遅くなりすぎていたが、今回はウェイトをかなり減らした。10000 から 5 に。どうやら、今までSleepの意味を取り違えていたようだ。5でも十分ストレスなく塗れる。バックグラウンドでない場合は3なので、裏のビルドも少し遅い程度で使える。

  • 追加した機能

    • バッチビルドにバッチリビルドの追加

      • 複数のカット袋でのリビルドコマンド。

    • 色アイコンの移動コマンドに「複製」チェックマークを追加。

      • 別の分類にコピーを作ります。

    • 色アイコンのコマンドのアイコンを変えた。

    • Preview 9 の EXE には、デバッグ情報を付けたままだった。


[1999/12/20] ver1.2 β5.7Preview11

  • 修正されたバグ

    • 色アイコン追加・変更・削除時にビューのスクロール位置が(0,0)になる

      • これは、バグではありません。LEADTOOLS7とMFC6.0の相性によるものです。LEADTOOLS7はMFC4.2のみサポート対象なため、内部的にちぐはぐが起きているために起こります。上記のコマンド実行後、強制的にビューのスクロール位置をリセットするようにして問題を回避しました。

  • 追加した機能

    • 環境設定にインポート＆ビルド時のスレッドの優先度設定を追加

      • 今までは、Sleepによりミリ秒単位でウェイトをかけていました。しかしこれだと、速いマシーンでも遅いマシーンでも同様にウェイトがかかってしまい、どのマシーンでも遅くなってしまいます。今回スレッドの優先度を指定することで、一切の Sleep API を排除しました。
      • これらの設定は環境設定から行えます。

    • コンパイラの最適化オプションの再設定

      • Preview9 のコンパイラのオプションの間違いを修正するために、オプションを変更した際に、最適化オプションがリセットされていました。
      • 今回、最適化オプションを「速度優先」「インライン関数有効」にもどしてコンパイルし直しました。
      • Preview10 はこれらのオプションが無効になっていたためビルドが遅くなっていました。（上記の Sleep より、こちらの理由でてきめんに遅くなっていました。）


[2000/02/24] ver1.2 β5.7Preview12

☆試用期間を2000/12/31まで延長しました

  • 修正されたされたバグ

    • 選択範囲に関するバグ

      • 選択範囲を無効にした場合、バケツツールや、色の置き換えツールや、ブラシツールで異常な動作をするバグ。
      • 「選択範囲」メニューの「全てを選択する」が、セル画像では機能しないのに選択できてしまうバグ。
      • 「選択範囲」クールバーが、セル画像では機能しないのに表示されてしまうバグ。

    • 色の保護に関するバグ

      • 色保護ツール選択時に、境界線色を全部削除してから、境界線以外の色を保護に指定して、バケツなどの他のツールに戻した後に、色保護→設定色→全て解除が効かなくなる。また、その際に、境界線が保護状態に戻ってしまうバグ。 「色パカ・チェッカー」ダイアログの、拡大率のコンボボックスで、100% を選択しても反映されないバグ。
      • アクティブでないビューの上で、マウスカーソルが変更されないバグ。 ○「色保護」メニューが、実線画像では機能しないのに選択できてしまうバグ。

    • ビューに関するバグ

      • 複数の同じ種類のビューで、使用するツールが同じになってしまうバグ。（仕様では、ビュー毎に別々のツールを使用できることになっていました）
      • ビューが存在しない状態で色を選択しても、ファイルを開きビューが表示された瞬間に、最後に選択されていた色に戻ってしまうバグ。この際、色選択の色と、カット袋ワークスペースの色が別々の色に表示されてしまう。
      • 環境設定で、彩色画像の初期背景色を設定しても反映されないバグ。

    • 致命的なバグ

      • プログラムの内部の ID が、規格外の番地を使用していたために、将来のMFCDLLのバージョンにおいて動作不安定になる可能性がある問題点。全ID を振り直しました。これによってβ5.4のヘルプは使えなくなります。

  • 追加した機能

    • カラーピッカーが常に、ペイント標準色に同期するオプションをつけた。カラーピッカーのポップアップメニューか、ファイルメニューの環境設定の「色」で行えます。

    • システム使用色をスポイトで拾った場合に、今までは環境設定で「使用しない」を選択した場合のみビープ音を鳴らしたが、それを、システム使用色を選択した時点で、使用するかどうかにかからわずビープ音を鳴らせるようにした。ファイルメニューの環境設定の「色」で行えます。

    • セル画像のエクスポートがファイル日時の比較のみでファイルを更新するために、パラメータを変更しても上書きされない問題点。これは、エクスポートの結果報告ダイアログを付けた。

    • ヘルプに関するボタンやコマンドを使用不能にしました。ヘルプ自体が無いための一時的処置です・・・。


[2000/02/28] ver1.2 β5.7Preview13

今回は、実害の無い仕様的問題点を修正しました。

  • 修正されたされたバグ

    • カラーピッカーの色の同期の問題点

      • バグではありませんが、タイマーを使って周期的に同期させていたために、カラーピッカーで色を選択している最中も、色が標準色と同期してしまう仕様的問題がありました。これを、タイマーを使わずに実装の方法を変えてプログラムし直しました。

    • カット袋ワークスペースで色アイコンを複数選択時の問題点

      • バグではありませんが、色アイコンをマウスの左ボタンドラッグによる複数選択指定中に選択表示された色アイコンの色が次々と連続してペイント標準色に設定されるために、遅いマシーンでストレスを感じる仕様的問題がありました。これをクリック時のみにペイント標準色が設定されるように変更しました。

    • スポイトパレットの画像ファイルを開いた際に初期カーソルがズームカーソルになってしまう問題点。

      • バグではありませんが、スポイトパレットで画像ファイルを開くと必ず最初にズームカーソルになってしまう仕様的問題がありました。これは、最初にズームするパターンが多いために変更してあったのですが、やはり、ズームするには＋ボタンを押せばよいので、元に戻しました。

    • スポイトパレットの拡大表示時のドラッグのバグ

      • 拡大表示の時に画像をドラッグすると、手のひらカーソルで画像がスクロールするのですが、このとき、水平・垂直にドラッグするとスクロールされないというバグがありました。


[2000/08/11] ver1.2 β5.7Preview13.4

MLのみで公開したバージョン

●　このバージョンから２値化の設定ファイル(*.asp)のフォーマットが変わりました。そのため、このバージョンで出力した asp ファイルを以前のバージョンで読み込むと、一般保護違反が起きプログラムが停止する恐れがあるので、ご注意ください。なお、β版の AniLaPaint独自仕様のバイナリーファイルは、決して配布などはしないでください。よろしくお願いいたします。

●　Preview13 からフィックスされた問題点
(Preview 13.1 2000/07/01)
・しおり機能で、AniLaPaint画像以外を表示させたウィンドウの切り替え時に画面が更新されないバグ(13.1)
(Preview 13.1 2000/07/21)
・VisualStudio6のSP4アップデータが今月出たので、その環境でコンパイルしました。MFC関連のライブラリも更新されていたので、内部的にバグフィックスされているようです。（おそらくWin2000対応とかだと思うけど)

●　Preview13 から追加した機能
(Preview 13.1 2000/07/01)
・新規作成(インポート)ウィザードの表にスキャン画像を追加する時に、常にファイル名に応じたソートを自動で行うことに変更した。
・ビューやダイアログバーのウィンドウのタイトルバー（キャプションバー）をダブルクリックすると、ウィンドウがタイトルバーだけの状態になる機能を追加しました。環境設定で変更可能。（Macを併用している人には便利かも)(13.1)
・マウスカーソルの形状を、＋だけに設定できるようにした。バケツなどの絵を表示せずに、全部選択範囲の設定時に表示されるカーソルで表示する。環境設定で変更可能。これも、PhotoShop使いの方からの強い要望で実装しました。
(Preview 13.1 2000/07/02)
・エクスポートに32bit圧縮TGAファイル出力を追加。これは以前から要望があったけど単に英語を読むのが億劫でサボっていただけです。
(Preview 13.1 2000/07/06)
・色の置き換えツールに、色の連続領域のサイズにより色を置き換えるかどうかのオプションをクールバーに追加する事にした。左のドロップダウンリストで３つのタイプの適応領域判定が可能。
「適応領域 [////] [全ての領域 ▼] 」
「適応領域 [ 3] [ピクセル以上の連続領域▼] 」
「適応領域 [ 3] [ピクセル以下の連続領域▼] 」
(Preview 13.1 2000/07/21)
・新規作成(インポート)ウィザードの２値化の設定ダイアログの、ゴミ削除機能を強化した。今までは、色トレス線の周りにまとわりつくドットゴミを削除できなかったが、それらのゴミを削除する。デフォルトでゴミのサイズが3ドット程度になっているが、1280x960のサイズの動画の場合、おそらく30ドット程度までゴミとして除去すると綺麗になると思われる。また、色トレス線本来の色にそれらのドットゴミを染めることもできる。ただし、Celeron400MHzでも１回のPreviewに15秒程度はかかってしまうので、ゴミ削除のチェックボックスは、完全に色トレス線の色を正確に拾えるように、スキャン画像の補正を行った後に設定すると良い。
・完全に試用期間チェックルーチンを外したので、2001年になっても全くそのまま動きます。これは、このMLを読んでくれた人だけの特典です。（だけど、ホームページにアップデートするであろう今後のバージョンでは再び制限をつけるつもりです。)

●お詫びと訂正

個人のメールの返信や取り扱い説明などの文章で「AdobePremiere は、ver5 で始めて TGA32bit が読めるようになりました。」と書いてしまいましたが、実は、ver4　でも（いやもっと昔から）読めていたようです。聞きかじりの情報を確認せずに書いてしまい申し訳ありませんでした。AdobePremiere では、TGA32bitのマスクを有効にするには、コンストラクションに貼り付けたクリップ上で右クリックメニューかメニューバーから、透明度設定を選択して、アルファチャンネルにしてください。場合によってはマスクの「反転」チェックボックスが必要です。

●プログラム開発環境を Windows2000 に変更しました。


[2000/08/28] ver1.2 β5.7

インストーラと取扱説明書を付随できるようになったので、Preview版ではなくなりました。

  • 修正されたバグ

    • インポートの２値化オプションのゴミ削除（彩色）のバグ
      • 色トレス線の消去方法で、近くの色で置き換えるを選んでも、場合によっては削除してしまうバグ


[2000/10/16] ver1.2.5.8

最終β版

今回のバージョンアップは主に、状況依存ヘルプの対応と、LANを使った同時編集時のデータ整合性の強化です。

  • 修正されたバグ

    • インポートの「前回と同じ条件で、新規作成し直す」ボタンを押して以前のインポートをやり直そうとした場合、既にそのスキャン画像が移動または削除されていても、表に設定されてしまうため、２値化のパラメータの設定ダイアログで、エラーが表示される

      • エラーメッセージを表示して、ログファイルの読み込みを中止するようにした。その際、ログファイルのデータは何も読み込まれません。そのような古いログファイルを消去するかどうか質問に答えると削除されるようにした。

    • カット袋ワークスペースの色アイコンをテキストファイル(CSV)から読み込む場合、空行があると一般保護違反で落ちる事があるバグ

      • これはどうしても再現しなかった。どんなテキストでもちゃんとエラーチェックが通っている。なぜ一般保護違反が起きたのか不明。OSのバグかなにかかもしれない。今回から、改行のみの行や不正な行は読み飛ばすことにした。正しい行のみ読み込むことで、CSVファイルの途中からでも読み込めるように変更した。

    • パレットファイルのリンク共有のダイアログで、パスを白紙のままOKボタンを押すと一般保護違反で落ちるバグ。

      • フィックスしました。

    • con や prn などのデバイス名を指定したときにハングアップするバグ

      • このバグは、パレットファイルのリンクや、環境設定の UNDO のフォルダ指定やエクスポートのフォルダ指定で発生していた。そのような使えない文字をフォルダやファイルの名前に指定したときにエラーメッセージを表示し、指定できないようにしました。

    • 壊れた画像ファイルを読み込もうとすると、「○○が不正です」のメッセージボックスが延々と表示されつづけるという、致命的なバグ。

      • これは、例えば、インターネットからダウンロードソフトを使用して画像ファイルをダウンロードする場合などで、途中で止めたときなどに、途中までのデータしかない画像ファイルができてしまうことが良くある。このようなファイルは本来途中までなのだから、jpgなどの拡張子をつけていてはいけないのだが、実際にはそういう中途半端なファイルを作ってしまうダウンロードソフトが多い。その画像を AniLa で表示しようとすると、上記のような無限ループに陥る。このバグをフィックスした。

    • ファイルサイズ０の名前だけの画像ファイル（新規画像など）を開いたときに、エラーを表示した後、ビューを自動で閉じるようにした。

      • 今までは画像なしのビューが開いていました。

    • AniLaProject.dat(カット袋)ファイルが存在しないのに「カット袋をひらきますか？」聞いてくる仕様的矛盾

      • 表示する画像と同じフォルダにカット袋ファイルが存在しない場合は、聞いてこないようにした。

    • 空のAniLaProject.dat(カット袋)ファイルが作られてしまう仕様的矛盾

      • カット袋プロジェクトを開くで、カット袋が存在しないフォルダを指定した場合、今までは「新しいカット袋を開きますか？」と聞いてきて空のカット袋を作っていたが、その仕様は削除した。「カット袋がありません。新規作成でカット袋を作ってください」とメッセージを表示することに変更。初心者が誤って、空のカット袋を作る場合があるため。

  • 追加した機能

    • 状況依存ヘルプに完全対応となった。

      • F1 キーや、「 選択した場所の説明 クリックした場所の説明」、ダイアログの「ヘルプ」ボタンなどが使用可能になった。また、ヘルプメニューに「検索」「キーワード」などを追加した。

    • 実線画像および彩色画像のファイルロック機構追加。

      • 実線画像および彩色画像をネットワークコンピュータ間で同じファイルを同時に編集できないように、ファイルロック機構を追加した。これによって、複数人で同じカット袋のファイルに彩色する際でも、２人以上が同時に同じ画像を彩色してしまうような状態は起こらない。もし、既に誰かがその画像を編集している最中の場合は、２人目からはスポイトしか使えないモードで画像を開きます。
      • ただし、このロック機構の概念が無いソフト（例えば PhotoShopなど）とでは、ロック機構が働きません。

    • セル画像のビューで、背景との境界の線の部分をマスクの透明度を利用してアンチエリアスがかかって見える工夫をした。

      • この機能によって彩色画像と同様のインターフェースで背景色をデジタル８色のどれにでも変更できるようにした。背景との境界はその背景色が透ける形でアンチエリアスがかかって見えます。

    • 「パレットファイルのリンク」を改め「アイコンをファイルで共有」にし、CSVファイルもリンク共有できるようにした。

      • CSVのような汎用テキストデータフォーマットのまま、共有可能にした。これによって、例えば、表計算ソフトと同じファイルを共有して扱うことができる。

    • 色アイコンファイルの拡張子をaplからanila_paletteに変更した。

      • ３文字の拡張子は、他のソフトのデータ形式と一致してしまう恐れがあるため、今後できるだけ使わない方向にした。単に拡張子が変わっただけなので、拡張子をリネームすれば今までのaplファイルも使える。ファイルダイアログの「種類」の部分をaplファイルに変えることで、拡張子を変更しなくても従来どおり読み込める。

    • インポートの２値化オプションファイルの拡張子をaspからanila_importに変更した。

      • asp 拡張子が、インターネットなどで一般的な拡張子になってしまったので、２値化設定のオプションファイルとしての拡張子としてはふさわしくないので変えることにした。単に拡張子が変わっただけなので、拡張子をリネームすれば今までのaspファイルも使える。ファイルダイアログの「種類」の部分をasplファイルに変えることで、拡張子を変更しなくても従来どおり読み込める。

    • カット袋の自動更新機能を強化

      • 他のパソコンで同じプロジェクトファイルを開いたときに、今までのバージョンでは開いた時点では同じであっても、その間にパレットの共有条件を変化させたり、パレットの共有をやめて、カット袋ないに色アイコンを保存した場合など、複数のパソコンで同時に開いていたカット袋の内容が異なり、これによって、最後にカット袋を閉じた設定のみがファイルに残るという不具合があった。今回は、完全にそれらが常に一致するようにした。つまり、パソコンAで色を修正したら、直ちに他のパソコン上の画面にそられが現れるようにした。パレットのリンクを変更した場合も同様。互いのカット袋ワークスペースが常に同期するように10秒間隔で自動的にチェックを行い更新するようにした。

    • MRUファイルリスト、つまり以前選択したファイルの履歴やカット袋の履歴が実際に今も存在するのかどうかを、メニューやプルダウン表示の時点でチェックするようにした。

      • これによって、既に移動してしまったファイルをあやまって選択することはない。
        最近のファイル・最近のカット袋ワークスペース・最近共有していた色アイコンのファイル・最近のエクスポートフォルダ・最近のスポイトパレットに表示したファイルの全てで機能します。

    • 外部コンバーターの設定画面で、過去のコマンドの履歴を消せるようにした。

      • 「履歴を消去」ボタンで、プルダウンに表示される過去のコマンドを一気に消去できるようにした。


[2000/10/20] ver1.2.5.9

最終β版

正式版まではバグフィックスのみです。

  • 修正されたバグ

    • セル画像を開いた状態で、ビルドを行うと「不正なビットマップ」エラーが表示されつづけるバグ。

      • これは、ver1.2.5.8でセル画像のビューの表示方法変更に伴い、画像データのメモリ上での扱いが変わったことに起因します。ビルド側から、セル画像を最新のものに変更するルーチンが昔のままで、あたらしい画像データの配置方法に変えていませんでした。そのために、セル画像を開いたままビルドを行うとメモリの一部が壊れるために、上記エラーメッセージの無限ループとなります。
      • このエラーメッセージですが何度も Enter キーを押しつづけるとエラーが表示されないタイミングがあるので、そこで、セル画像のビューを閉じてしまえば、その後の処理を続けられます。このエラーの場合、AniLaPaintおよびシステム領域のメモリは壊れません。あくまで１つのセル画像のビューのメモリ領域のみ壊れます。したがって、何ら他の問題は起こしません。
      • このバグをフィックスしました。

    • ヘルプのキーワードの項目が、ソートされていなかったバグ。

      • これは、ヘルプファイルの方のミスです。


[2000/12/24] ver1.2.5.10

最終β版

正式版まではバグフィックスのみの方針ですが、多少機能を追加しました。

このバージョンから、制限期間をなくしました。くわしくは「制限事項」をご覧下さい。

  • 修正されたバグ

    • Undoフォルダの指定によってはペイント時にエラーとなるバグ

      環境設定の[Undo]の設定で、指定されたフォルダの親フォルダのいずれかに「システム」属性のフォルダがあると、ファイルを開く時や、ペイント時にエラーとなり、
      AniLaPaint Application Error

      ！
               Undo(元に戻すための画像)の追加中にエラーが発生しました

      対象　[ CUndoAniLaBitmapXorData::Save()]
      症状r [error code : -1]

      今までの Undo 情報も破損したおそれがありますので、一旦 Undo 情報をメモリから削除します。
      ([ツール]の[プロバティ]の[編集]の項目を確認して下さい)

      などのように表示されていました。また、エラーメッセージの文句が間違っていました。
      ※ Windows 98やMe の場合、AniLaPaint のデフォルトのフォルダが C:\Windows\Temp となっており、また、C:\Windows フォルダは、デフォルトで「システム」属性である可能性が高いです。そのため、何も設定しない状態でいきなりペイント時に上記のエラーが表示されました。

    • NTFSフォーマットしたドライブでAniLaPaintが異常を起すバグ

      NTFS フォーマットしたドライブを Undo 情報保存用のフォルダとして指定すると、Undo のエラーとなっていました。
      また、エクスポートするフォルダにも選択しても新規にフォルダを作成できませんでした。
      ※ Windows 2000 は NTFS フォーマットされている場合が多いので、この現象が発生しました。

    • CD-ROMなどをUndoフォルダやエクスポート時のフォルダに指定できてしまっていたバグ

      環境設定の[Undo]の設定や、エクスポート時のフォルダに、CD-ROMを指定できてしまっていた。

    • 正しくないエラーメッセージの問題点

      以下の問題点が内在していました。これらは正確にはバグとは違います。
      メモリ不足やリソース不足の場合、正しいエラーメッセージは、
      AniLaPaint Application Error
      ！
         画像処理中にエラーが発生しました。
      対象 [CPaintPen::OnPaint(CPoint pos,COLORREF col)]
      症状 [LEADエラー:メモリ不足]

      などのように表示されます。一方正しくないエラーメッセージは、

      AniLaPaint
      ×
        LEADエラー：メモリ不足
      などのように１行だけで表示されます。後者のエラーメッセージの場合、正しく内部的に処理されていないために、連続して出る可能性があります。
      正しくないエラーメッセージは、フレームワークがシステム保護のために自動的に表示しているもので、私がプログラムしたメッセージではありません。このメッセージが表示されても、私が組んだプログラムでは、エラーが起こっていることを認知していませんので、引き続き処理を続行してしまいます。そのために、エラーが連続的に表示されたり、GDIやメモリを開放できなかったりすることが起こります。
      数千行の個所の変更をし、LEADエラーに対しては全て対処いたしました。

    • Win95 OSR1 でエクスポート時に一般保護違反が起きる

      OSの互換性の問題で、エクスポート時に「ファイル日時による更新」を行うと、一般保護違反が発生しておりました。他のOSでは発生していません。

  • 追加した機能

    • 環境設定を保存する場所を、レジストリ以外に INI ファイルも選択できるようにした。

      今まではレジストリのみを使用していました。しかし、Win9x系のOSの場合レジストリの容量に制限があり、ソフトが沢山インストールされていると、この容量を上回り、システム自体が不安定になるということが考えられます。そこで、レジストリを一切使用しないモードを追加しました。
      このバージョン起動時に、その選択画面が現れますが、 Shift キーを押しながら起動して、設定を変更することも出来ます。

    • 空き容量（メモリ状況）を常に表示するようにした

      常にステータスバーに、空きメモリの容量を表示することにした。

    • カット袋メニューの色パカチェッカーを行う際に、メモリをチェックするようにした。

      • 色パカチェッカーを実行時に、実メモリが足りているかどうかをチェックするようにした。これによって、この部分でディスクスワップのために、アニメーション表示が遅くなることがなくなった。

    • セル画像の背景色変更のスピードアップ

      セル画像の背景色の変更のアルゴリズムを変更。背景色変更のスピードを速くした。

  • 取扱説明書内で変更したページ一覧

    • 第１章 はじめにお読みください

      動作環境 　制限事項 　ライセンス取得方法 　ユーザサポート 　アンインストールの方法

    • 第４章 画面の各部の説明

      色パカ・チェッカーダイアログ

    • 第７章 その他


[2000/12/30] ver1.2.5.11

最終β版

正式版まではバグフィックスのみの方針ですが、多少機能を追加しました。

制限期間をなくしています。くわしくは「制限事項」をご覧下さい。

  • 修正されたバグ

    • インポートのバグ

      • スキャン画像の選択時に複数選択すると C: 等のようにドライブのみとなってしまうバグ。
      • ２値化のオプションで、回転を0以外にするとインポートできないバグ。

    • エクスポートのバグ

      • 前回のエクスポートで、(24bitマスクなし透明キー白)だった場合、次回に設定初期値が、(24bitマスクなし背景色)になってしまうバグ。
      • 1.2.5.9以前のエクスポートの設定によっては、エクスポートできないバグ。
      • 外部コンバータの設定ダイアログで変換後の拡張子の履歴が一部のOSで変になるバグ。

  • 追加した機能

    • エクスポートの設定保存先の変更

      • エクスポートの設定は、レジストリではなく、各カット袋フォルダにexport.ini テキストファイルとして保存することにした。これによって、エクスポート先のフォルダ指定も含めた完全な、カット袋毎の前回のエクスポート値を保持することができるようになった。
      • 1.2.5.10の最後の設定を読み込みたい場合、Shiftキーを押しながら、エクスポートダイアログを開いてください。（暫定的機能）

  • 取扱説明書内で変更したページ一覧

    • 第１章 はじめにお読みください

      動作環境 　制限事項 　ライセンス取得方法

    • 第２章　入門編　>> ファイル形式について

      エクスポートできる画像(*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.ras)

      表示のみの画像 (*.anc;*.pcx;*.tga;*.png;*.psd;*.bmp;*.wmf;*.tif;*.jpg;*.jpeg;*.cmp;*.ras;*.pct)

      エクスポートオプション ファイル (export.ini)

    • 第７章 その他

      作者への連絡方法


[2001/01/13] ver1.2.5.12

最終β版

正式版まではバグフィックスのみの方針ですが、多少機能を追加しました。

制限期間をなくしています。くわしくは「制限事項」をご覧下さい。

  • 修正されたバグ

    • インポートのバグ

      • インポート時に「前回と同じ条件でもう一度、新規作成しなおす(R)」ボタンで前回の設定を読み込んだ時に、前回の設定で「欠番」を設定してあると、「前回のスキャン画像が存在しない」と表示され、開けないバグ。
      • インポート時に「欠番」を作ると、「欠番」１つあたり20byteのメモリーリークが発生していた。

    • エクスポートのバグ

      • 「マスクの透明部分」を「黒=透明/白=不透明」にするとエクスポートできないバグ。
      • 前回エクスポート時に、キャンセルなどで、8bitマスクのみエクスポートされている状態の時などに、「ファイル日時による更新」では「既存のファイルが存在」となり、エクスポートされないバグ。
      • 同じフォーマットで、32bit から 24bit + 8bit マスクに変更してエクスポートしなおしたときにも同様なことが起こるバグ。
      • エクスポート後の状況表示のダイアログの文字列に、マスクファイルに関する記述がない。
      • エクスポートの最中に、ディスク容量が無くなってしまったときに、エクスポートできていないのにあたかも完了したかのようになるバグ。

    • カット袋ワークスペースのバグ

      • カット袋ワークスペースの「色アイコン」を編集時、色を変えても「標準ペイント色」が変更前の色のままであるバグ。

  • 追加した機能

    • AniLaPaint の状態を出荷時に戻す機能の追加

      • 初回起動時または、Shiftキーを押しながら起動した場合に表示されるダイアログに、INIファイルやレジストリを「出荷時の状態に戻す」機能を追加。

    • エクスポート中のプログレスバーの変更

      • エク出スポート中のプログレスバーに、ディスク容量のバーも同時に表示することにした。なお、ディスク容量のAPIが win95 OSR1 から OSR2 の間に変わったために、内部的にOSをチェックして呼びす関数を変えるような形で実装したが、家には win95 OSR2以上しかないので、確認不可能。もしかしたら、win95 OSR1では動かなくなるかもしれない。この件に関しては報告がなければ動作しているものとみまします。

    • MRUリスト表示への機能追加

      • 「最近使ったファイル」「最近使ったカット袋ワークスペース」「最近スポイトパレットに使ったファイル」のメニューに「履歴の消去」コマンドをそれぞれ追加。

    • カット袋ワークスペースの機能追加

      • 「情報の更新を禁止」 コマンドを使い、サムネイルや色アイコンの情報更新を一時ストップする機能を追加。

    • その他の機能追加

      • DDE Execute open を使用可能にしました。これによって、エクスプローラで AniLaPaint画像ファイルをダブルクリックした時に、現在 AniLaPaint が起動している場合にはそこに開かれるようになりました。

  • 取扱説明書内で変更したページ一覧

    • 第１章 はじめにお読みください

      AniLaPaintの状態を保存する場所について

      アンケートのお願い

      アンインストールの方法

    • 第４章 画面の各部の説明

      >> メニューバー >> ファイル

      最近使ったファイル

      最近使ったカット袋ワークスペース

      >> メニューバー >> カット袋

      表示 >> 情報の更新を禁止

      >> コントロールバー >> ダイアログバー

      カット袋ワークスペース

      >> コントロールバー >> ダイアログバー >> アイコンメニュー

      スポイトパレットのアイコンメニュー

      カット袋プロジェクトワークスペースのアイコンメニュー

      >> ダイアログ >> カット袋ワークスペースに関するダイアログ >> エクスポートに関するダイアログ

      セル画像のエクスポート


第７章 その他

ホーム>>

第７章 その他

ここでは、その他の事項に付いて説明します。

転載について
著作権について
作者への連絡方法
Gif と Tiff フォーマットについて


転載について

正式版1.2.6.xが公開された後には、パソコン通信のBBSや雑誌付録CD-ROMなどへの転載は可能になります。

このバージョンは開発版なので、転載を禁止します。


著作権について

AniLaPaintおよびそのオンラインヘルプの著作権は小野木一樹が所有しております。

※AniLaPainit画面のスクリーンショットは、自由に使っても構いません。


作者への連絡方法

１） E-Mail での連絡方法

ソフトに関する質問・苦情・要望等について、いつでも受け付けております。

AniLaPaint Support
 anilapaint@jcom.home.ne.jp

不具合などについては、ユーザサポートで受け付けています。

２） Web での連絡方法

次のURLから、掲示板などを利用して連絡を取ることもできます。

おのぎん's ほ～むページ
 http://www.aaa-int.or.jp/onogin/

AniLaPaint ほ～むページ
 http://members.jcom.home.ne.jp/anilapaint/


Gif と Tiff フォーマットについて

LZW圧縮のかかったGif及びTiffフォーマットは、米国ユニシス社が特許を保有しているため、AniLaPaintでは使用できません。


送金方法

現在は、β版です。したがって、まだ送金方法はありません。

正式版がでるまでお待ちください。

なお、β版は試用期間には含まれません。